Bug 126324 - PPTX: FILEOPEN: what's shown as a past year in MSO is shown as today's date in LO
Summary: PPTX: FILEOPEN: what's shown as a past year in MSO is shown as today's date i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
: 127765 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-10 09:25 UTC by Gerald Pfeifer
Modified: 2019-11-26 10:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slide (PPTX) (1.18 MB, application/vnd.ms-powerpoint)
2019-07-10 09:28 UTC, Gerald Pfeifer
Details
This is how it looks in LibreOffice. (46.21 KB, image/png)
2019-07-10 09:29 UTC, Gerald Pfeifer
Details
This is how it looks in Office 365. (41.05 KB, image/png)
2019-07-10 09:30 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2019-07-10 09:25:29 UTC

    
Comment 1 Gerald Pfeifer 2019-07-10 09:28:12 UTC
Created attachment 152704 [details]
Sample slide (PPTX)

This slide shows a timline where every data point is associated with a year.

In Microsoft Office/Office 365, those data points read 1994, 1995, 1996, and
so forth.

In LibreOffice they read 7/9/2019, 7/9/2019, 7/9/2019 (or whatever the current
date is).
Comment 2 Gerald Pfeifer 2019-07-10 09:29:35 UTC
Created attachment 152705 [details]
This is how it looks in LibreOffice.
Comment 3 Gerald Pfeifer 2019-07-10 09:30:31 UTC
Created attachment 152706 [details]
This is how it looks in Office 365.
Comment 4 Xisco Faulí 2019-07-10 11:39:39 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 7a0164f0d82d91e2ac481d74cdacfe9a7ad6080f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

it seems more like a chart problem...

@Balazs, I thought you might be interested in this issue
Comment 5 Gabor Kelemen 2019-07-10 13:16:53 UTC
Those are not parts of the chart: you can delete the chart and the date boxes will remain.

They are date fields inserted in text boxes and formatted as 'YY' - this format we do not handle well.

I'm not sure how can one create such a format for a field in PP. 
LO only has a few fixed variants (See Insert - Fields).
Comment 6 Commit Notification 2019-10-25 18:23:38 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/df9672b1fada6fc847bfa4c8a8f016fb2af6a7b5

tdf#126324 Import custom date as custom XTextField

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-10-28 09:48:33 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: c4d760b9edf0399955d30a0dfbe5f7b1b1ed37cb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamas Bunth, thanks for fixing this issue! Can it be closed as RESOLVED FIXED ?
Comment 8 Xisco Faulí 2019-10-28 10:58:12 UTC
> @Tamas Bunth, thanks for fixing this issue! Can it be closed as RESOLVED
> FIXED ?

BTW, any chance we could have a unittest for it ?
Comment 9 Commit Notification 2019-10-29 20:16:30 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/bf10253dd556b69fa771320c986c05c653e6d220

tdf#126324 pptx unit test for custom date import

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2019-10-30 07:12:44 UTC
(In reply to Commit Notification from comment #9)
> Tamas Bunth committed a patch related to this issue.
> It has been pushed to "libreoffice-6-3":
> 
> https://git.libreoffice.org/core/commit/
> bf10253dd556b69fa771320c986c05c653e6d220
> 
> tdf#126324 pptx unit test for custom date import
> 
> It will be available in 6.3.4.

This unit test has been pushed to 6.3.4 branch while the corresponding fix has been pushed to master branch only. So the test fails as expected ;-).
Please could you revert this patch or backport the fix.

Best regards. JBF
Comment 11 Commit Notification 2019-10-30 08:09:47 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/a8a97925f79bb1859604988483168c9dded44052

tdf#126324 Import custom date as custom XTextField

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2019-10-30 08:15:36 UTC
(In reply to Jean-Baptiste Faure from comment #10)
> (In reply to Commit Notification from comment #9)
> > Tamas Bunth committed a patch related to this issue.
> > It has been pushed to "libreoffice-6-3":
> > 
> > https://git.libreoffice.org/core/commit/
> > bf10253dd556b69fa771320c986c05c653e6d220
> > 
> > tdf#126324 pptx unit test for custom date import
> > 
> > It will be available in 6.3.4.
> 
> This unit test has been pushed to 6.3.4 branch while the corresponding fix
> has been pushed to master branch only. So the test fails as expected ;-).
> Please could you revert this patch or backport the fix.
> 
> Best regards. JBF

At least we see the unittest works xD.
Pushed the fix to 6-3 too
Comment 13 Commit Notification 2019-10-30 08:20:59 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fddfbeff8a8989a1e8852d77f69f834c79eff62f

tdf#126324 pptx unit test for custom date import

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2019-10-30 14:15:19 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: 13532e63e715ab2bfd1a8040bec6f700fbfa6250
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamas Bunth, thanks for fixing this issue!
Comment 15 Jean-Baptiste Faure 2019-10-30 20:32:23 UTC
(In reply to Xisco Faulí from comment #12)
> [...]
> At least we see the unittest works xD.

Indeed :-)

> Pushed the fix to 6-3 too

Thank you very much. Build OK now.

Best regards. JBF
Comment 16 NISZ LibreOffice Team 2019-11-26 10:20:05 UTC
*** Bug 127765 has been marked as a duplicate of this bug. ***