Download it now!
Bug 127765 - Think-Cell chart shows wrong values in LO
Summary: Think-Cell chart shows wrong values in LO
Status: RESOLVED DUPLICATE of bug 126324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2019-09-25 14:23 UTC by Olaf Felka
Modified: 2019-11-26 10:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bug doc 1 (96.23 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-09-25 14:24 UTC, Olaf Felka
Details
comparison MSO 2010 and LibreOffice 6.4 Master (30.20 KB, image/png)
2019-09-25 14:41 UTC, Xisco Faulí
Details
Textbox issue (13.00 KB, image/png)
2019-09-26 07:19 UTC, Balázs Varga
Details
The example file in current 6.4 master (107.61 KB, image/png)
2019-11-26 10:18 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Felka 2019-09-25 14:23:19 UTC
Description:
Attached Presentation shows Think-Cell chart with wrong values. Given values are replaced with dates.
The PDF export is also wrong.

Steps to Reproduce:
1. Open attached bug doc in LO6.3.1.2
2. Open attached bug doc in PowerPoi8nt 2016
3. Compare

Actual Results:
Attached Presentation shows Think-Cell chart with wrong values. Given values are replaced with dates.

Expected Results:
LO shows the same values as PowerPoint


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Olaf Felka 2019-09-25 14:24:15 UTC
Created attachment 154494 [details]
bug doc 1

The bug doc for verification.
Comment 2 Xisco Faulí 2019-09-25 14:41:20 UTC
Chart values are ok, but X, Y and titles values are wrong

Version: 6.4.0.0.alpha0+
Build ID: cc65651a0490383f1a833bb6215d8ec4272d8b5d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-09-25 14:41:43 UTC
Created attachment 154495 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 4 Xisco Faulí 2019-09-25 14:42:54 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Xisco Faulí 2019-09-25 14:44:34 UTC
@Balazs, I thought you might be interested in this issue, at first glance it seems an easy fix for you, now that you are a chart expert ;-)
Comment 6 Balázs Varga 2019-09-26 07:19:46 UTC
Created attachment 154513 [details]
Textbox issue

Thank you very much, Xisco. :)
But as I see it, this is not a chart BUG, but a textbox issue.
There's a chart, but there are text boxes around it. The problem occurs, without the chart too.
Comment 7 Xisco Faulí 2019-09-26 07:24:31 UTC
oh, good point, didn't check it when I triage the bug. thanks a lot!
Comment 8 NISZ LibreOffice Team 2019-11-26 10:18:47 UTC
Created attachment 156122 [details]
The example file in current 6.4 master

This seems to have gotten better (as the labels are imported correctly, but not as modifiable time/date fields) in:

Version: 6.4.0.0.beta1+ (x64)
Build ID: 1aa0e52f70e62022cffb499a609ac2def6245166
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 9 NISZ LibreOffice Team 2019-11-26 10:20:05 UTC
Bibisecting with bibisect-win64-6.4 shows this is a result of the fix to bug #126324

*** This bug has been marked as a duplicate of bug 126324 ***