Bug 126490 - FORMATTING: Row height not reduced for small fonts
Summary: FORMATTING: Row height not reduced for small fonts
Status: RESOLVED DUPLICATE of bug 83568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-21 05:08 UTC by Daniel Collins
Modified: 2021-09-01 12:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Collins 2019-07-21 05:08:10 UTC
Description:
Row heights are automatically set to large values if the font size is set to a large number. However, smaller-than-normal font sizes do not reduce the row height below the starting value.

Steps to Reproduce:
1. Make a new Calc file. 
2. Select all the cells. 
3. Observe start font size 10 (row height 0.18"). 
4. Set font size to 14 (observe row height 0.24").
4. Set font size to 6 (observe row height 0.18"). 

Actual Results:
Font size 10 and any smaller font size all generate the same row height (0.18"). 

Expected Results:
Smaller font sizes (e.g., below 10) should generate correspondingly smaller row heights (symmetric with large font sizes generating larger row heights). 


Reproducible: Always


User Profile Reset: No



Additional Info:
The steps above use direct formatting of the cells; the same behavior is seen if we modify font size in the styles (including default style). Manually selecting Optimal Row Height also does not change the row height from these results. 

As a consequence, if the user wants to fit more rows on a page using a small font, then we must manually determine and set an appropriate row height for that purpose.
Comment 1 raal 2019-07-21 05:52:43 UTC
Hello,

Thank you for submitting the bug. The bug has previously been reported, so this bug will be added as a duplicate of it. You will automatically be CCed to updates made to the other bug.

*** This bug has been marked as a duplicate of bug 95420 ***
Comment 2 Timur 2021-09-01 12:30:09 UTC

*** This bug has been marked as a duplicate of bug 83568 ***