Bug 95420 - Optimal row height not determined correctly for small font rows
Summary: Optimal row height not determined correctly for small font rows
Status: RESOLVED DUPLICATE of bug 83568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-10-29 17:37 UTC by Hayo Baan
Modified: 2021-09-01 12:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample spreadsheet with rows of different font sizes (8.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-29 17:37 UTC, Hayo Baan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hayo Baan 2015-10-29 17:37:08 UTC
Created attachment 120080 [details]
Sample spreadsheet with rows of different font sizes

When you use a smallish (<10pt) font for a row in Calc, the optimal row height is not shrunk accordingly, but stays fixed at the default. For larger font sizes this works fine. Worse, existing spreadsheets with correct row heights change back to the larger size when you enter/change cell values.

I have attached a simple spreadsheet exhibiting this problem.

Note: OpenOffice works fine in this case.
Comment 1 Joel Madero 2015-10-30 04:01:16 UTC
Bodhi 3.x
LibreOffice 5.0.2.2 release - if you can test older versions and report back that would be great (http://downloadarchive.documentfoundation.org/libreoffice/old/)


Setting to:
NEW
Minor - can slow down but won't prevent high quality work;
Low - easy workaround (manually set)

It's a little unclear if the second thing mentioned is a separate issue - if it is it should be reported separately.

In the future please don't report bugs against master without testing a stable release first as "version" is oldest version the bug is on so master should only contain regressions.
Comment 2 Hayo Baan 2015-10-30 08:10:41 UTC
Hi Joel, thanks for looking into this.

(In reply to Joel Madero from comment #1)
> Bodhi 3.x
> LibreOffice 5.0.2.2 release - if you can test older versions and report back
> that would be great
> (http://downloadarchive.documentfoundation.org/libreoffice/old/)

I downloaded and tested this against the 4.4.6.3 release just now too and it exhibits the same behaviour. If you want, I can easily test other versions too.
 
> Setting to:
> NEW
> Minor - can slow down but won't prevent high quality work;
> Low - easy workaround (manually set)

(though it becomes quiet cumbersome to do this for hundreds of rows…)

 
> It's a little unclear if the second thing mentioned is a separate issue - if
> it is it should be reported separately.

I'm sure this is actually one and the same issue, updating a cell just triggers libre office to re-evaluate the optimal row height.

 
> In the future please don't report bugs against master without testing a
> stable release first as "version" is oldest version the bug is on so master
> should only contain regressions.

Oops, I selected the wrong version; I was using the latest stable version (5.0.2.2)

Hope this is an easy thing to fix as most of my spreadsheets have these smaller font size rows (to cram more info on them)…
Comment 3 Hayo Baan 2015-10-30 08:36:56 UTC
I tested some more versions:

v3.3.0 Fully OK (row height shown correctly)

v3.6.7.2 Half working OK. Initially the spreadsheet is shown with the rows too high. Manually setting the optimal row height via the context menu/double clicking works correctly though.

v4.0.0.1 Same bad behaviour as in 5.0.2.2
v4.4.6.3 Same bad behaviour as in 5.0.2.2
Comment 4 Joel Madero 2015-12-14 01:40:43 UTC
I had to skip a couple commits because of other issues so it's not perfect but hopefully it gives some guidance.

Also upping to Medium because it's a regression.


There are only 'skip'ped commits left to test.
The first bad commit could be any of: c9046ea7e069426d10e071d0bcb01c64685844c6 2d8ee8e5bf8901874460df1b36b3faceae1cb931
We cannot bisect more!

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect skip a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect skip 3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3
# bad: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
git bisect bad 4f705a8cfb1998b09f2062510b207d35a33647d8
# bad: [3c72d6d27e2a0c420f74941355400b0834c550bb] source-hash-c30677731c55688c764a669ecea1b1c4d17ae57d
git bisect bad 3c72d6d27e2a0c420f74941355400b0834c550bb
# good: [92457a48f3715b1233ea025387627280dae681b0] source-hash-c1503da35d8879366da13258837cf0084a536809
git bisect good 92457a48f3715b1233ea025387627280dae681b0
# bad: [206506b5a81e183bfab960d6abe62489c8438daf] source-hash-47811d4cf17688b2db5910e2cd500143137fd6f1
git bisect bad 206506b5a81e183bfab960d6abe62489c8438daf
# good: [65883fecdd4e5ccd4091d0089742690dccafdbfa] source-hash-8d8a2f2be58529d70f4783d5d1e91fca350f119f
git bisect good 65883fecdd4e5ccd4091d0089742690dccafdbfa
# skip: [c9046ea7e069426d10e071d0bcb01c64685844c6] source-hash-f5115e33e4c5e49e9b79ed32fccc193a99c3dc30
git bisect skip c9046ea7e069426d10e071d0bcb01c64685844c6
# good: [e2ef0c10eb06304986b8503584b44f02561ce4b5] source-hash-1b4aadebeb1898686313ff30ef47ddc4336a7444
git bisect good e2ef0c10eb06304986b8503584b44f02561ce4b5
# bad: [2d8ee8e5bf8901874460df1b36b3faceae1cb931] source-hash-777e3930a1e85b9bc97c1852b09802fc389c5e2d
git bisect bad 2d8ee8e5bf8901874460df1b36b3faceae1cb931
# only skipped commits left to test
# possible first bad commit: [2d8ee8e5bf8901874460df1b36b3faceae1cb931] source-hash-777e3930a1e85b9bc97c1852b09802fc389c5e2d
# possible first bad commit: [c9046ea7e069426d10e071d0bcb01c64685844c6] source-hash-f5115e33e4c5e49e9b79ed32fccc193a99c3dc30
Comment 5 QA Administrators 2017-01-03 19:51:08 UTC Comment hidden (obsolete)
Comment 6 Hayo Baan 2017-01-04 10:53:27 UTC
The behaviour as described is still present in the latest (5.2.3.3) version of LibreOffice (Mac OS 10.11.6).
Comment 8 QA Administrators 2018-09-15 03:10:10 UTC Comment hidden (obsolete)
Comment 9 Hayo Baan 2018-09-15 14:58:24 UTC
Just confirmed: This problem is still present in version 6.1.1.2
Comment 10 raal 2019-07-21 05:52:43 UTC
*** Bug 126490 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2021-09-01 12:29:38 UTC
I don't know why bug 83568 was just See Also, when it seems to be the same. 
If you can explain the difference, set New again. 
All CC folks, please go to other bug.

*** This bug has been marked as a duplicate of bug 83568 ***