Download it now!
Bug 126525 - Use external color pickers as provided by os/DE, or other projects
Summary: Use external color pickers as provided by os/DE, or other projects
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Color-Picker-Dialog
  Show dependency treegraph
 
Reported: 2019-07-24 14:30 UTC by Grey
Modified: 2020-02-19 07:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grey 2019-07-24 14:30:57 UTC
I was reading <a href="https://bugs.documentfoundation.org/show_bug.cgi?id=93813">Bug 93813</a> and got to thinking about how the entire suite, not just Draw, needs this feature as swatch creation in LO is non-trivial. 

I'm pretty sure some developer on your team had already considered this...but just in case...

I was thinking LO could hook into the existing system-wide color picker available in Win/Mac/Linux...ah, Linux (regardless of DE) doesn't have a system-wide color picker.

So, instead of "reinventing the wheel" and coding from scratch, couldn't an existing GPL/MIT solution be integrated, thus eliminating the need for (at least) three different solutions.

Pardon me for being presumptious. I admit I'm not in anyway a programmer, just an end-user, but I feel in this day and age a suite-wide color picker is commonplace, and judging by questions and requests posted here, on ask.libreoffice.org and elsewhere, I'm not alone. Thank you.
Comment 1 V Stuart Foote 2019-11-15 14:13:01 UTC
Rereading, don't see this as viable approach.  Difficult to "integrate" whatever external libs are available by os/DE--and then issues for consistency cross platform.

IMHO => WF
Comment 2 Heiko Tietze 2019-11-15 15:53:49 UTC
(In reply to Grey from comment #0)
> ...ah, Linux (regardless of DE) doesn't have a system-wide color picker.

Which is a show-stopper.

> ...judging by questions and requests posted here, on ask.libreoffice.org

What issue/use case brings you to the proposed solution?
Comment 3 Grey 2020-02-12 20:44:24 UTC
Gentlemen,

first off, my apologies for the delay in responding.

<quote>Rereading, don't see this as viable approach.  Difficult to "integrate" whatever external libs are available by os/DE--and then issues for consistency cross platform.</quote>

<quote>Which is a show-stopper.<quote>

Okay. I leave the approach to whatever the developers deem best. All I know is that GIMP, Blender, Krita, Inkscape, Scribus, etc. all have a pipette/eyedropper tool. I don't presume to know how those applications have integrated said tool but it leads me to believe the problem is not surmountable nor novel technology.

<quote>IMHO => WF</quote>

Well, then...that settles that. Thanks for your time.
Comment 4 QA Administrators 2020-02-15 06:51:30 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2020-02-19 07:55:11 UTC
(In reply to Grey from comment #3)
> Well, then...that settles that. Thanks for your time.

Thanks for your time to file the ticket! Very much appreciated.