Bug 126572 - FILEOPEN FILESAVE connectors from draw/impress are not exported to .pptx
Summary: FILEOPEN FILESAVE connectors from draw/impress are not exported to .pptx
Status: RESOLVED DUPLICATE of bug 80236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Connectors PPTX
  Show dependency treegraph
 
Reported: 2019-07-26 22:09 UTC by andreas_k
Modified: 2019-09-29 16:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
impress file (11.82 KB, application/vnd.oasis.opendocument.presentation)
2019-07-26 22:09 UTC, andreas_k
Details
impress export pptx file (20.63 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-07-26 22:10 UTC, andreas_k
Details
impress file reasaved with PowerPoint to PPTX (43.12 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-07-27 20:50 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-07-26 22:09:49 UTC
Created attachment 153002 [details]
impress file

if you draw shapes and connect them with connectors, the connectors are not visible.

attached the impress file
Comment 1 andreas_k 2019-07-26 22:10:24 UTC
Created attachment 153003 [details]
impress export pptx file

the connectors are not saved.
Comment 2 Jacques Guilleron 2019-07-27 14:29:58 UTC
Hi andreas_k,

I dont reprobuce with
LO  5.3.1.1 Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; Locale : fr-FR (fr_FR); Calc: CL
and upper versions.

Jacques
Comment 3 Bartosz 2019-07-27 20:50:27 UTC
Created attachment 153008 [details]
impress file reasaved with PowerPoint to PPTX

I'm able to reproduce the issue on Ubuntu 18.04 and LO 6.0.7.2.
Steps to reproduce:
1. Open Impress file
2. Ungroup shapes
3. Make sure that when you move shapes connectors are changing location
4. Save as PPTX and reopen

Actual result:
- during moving shapes, the connectors are not moving

Expected result:
- during moving shapes, the connectors following the shapes


I have also exported Impress file by MS PowerPoint to PPTX.
Everything is working fine under MS PowerPoint.
Unfortunately connectors are not working correctly with PPTX file exported with MS PowerPoint.
Comment 4 Bartosz 2019-07-27 20:54:05 UTC
Most propably it is duplication of the tdf#89449
Comment 5 Xisco Faulí 2019-09-26 08:47:35 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 186d36a7036462ae641b35004b4ffba3eeeca46f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 6 Xisco Faulí 2019-09-29 16:59:07 UTC
This is a duplicate of bug 80236

*** This bug has been marked as a duplicate of bug 80236 ***