Bug 126581 - FORMATTING - Date format default changes
Summary: FORMATTING - Date format default changes
Status: CLOSED DUPLICATE of bug 126116
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 126606 126640 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-28 21:42 UTC by John
Modified: 2019-07-31 18:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2019-07-28 21:42:47 UTC
Description:
cell date format changes as a new date entered into a cell formatted for date and not a blank cell set to date.

Steps to Reproduce:
1. cell format set to mm/dd/yy in blank cell.
2. enter a date into blank cell  i.e 02/02 or 2/2/19
3. date displays as 02/02/19
4. now enter a new date into that same cell i.e 03/03 or 3/3/19
5. date displays as 03/03/2019
6. check cell format... it has changed to mm/dd/yyyy

Actual Results:
mm/dd/yyyy

Expected Results:
mm/dd/yy


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

PROBLEM NEW TO THIS VERSION started with upgrade from LibreOffice_6.2.4_Win_x64
Comment 1 Oliver Brinzing 2019-07-29 17:27:03 UTC
reproducible with:

Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

e.g.:
- open new spreadsheet
- enter A1: 1/2/  -> 01.02.19
- enter A1: 1/2/  -> 01.02.2019

but *not* reproducible with LO 6.1.6.3
Comment 2 Oliver Brinzing 2019-07-29 18:02:09 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/4d51531130988d87839bb7b0c077a5df43b2a6be

Resolves: tdf#125109 prefer edit format's acceptance patterns and YMD order

Change-Id: I4036061b9e8f01d99f04f20dfbbd2cf23d3a9b59
Reviewed-on: https://gerrit.libreoffice.org/72632
Reviewed-by: Eike Rathke <erack@redhat.com>
Tested-by: Jenkins
(cherry picked from commit 478e051f4ea13b15120fdf74faf94a6c2cfcb50c)
Reviewed-on: https://gerrit.libreoffice.org/72848
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Tested-by: Caolán McNamara <caolanm@redhat.com>

$ git bisect bad da0edbff849d497ac118647a56ce00e321895fc9 is the first bad commit
commit da0edbff849d497ac118647a56ce00e321895fc9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Jun 10 14:11:14 2019 -0700

    source 4d51531130988d87839bb7b0c077a5df43b2a6be

    source 4d51531130988d87839bb7b0c077a5df43b2a6be

:040000 040000 bc74f4c2d17df557cb37e1466534f2159d4befa1 937cc41407b96c97f0af6386df2a1aa998c2c511 M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.2
$ git bisect log
# bad: [35a87a66cfc6dfb661f6fed49fb32c081dd26bc7] source d250c94d78ac7e79753aa30f869db919b01fc450
# good: [b0a56ec98b1368cb5e3e531e0b3f69565af91609] source 3a801799536e6870f2fb111b1cc00b9575a35a39
git bisect start 'master' 'oldest'
# good: [7f7b05d44d7d7f13cc9c865963a72e555b516b3d] source 1b88de0a07180661c4d5d6706247d546d06bc983
git bisect good 7f7b05d44d7d7f13cc9c865963a72e555b516b3d
# good: [1c3155d561cb094926cd19aa514856dfb4e23c5e] source a626bdd56d7116efa57e65403ad51b56657148c3
git bisect good 1c3155d561cb094926cd19aa514856dfb4e23c5e
# good: [ae0a07b0d72f65d3de33abe942073e21270f85a8] source 1d3a07415eda3014d67d7c56466a8ad1d0ec51d9
git bisect good ae0a07b0d72f65d3de33abe942073e21270f85a8
# good: [d08dc9d186b26aa58a919139e18d10f49382d6cb] source 0812325b46a877a6f150e5b9e1319e53eb9c87da
git bisect good d08dc9d186b26aa58a919139e18d10f49382d6cb
# good: [4c0e4542f248f478ac909e3aebac34d46c0a91e2] source ad44bb453177e16d07e37f40745154b571489ffe
git bisect good 4c0e4542f248f478ac909e3aebac34d46c0a91e2
# good: [af9fce0e5d7a5774739c9c5b99b3d219fcb60942] source 4f279b95efbc113d3c1907a232a4e647e2b4054f
git bisect good af9fce0e5d7a5774739c9c5b99b3d219fcb60942
# bad: [10e0aa2b590acddb3d46bd7545ec49395250746e] source 87c418a98650ab6e4a62a0b4b72e02fee358dced
git bisect bad 10e0aa2b590acddb3d46bd7545ec49395250746e
# good: [f2e84930a3c2c15afd3bd9b86396d36869753209] source b6a3d0566628e2d8416708d0410193435a3b8e53
git bisect good f2e84930a3c2c15afd3bd9b86396d36869753209
# good: [0763ec6fe381992aa3fbeb43bbf4ed620c231f26] source ee46d8e8c7375044e792ce330c80bf313e59b5e7
git bisect good 0763ec6fe381992aa3fbeb43bbf4ed620c231f26
# bad: [da3df5d7ad9b1ff786a39d1302cf2902aee3bc1f] source 3dd024a28a98a9d4b4efc3c7ec6acaa94d2b25fd
git bisect bad da3df5d7ad9b1ff786a39d1302cf2902aee3bc1f
# good: [bf1a7d1912db3114ab52d9da542710901316e82a] source 2980fa249a2680f32915de470a9cd8840780c2a0
git bisect good bf1a7d1912db3114ab52d9da542710901316e82a
# good: [ebf3126547d00e609115b4a90736a157b080c08a] source 54b588724005c502590a2f43ea42f6b2fb8fb1f2
git bisect good ebf3126547d00e609115b4a90736a157b080c08a
# bad: [da0edbff849d497ac118647a56ce00e321895fc9] source 4d51531130988d87839bb7b0c077a5df43b2a6be
git bisect bad da0edbff849d497ac118647a56ce00e321895fc9
# first bad commit: [da0edbff849d497ac118647a56ce00e321895fc9] source 4d51531130988d87839bb7b0c077a5df43b2a6be
Comment 3 Oliver Brinzing 2019-07-30 16:18:29 UTC
*** Bug 126606 has been marked as a duplicate of this bug. ***
Comment 4 Oliver Brinzing 2019-07-31 17:06:09 UTC
*** Bug 126640 has been marked as a duplicate of this bug. ***
Comment 5 Eike Rathke 2019-07-31 18:33:57 UTC

*** This bug has been marked as a duplicate of bug 126116 ***