Bug Hunting Session
Bug 126781 - size of conditional formatting window prevents text to be changed (right end unreachable)
Summary: size of conditional formatting window prevents text to be changed (right end ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.2 target:6.3....
Keywords: bibisected, bisected, regression
: 128223 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-08 17:29 UTC by Frank
Modified: 2019-10-18 11:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
window with fixed size - text to the right unreachable (86.08 KB, image/png)
2019-08-08 17:29 UTC, Frank
Details
Conditional formatting cannor be changed while long text not reachable (591.09 KB, application/octet-stream)
2019-08-11 11:51 UTC, Frank
Details
Screenshot from help - about LO (39.77 KB, image/png)
2019-09-23 18:23 UTC, Frank
Details
Rightmost position available but not end of text (40.39 KB, image/png)
2019-09-24 15:40 UTC, Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank 2019-08-08 17:29:16 UTC
Created attachment 153241 [details]
window with fixed size - text to the right unreachable

As you can see in the attachment, the formatting text (its text has been created with a former Version of calc) cannot be edited, because the text continues far to the right, however you cannot move to the right and the window size cannot be changed.
Comment 1 raal 2019-08-11 09:45:00 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 Frank 2019-08-11 11:51:00 UTC
Created attachment 153292 [details]
Conditional formatting cannor be changed while long text not reachable

Try to edit the conditional formatting e.g. worksheet "verbräuche" column X. You will see, that it is impossible to put the cursor into the rightmost area.
Comment 3 Oliver Brinzing 2019-08-19 17:37:23 UTC
reproducible with:

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 082e95f684e44954275dc58e306b8dc69590ac80
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

but *not* reproducible with:

Version: 6.2.6.2 (x64)
Build ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc:
Comment 4 Oliver Brinzing 2019-08-19 18:12:53 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/492b0d5d076d38234fea4e4e7c5dbec578296fd2

commit	492b0d5d076d38234fea4e4e7c5dbec578296fd2	[log]
author	Caolán McNamara <caolanm@redhat.com>
Tue May 07 12:27:43 2019 +0100
committer	Caolán McNamara <caolanm@redhat.com>
Sat May 11 18:34:23 2019 +0200
tree	47b4a17120d7d3c71bf7674b45768f38b761e360
parent	acd290431fd39ed0602e057e036326b46a99f7a8 [diff]

weld conditional formatting

/cygdrive/d/sources/bibisect/bibisect-win32-6.3
$ git bisect bad
db5f55b09f11d45f5bcd0b98ce862aed7c085a60 is the first bad commit
commit db5f55b09f11d45f5bcd0b98ce862aed7c085a60
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat May 11 09:52:22 2019 -0700

    source sha:492b0d5d076d38234fea4e4e7c5dbec578296fd2
    source sha:492b0d5d076d38234fea4e4e7c5dbec578296fd2

:040000 040000 d70670cb2ec8f04e9bca9f97f1176c035f5ff161 ad6eb1a1320e122c5d4b64ade7b9903432649a19 M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.3
$ git bisect log
# bad: [18f926e8e18b3d855c2f79ef279febbeb846b8cd] source sha:13152ad88b24cadc836a829b4424a72a152ca9b1
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'master' 'oldest'
# good: [3aea60569b9190400409ebb93f0a5d323b6fc5d4] source sha:47ce4b87d8a13fc340794ffd9a10d5bd6a15e644
git bisect good 3aea60569b9190400409ebb93f0a5d323b6fc5d4
# good: [3b794d71dd796e467baef082c140bdc77c69c979] source sha:47d25dc5abe000ce751cb1e4dbd1f85f7198ca05
git bisect good 3b794d71dd796e467baef082c140bdc77c69c979
# bad: [a42f6c6e5c4ec8fabee76bfa131fd188f758dc93] source sha:e2aa8f8cb3b93ec3cb14c5c9edc3bbce78c1558f
git bisect bad a42f6c6e5c4ec8fabee76bfa131fd188f758dc93
# good: [95f9e136bc046fbc3b6848d30b228dfcc3a823f8] source sha:f0c3fc59e1eefbec202e0a10553dd6581fc2cae5
git bisect good 95f9e136bc046fbc3b6848d30b228dfcc3a823f8
# bad: [34ec72d670699ca24928a9a7cdae62f7bcd384f4] source sha:991f7bf545872ead25513cec761c603bb502e587
git bisect bad 34ec72d670699ca24928a9a7cdae62f7bcd384f4
# good: [d5e5b838f2689180c679c8c248c7e2fc8b703558] source sha:142a139b8de7712d6f24dcad558c45c453985f40
git bisect good d5e5b838f2689180c679c8c248c7e2fc8b703558
# bad: [b902368109728d5c9b9c232ed0b0c733a5169512] source sha:b03a2d037492b839788da3de076e6cdea30a691d
git bisect bad b902368109728d5c9b9c232ed0b0c733a5169512
# good: [b10511871c79b8777efd1f2ea6cfba8659c50c08] source sha:08b79ade4f2e2fa98487696591123f71a7521dff
git bisect good b10511871c79b8777efd1f2ea6cfba8659c50c08
# bad: [8def0cd4db588eec1c1b6e0597e89d913fe7d6e8] source sha:caa6de6c97b0c2fc82c6a2699a1e84b9d2eb9dbd
git bisect bad 8def0cd4db588eec1c1b6e0597e89d913fe7d6e8
# good: [1b06d813fdf30946ac19d31af131bb9fc5e0e3f9] source sha:42a57840a86665f1a74010ff1e3da27934c85df9
git bisect good 1b06d813fdf30946ac19d31af131bb9fc5e0e3f9
# good: [52bf36076a59772c48f64ef8d2856c2fe992a51d] source sha:2de1fd7d8b8bd42c66190140cc4506df0c3367f1
git bisect good 52bf36076a59772c48f64ef8d2856c2fe992a51d
# good: [cb7d22697616208eb4a6467a328b15a3d0c13aac] source sha:acd290431fd39ed0602e057e036326b46a99f7a8
git bisect good cb7d22697616208eb4a6467a328b15a3d0c13aac
# bad: [db5f55b09f11d45f5bcd0b98ce862aed7c085a60] source sha:492b0d5d076d38234fea4e4e7c5dbec578296fd2
git bisect bad db5f55b09f11d45f5bcd0b98ce862aed7c085a60
# first bad commit: [db5f55b09f11d45f5bcd0b98ce862aed7c085a60] source sha:492b0d5d076d38234fea4e4e7c5dbec578296fd2
Comment 5 Commit Notification 2019-08-20 07:24:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1a78436290b7dd22df81d6491b656182604d38fd%5E%21

Resolves: tdf#126781 don't let width grow to fit condition text

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-08-20 07:30:35 UTC
fixed in master, backport to 6-3 in gerrit
Comment 7 Commit Notification 2019-08-20 09:04:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/16eaea5fe8c3e9942b36f6d9969886191f25620c%5E%21

Resolves: tdf#126781 don't let width grow to fit condition text

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-08-23 18:40:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-1":

https://git.libreoffice.org/core/+/909d532b10118881e36d27194756bbf26e443c58%5E%21

Resolves: tdf#126781 don't let width grow to fit condition text

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Frank 2019-09-22 08:30:03 UTC
Hello,

I'm testing with 6.3.2.2 and I find it's still the same problem for me. Window size is fixed and I cannot reach the right part of the text in conditional formatting. I'm currently testing with the same worksheet als I submitted on 2019-08-11.
Comment 10 Xisco Faulí 2019-09-23 11:15:49 UTC
(In reply to Frank from comment #9)
> Hello,
> 
> I'm testing with 6.3.2.2 and I find it's still the same problem for me.
> Window size is fixed and I cannot reach the right part of the text in
> conditional formatting. I'm currently testing with the same worksheet als I
> submitted on 2019-08-11.

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 11 Frank 2019-09-23 18:23:48 UTC
Created attachment 154395 [details]
Screenshot from help - about LO
Comment 12 Xisco Faulí 2019-09-24 11:24:04 UTC
Hello Frank,
Indeed, the dialog size is fixed, but I can reach everything within the dialog.
Could you please explain the steps you follow to reproduce the problem with the unreachable element ?
Comment 13 Frank 2019-09-24 15:40:07 UTC
Created attachment 154449 [details]
Rightmost position available but not end of text

Hallo.

Naturally I can give you further information.
In the attachment you will find a screenshot and here is what I have done:
Ich chose condition number two and here i went to field number tree. It starts with "SVERWEIS(DAT.....". I put the cursor into this field an go to the right in order to edit the condition (which is fairly long, indeed. As you can see in the screenshot the cursor stops at "Verbräuche_V" and is stuck at this position although there are many letters to come. So - I can't edit what I'm unable to see.
How can I edit the missing text? In earlier versions of LO the cursor went down to the rightmost letter of my created condition. Furthermore I could enlarge the window, which was far more comfortable as I could see nearly the complete phrase.
So, as a conclusion:
You are absolutely correct that you can put the cursor to the right, but I stops too early. Therefore you can create very short conditions only!
best regards
Frank
Comment 14 QA Administrators 2019-09-25 03:02:41 UTC Comment hidden (obsolete)
Comment 15 Caolán McNamara 2019-09-30 15:25:35 UTC
So I think the major issue is actually solved, but there is another not so obvious problem, but that problem is more obvious with the German UI as the strings in the combo box are longer there triggering this problem.
Comment 16 Commit Notification 2019-09-30 18:31:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/65977a839d1de4ed801ae6803371bf5ba7ee799a

Related: tdf#126781 allow conditional format to resize

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-10-01 07:55:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0ff8140676877f7a37ceb14d9ba797d6e2a18cf6

Resolves: tdf#126781 force comboboxes to take 1/3 avail space

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Caolán McNamara 2019-10-01 07:56:58 UTC
looks good to me in master, backport to 6-3 in gerrit
Comment 19 Commit Notification 2019-10-01 12:06:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/aace6e60b555740260a85ec90036b85d61ee4f06

Resolves: tdf#126781 force comboboxes to take 1/3 avail space

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Xisco Faulí 2019-10-02 09:59:34 UTC
Hello Frank,
Could you please confirm with a daily build from http://dev-builds.libreoffice.org/daily/master/ that the issue is fixed ?
Thanks in advance
Comment 21 Frank 2019-10-02 14:04:38 UTC
OK. Tested with the latest daily build and everything seems to be technically functional so far. I can edit the complete phrase up the the rightmost positions in each case, so it's fully usable - however the window size is still pretty small.
Comment 22 Xisco Faulí 2019-10-16 11:01:53 UTC
(In reply to Frank from comment #21)
> OK. Tested with the latest daily build and everything seems to be
> technically functional so far. I can edit the complete phrase up the the
> rightmost positions in each case, so it's fully usable - however the window
> size is still pretty small.

Hi Frank,
Thanks for checking. Setting to VERIFY then
Comment 23 Xisco Faulí 2019-10-18 11:39:29 UTC
*** Bug 128223 has been marked as a duplicate of this bug. ***