Download it now!
Bug 126787 - Setting borders on character format become paragraph format
Summary: Setting borders on character format become paragraph format
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.4.0 target:6.3.2
Keywords: bibisected, bisected, regression
: 127839 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-09 07:23 UTC by Mark Hung
Modified: 2019-10-12 05:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2019-08-09 07:23:42 UTC
Description:
Setting borders on character format become paragraph format.

Steps to Reproduce:
1. Insert a few characters in a text document in writer.
2. Select the text, right click to open context menu. Select character/character... to open the character format menu.
3. Turn on the border for the characters from the tab page.

Actual Results:
Borders are turned on for the whole paragraph. It can be verified in the border tab page in the paragraph dialog.

Expected Results:
Only the border of the selected characters should be turned on.


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced in 
版本:6.4.0.0.alpha0+
組建 ID:80089fb50eb73d32ddb035370b9389a3e270b5ed
CPU 執行緒:4; OS:Linux 4.15; UI 算繪:預設; VCL: gtk3; 
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded

But not reproducible in
Version: 6.2.5.2
Build ID: 1:6.2.5-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: zh-TW (zh_TW.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Durgapriyanka 2019-08-15 21:42:48 UTC
Thank you for reporting the bug. I cannot reproduce this bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Mark Hung 2019-08-17 03:51:14 UTC
I've bisected the issue.

c3586f0cde707dc41cde7debba89138c4d428ac1 is the first bad commit
commit c3586f0cde707dc41cde7debba89138c4d428ac1
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Aug 5 18:29:19 2019 +0200

    source sha:30d03b495f437e9b2edbb0f8ceebe3020ba7459c
    
    source sha:30d03b495f437e9b2edbb0f8ceebe3020ba7459c

:040000 040000 4fd372475270d57fa931c5c9668dd36ff8955804 117fee423c7c8a9fc84540fd37094fa7f0562919 M	instdir

commit 30d03b495f437e9b2edbb0f8ceebe3020ba7459c
Author: Mike Kaganski <mike.kaganski@collabora.com>
Date:   Mon Aug 5 14:36:19 2019 +0300

    tdf#126684: store "DialogUseCharAttr" in RES_PARATR_GRABBAG
    
    ... because RES_CHRATR_GRABBAG value may be later reset by initial
    value read from char format, when it's present there.
    OTOH, RES_PARATR_GRABBAG shouldn't be present in character format,
    so it should be safe to pass the grabbag item there.
    
    Regression after commit 074fc4a1499aac6eb67cd0b2dca00a51071cff0e.
    
    Change-Id: Iebbee04929714d6a3fb72274a211699b2a80b3d2
    Reviewed-on: https://gerrit.libreoffice.org/76981
    Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
    Tested-by: Mike Kaganski <mike.kaganski@collabora.com>
Comment 3 Mark Hung 2019-08-17 04:03:23 UTC
Hi Mike,

You may want to check this.
Comment 4 Mike Kaganski 2019-08-17 07:56:23 UTC
https://gerrit.libreoffice.org/77617
Comment 5 Commit Notification 2019-08-17 09:27:53 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/202c9a7d826c95fc05db912a8d19c598a240f1cd%5E%21

tdf#126787: extend/restore item set ranges to hold RES_PARATR_GRABBAG

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-08-18 05:31:34 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e0826f8e18b5ad8f8743a4aa2fb78bffda2524f8%5E%21

Related: tdf#126787: remove some defensive programming parts

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-08-21 10:14:39 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike, thanks for fixing this issue!
Comment 8 Commit Notification 2019-08-21 13:58:38 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/ad2fde8797bd7753987dc1bbbae35fb1cc5ce1df%5E%21

tdf#126787: extend/restore item set ranges to hold RES_PARATR_GRABBAG

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-09-30 13:30:26 UTC
*** Bug 127839 has been marked as a duplicate of this bug. ***
Comment 10 V Stuart Foote 2019-09-30 13:41:02 UTC Comment hidden (obsolete)
Comment 11 george 2019-10-12 05:51:33 UTC
My libre office was just updated to 6.3.2.2 and I verify that the issue has been resolved.