Download it now!
Bug 126804 - Tip-Of-The-Day don't show at start
Summary: Tip-Of-The-Day don't show at start
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-08-10 02:03 UTC by Leandro Martín Drudi
Modified: 2019-09-26 10:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2019-08-10 02:03:19 UTC
Description:
Although the option to show the suggestion of the day when starting LibreOffice is active, it is not always shown (it seems that only when creating a new document, not when opening an existing file, but I cannot assure it).

Steps to Reproduce:
1. Open LibreOffice.
2. Create a new document.
2.1. Can show or can't show de dialog.
3. Open an existent document.
3.1. Never show the Tip-of-the-Day

Actual Results:
1. Open LibreOffice.
2. Create a new document.
2.1. Can show or can't show de dialog.
3. Open an existent document.
3.1. Never show the Tip-of-the-Day

Expected Results:
Create or open show the tip


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Versión: 6.3.0.4 (x64)
Id. de compilación: 057fc023c990d676a43019934386b85b21a9ee99
Subprocs. CPU: 8; SO: Windows 10.0; Repres. IU: predet.; VCL: win; 
Configuración regional: es-AR (es_AR); Idioma de IU: es-ES
Calc: CL
Comment 1 Roman Kuznetsov 2019-08-10 08:00:54 UTC
Tip shows only one time per day with first start of LibreOffice. Please test your problem more detail.
Comment 2 Leandro Martín Drudi 2019-08-10 17:42:20 UTC
Once every 24 hours or once per calendar day?
How is the day counted? Because it's been 3 days since the installation (or 2 if we count from the hour) and I've only seen it after installing and never again. And the option is active.
However, after trying to create new documents, in the fourth attempt the message just appeared (if previously closed LibreOffice)
Comment 3 QA Administrators 2019-08-19 07:10:58 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-08-19 08:05:41 UTC
Hello Leandro,
It should be displayed if your remove the user profile. Then, it's displayed once a day. Changing your OS' date would make it to be displayed again.
Comment 5 Leandro Martín Drudi 2019-08-19 21:57:24 UTC
I installed the version independently (with Separate Install GUI) three times (removing the installation each time) and:
1) First installation:
1.1) It did not appear at the first start (I created a new file).
1.2) It did not appear on the second start (I created a new file).
1.3) It appeared only on the third start (I created a new file).
2) Second installation.
2.1) It appeared at the first start (I opened a file).
2.2) It did not appear on the second start (I opened a file).
2.3) It appeared on the third start (I opened a file).
3) Third installation:
3.1) It did not appear at the first start (I opened a file).
3.2) It appeared on the second start (I created a new file).
3.3) It did not appear on the third start (I opened a file).
1, 2 and 3 happened within 1 hour on the same day.
Comment 6 Heiko Tietze 2019-08-20 06:29:12 UTC
New installation of the program will not alter the user configuration. The function compares the system time with the last time the tip was shown. And when it's shown it writes the time stamp to the registry (officecfg::Office::Common::Misc::LastTipOfTheDayShown). The tip will not show up when you disable it or if LibreOffice is started with the parameter "--headless".

Maybe your system time is wrong.
Comment 7 Leandro Martín Drudi 2019-08-20 17:30:42 UTC
When I do a parallel installation, is the user profile folder created in the installation directory?
And if I delete the root folder, is the profile folder deleted?
And if I install again, the user folder is created again?

So it doesn't work properly.
Comment 8 Heiko Tietze 2019-08-21 06:10:19 UTC
(In reply to Leandro Martín Drudi from comment #7)
> When I do...
No

Use Help > Restart in Safe Mode and Reset to factory settings (both options on) to purge all user settings. The configuration is... oh, you are running Windows. Somewhere under Users/<name>/<something hidden>. Just delete this folder.
Comment 9 Leandro Martín Drudi 2019-09-11 01:49:58 UTC
Not reproducible in:
Version: 6.3.1.2 (x64)
Compilation ID: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 8; OS: Windows 10.0; Repres. IU: GL; VCL: win; 
Regional configuration: es-AR (es_AR); IU language: es-ES
Calc: CL

Plus, it shows every time you start LibreOffice. Great!
Great job
Comment 10 Xisco Faulí 2019-09-26 10:09:58 UTC
Closing as RESOLVED NOTABUG