Bug Hunting Session
Bug 126843 - Spell check "ignore all" locks up if multiple instances of the mispelled word in same sentence
Summary: Spell check "ignore all" locks up if multiple instances of the mispelled word...
Status: RESOLVED DUPLICATE of bug 127060
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-11 23:30 UTC by bchemnet
Modified: 2019-09-02 15:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bchemnet 2019-08-11 23:30:14 UTC
If a sentence (in Writer) or a single cell (in Calc) contains multiple instances of the same word that is identified as mispelled, pressing "Ignore All" while spell checking hangs the program.  "Ignore once" works fine, as does "ignore all" on the same word as long as the next instance is in a different sentence.

To reproduce, create a blank document and type two instances of the same mispelled word (eg: testa testa).  Run spell check, press "ignore all" and watch it stall indefinitely.

I actually encountered this while spell checking a document with units on numbers, so that phrases like "nm" and "mL" appear many times.  This was not a problem in 6.1.4, which is what I upgraded from.
Comment 1 Alex 2019-08-16 09:08:54 UTC
I can confirm that this occurring for me as well, in an identical fashion.
Comment 2 IM 2019-09-01 18:58:57 UTC
Thank you for reporting the bug. I can confirm that the bug is present in:

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-09-02 15:17:39 UTC
Thanks for reporting this issue.
It seems like a dupe of bug 127060

*** This bug has been marked as a duplicate of bug 127060 ***