Download it now!
Bug 126850 - About dialog website button link should lead to Sorbian websites
Summary: About dialog website button link should lead to Sorbian websites
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2019-08-12 13:34 UTC by milupo
Modified: 2020-10-01 22:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Upper Sorbian About dialog (28.28 KB, image/png)
2019-08-12 13:34 UTC, milupo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description milupo 2019-08-12 13:34:53 UTC
Created attachment 153322 [details]
Upper Sorbian About dialog

Hi,

the link of the Website button in About dialog leads to a wrong URL in Upper Sorbian (hsb) and Lower Sorbian (dsb) LibreOffice. The Upper Sorbian button leads to www.libreoffice.org/hsb instead of hsb.libreoffice.org and the Lower Sorbian button leads to www.libreoffice.org/dsb instead of dsb.libreoffice.org.

Expected: Button link should lead to hsb.libreoffice.org resp. dsb.libreoffice.org

I asked on libreOffice-l10n and Eike Rathke replied to me as follows:

"Same for any other language it seems. The URIs are generated,
cui/source/dialogs/about.cxx uses localizeWebserviceURI(sURL) that
appends a language tag to the given sURL. So either that needs to be
redirected on server side, or the URI be assembled differently. I don't
know what the original intention was there."

There is an old similar bug report  for German LO:

https://bugs.documentfoundation.org/show_bug.cgi?id=51279

Please fix this or tell me where I can fix this.
Comment 1 Xisco Faulí 2019-08-13 11:16:59 UTC
Hello,
See https://bugs.documentfoundation.org/show_bug.cgi?id=51279#c1 on how to do it

*** This bug has been marked as a duplicate of bug 51279 ***
Comment 2 milupo 2019-08-13 13:08:31 UTC
Hi Xisco,

thank you for your reply.

No the solution in the old bug 51279 comment 1 does not work. It refers to module libo_ui. This module does not exist anymore. I've already searched on Pootle but did not find the right string.
Comment 3 Xisco Faulí 2019-08-13 13:18:04 UTC
@Andras, Would you mind helping milupo with this ?
Comment 4 milupo 2019-10-24 18:24:30 UTC
This issue still exists in LO 6.3.3.2. When When will this bug be fixed?
Comment 5 milupo 2020-02-27 21:11:49 UTC
Hi, the bug report exists half a year now. When will the bug be fixed?
Comment 6 Andras Timar 2020-02-27 21:48:00 UTC
I don't think that this bug belongs to Bugzilla. Eike gave an answer, that the URL has to be redirected at server side. For example my language is Hungarian and Website button opens https://www.libreoffice.org/hu and that redirects to https://hu.libreoffice.org. https://redmine.documentfoundation.org/ does not work for me at the moment, otherwise I'd reported the issue there. It would be the best to grab Cloph on irc and ask him.
Comment 7 Heiko Tietze 2020-09-28 08:01:26 UTC
Rather ask at #tdf-infra (poked Guilhem)
Comment 8 Heiko Tietze 2020-09-30 08:14:57 UTC
Issue reported on Redmine https://redmine.documentfoundation.org/issues/3400
Comment 9 Heiko Tietze 2020-10-01 06:10:38 UTC
The infra team has closed the redmine ticket as resolved so I do here. Thanks Guilhem.
Comment 10 milupo 2020-10-01 22:30:48 UTC
Thank you for opening the Readmine ticket and fixing the bug.