Bug Hunting Session
Bug 51279 - UI: Help/About Website button link should lead to localized LibO Website
Summary: UI: Help/About Website button link should lead to localized LibO Website
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Windows (All)
: medium major
Assignee: sophie
URL:
Whiteboard: done: [DE][JA][LT][PT-BR][RU][zh-TW][...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-20 23:53 UTC by Rainer Bielefeld Retired
Modified: 2019-08-13 11:16 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-06-20 23:53:51 UTC
Steps how to reproduce Server Installation of  "LibreOffice  3.6.0.0.beta2  German UI/Locale [Build-ID: f010139] on German WIN7 Home Premium (64bit):

1. Start LibO installed on German WIN7 PC
   > shows German UI language and German localization
2. Menu 'Help -> Help/About' ('Hilfe -> Info über LOdev'
   > "About" dialog appears in German Language
3. Click button 'Weibseite'
   Expected: leads to existing German <Website http://de.libreoffice.org/>
   Actual: leads to <http://www.libreoffice.org/>
Comment 1 Andras Timar 2012-06-29 08:08:37 UTC
@Rainer: Please note that not all languages have localized website. The link itself is localizable, it is up to the teams, if they localize it. Germans did it, see: https://translations.documentfoundation.org/de/libo_ui/translate.html?search=ygFO&sfields=notes

I don't know what's the criteria for this bug to be closed, I leave it to you. :)
Comment 2 Rainer Bielefeld Retired 2012-06-29 09:05:17 UTC
(In reply to comment #1)
> @Rainer: Please note that not all languages have localized website. 

I know (of course).

> I don't know what's the criteria for this bug to be closed, 

When all localized builds lead to available localized websites?

I believe this issue is really important (point of view marketing), but of course I will not check all those hundreds localizations. I will ask German localization team for help with contacts and leave a note on <l10n@global.libreoffice.org>
Comment 3 Florian Reisinger 2012-07-06 07:53:21 UTC
Hi! The criteria would (for example be):

Attach a language after the url

For example: libreoffice.org?lang=de

At the website we have such sort of thing

if($_POST["lang"] == "de")
  redict.to(de.libreoffice.org)

This above is Pseudocode, of course AND it would be better if we had a Pootle string for that option..

Still with b3
Comment 4 Rainer Bielefeld Retired 2012-07-06 10:52:55 UTC
Hi all from localization teams, 

can you please check whether the link has already been localized and if/when yes leave a note her in the Bug in Witeboard behind "done:"?

Thank you

Rainer
Comment 5 Stuart Swales 2012-07-06 11:03:44 UTC
Not enough resource to localise en-GB site, nor really enough differences to make it worthwhile, unlike the UI & Help.
Comment 6 Rainer Bielefeld Retired 2012-07-07 00:00:28 UTC
Added The ones where I currently did not check whether localized Website exists  and/or whether localized link from Help works
Comment 7 Nguyen Vu Hung 2012-07-07 15:48:17 UTC
UI: Help/About Website button link should lead to localized LibO Website:

Yes, it is what I am doing now.


I think pointing and user to Vietnamese website is reasonable
-> http://vi.libreoffice.org
Comment 8 Rainer Bielefeld Retired 2012-07-08 04:02:28 UTC
[AR],[BRX] checked with 3.6.0.0.beta3 WIN
Comment 9 Rainer Bielefeld Retired 2012-07-10 04:21:47 UTC
[ES] undone for 3.6.0.0.beta3
Comment 10 Modestas Rimkus 2012-07-10 08:52:26 UTC
[LT] Updated the string in Pootle with the localized URL. Should be done for the next version that uses updated strings.
Comment 11 Rainer Bielefeld Retired 2012-07-12 06:04:09 UTC
Please also see "Bug 52000 - UI: Unify info links to localized LibO websites", a smart fix there might be able to fix this one, too without involving localization teams.
Comment 12 Rainer Bielefeld Retired 2012-07-12 11:49:26 UTC
Please also see "Bug 52009 - LOCALHELP: URL for Documentation should be localized"
Comment 13 Volkan 2013-11-09 16:12:19 UTC
Any progress with this?
Comment 14 Robinson Tryon (qubit) 2013-12-02 19:12:27 UTC
Joren - Please test this and see if you get a localized site. It works for sophie in French and me in English (I get sent to libreoffice.org/en), so I'm tempted to resolve as 'WORKSFORME'.
Comment 15 Robinson Tryon (qubit) 2013-12-02 19:14:51 UTC
Assigning to sophie :-)
Comment 16 Jorendc 2013-12-02 19:18:13 UTC
Dutch localization works fine. Tested using LibreOffice 4.1.4.1 rc with Dutch Localization. URL http://nl.libreoffice.org/ opens in browser

Kind regards,
Joren
Comment 17 retired 2013-12-02 20:35:06 UTC
With german localization I get sent to http://de.libreoffice.org

WORKSFORME.
Comment 18 sophie 2013-12-05 10:36:58 UTC
Hi, So I've informed the l10n team about this issue, and pointed also the location of the 'http://www.libreoffice.org' string in their UI and help files asking the team to check for its adaption to native-language website if it exists. 
I'm closing this issue. Cheers - Sophie
Comment 19 Xisco Faulí 2019-08-13 11:16:59 UTC
*** Bug 126850 has been marked as a duplicate of this bug. ***