Bug 126887 - Paragraph Style Inheritance Bug: Derived styles of Heading 1..10 missing "Chapter Numbering" List Style used by Chapter Numbering Feature
Summary: Paragraph Style Inheritance Bug: Derived styles of Heading 1..10 missing "Cha...
Status: RESOLVED DUPLICATE of bug 62032
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering Writer-Styles-Heading
  Show dependency treegraph
 
Reported: 2019-08-13 15:32 UTC by Jason White
Modified: 2020-01-15 15:58 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Template to produce style design in comment 13 (9.25 KB, application/vnd.oasis.opendocument.text-template)
2020-01-14 22:27 UTC, sdc.blanco
Details
Instructions for using template in comment 14 - and actual application (15.85 KB, application/vnd.oasis.opendocument.text)
2020-01-14 22:36 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason White 2019-08-13 15:32:41 UTC
Description:
The paragraph style inheritance system does not pass the "Chapter Numbering" List Style into derived paragraph styles.

This prohibits derived styles from inheriting the ability to have chapter numbering.

Steps to Reproduce:
1. Enable chapter numbering for styles Heading 1..10 
2. Open the modify style dialog for the "Heading 1" style. Under the "Outline & Numbering" tab observe that "Numbering Style" is locked and equals to "Chapter Numbering" (this is expected)
3. Create a new paragraph style from the "Heading 1" style call it "MySpecialHeading 1"
2. Open the modify style dialog for the "MySpecialHeading 1" style. Under the "Outline & Numbering" tab observe that "Numbering Style" is not locked and does not equal to "Chapter Numbering" (this is unexpected).

Actual Results:
The "Chapter Numbering" list style not passed to derived paragraph styles.

Expected Results:
The "Chapter Numbering" list style is passed to derived paragraph styles.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 12; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 m.a.riosv 2019-08-13 16:55:28 UTC
If I'm not wrong it is covered.
Take a look on the documentation: Assigning outline levels to other styles
https://wiki.documentfoundation.org/images/c/c0/WG60-WriterGuideLO.pdf
page 186

Please if you are not agree reopen it.
Comment 2 Jason White 2019-08-13 17:02:46 UTC
m.a.riosv,

I have read the document you cited and performed testing. Outline level has no effect on the behavior described. I do not believe outline level is related to the "Chapter Numbering" list style 

-Jason White
Comment 3 Xisco Faulí 2019-08-14 10:49:55 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 4 Jason White 2019-08-14 13:19:43 UTC
Xisco Faulí,

Sorry, my bad! I intended to select UNCONFIRMED.

-Jason White
Comment 5 Dieter 2019-08-19 13:23:55 UTC
I confirm the described behaviour, but I don't think, this is a bug.

If the settings in "outline & numbering" tab are locked you can see, that this style is used for chapter numbering. If you create a new style (although it is a child of a style that is used for chapter numbering) this new style isn't used for chapter numbering. So settings can't be locked.

cc: Design Team for further input

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 6 Heiko Tietze 2019-08-20 07:29:44 UTC
Why should we disable properties for new styles?
Comment 7 sdc.blanco 2020-01-11 16:15:35 UTC
What INFO is NEEDed?

I understand that this was a bug report and not an enhancement request.

The OP is surprised that making a new (heading) style does not retain the Chapter Numbering.

Add a step 5 and 6 to the procedure in comment #0 --

5. Tools>Chapter Numbering, select Level, select Paragraph style "MySpecialHeading 1", OK.

6. Open the modify style dialog for the "MySpecialHeading 1" style. Under "Outline & Numbering" tab observe that "Numbering Style" is equal to "Chapter Numbering".

If that is what Jason expected, then maybe this is NAB.

If meant as enhancement request:

Chapter Numbering is not a style to be selected. It appears only when Tools>Chapter Numbering is used. 

Only one paragraph style can be selected for Level 1 in Chapter Numbering.
If this Numbering Style were "inherited", then each time a new Heading 1 (child) is made, it would (in effect) "override" the existing setting of the Paragraph Style in the Chapter Numbering.  (probably not a desirable feature)
Comment 8 Heiko Tietze 2020-01-13 11:00:18 UTC
Isn't it the same request as in bug 129669?
Comment 9 sdc.blanco 2020-01-13 11:32:46 UTC
(In reply to Heiko Tietze from comment #8)
> Isn't it the same request as in bug 129669?
Nope. The present report is a query about why Chapter Numbering Style is not inherited when making new paragraph styles based on Heading [1-10] (or a proposal that it should be that way).  Bug 129699 is about allowing the change of outline levels for existing Heading [1-10] paragraph styles.
Comment 10 sdc.blanco 2020-01-13 11:34:45 UTC
(In reply to sdc.blanco from comment #9)
>  Bug 129699 is about allowing the
Should be bug# 129669
Comment 11 Heiko Tietze 2020-01-13 13:53:28 UTC
Same topic to me meaning reason why it is disabled. Anyway, adopting the decision from the sister bug.
Comment 12 sdc.blanco 2020-01-14 12:54:43 UTC
I hope Jason (the original reporter) will come back, and clarify his intention. I do not think he was requesting an enhancement in this case.
Comment 13 Jason White 2020-01-14 14:58:15 UTC
Hello everyone,

The original problem I encountered in filing this bug is that as follows: I am an Electrical Engineer that designs parts for aircraft (also an open source enthusiast). I write a lot of requirements documents. Requirements need to be numbered (see example [1]) and this is achieved through the chapter numbing mechanism and paragraph styles. In a requirements document I need at least three differtent paragraph styles for each level of numbering. Because of how LibreOffice does (or rather doesn't) handle this case with its chapter numbering mechanism I filed this bug.

Bug vs enhancement request is a matter of perspective on how the mechanisms in LibreOffice are intended to work. The current behavior appears to prohibit creation of documents that have multiple paragraph styles map to each level of chapter numbering. This prohibits the use of LibreOffice to create said requirement documents that must adhere to strict formatting and organizational (numbering/headings/formatting/table of contents/etc.) requirements.

Example [1], the simplest case, one style for numbered section headings, one style for numbered requirements. Two parapgraph styles per numbering level. (My real life would usage would actually use 3 or more style)

1. System Requirements (numbered, bold heading with space before/after style)
1.1 The device shall blah... (numbered, normal text style, no extra space)
1.2 The device shall blah... (numbered, normal text style, no extra space)
1.3 Electrical Requirements (numbered, bold heading with space before/after style)
1.3.1 The device shall blah... (numbered, normal text style, no extra space)
1.3.2 The device shall blah... (numbered, normal text style, no extra space)
1.3.3 Power Budget (numbered, bold heading with space before/after style)
1.3.3.1 The device shall Blah.. (numbered, normal text style, no extra space)
1.3.3.2 The device shall Blah.. (numbered, normal text style, no extra space)
Comment 14 sdc.blanco 2020-01-14 22:27:26 UTC
Created attachment 157154 [details]
Template to produce style design in comment 13

(In reply to Jason White from comment #13)

Many thanks for the useful clarifications.

> The current behavior appears to prohibit creation of documents that have
> multiple paragraph styles map to each level of chapter numbering. 
Agree.  If you use Chapter Numbering, then only level 1 numbering style can be given. But you can do what you want without Chapter Numbering.

Please see attached file, a template that has styles that I believe will meet the requirements that you described in comment 13. (Instructions in next comment.)
Comment 15 sdc.blanco 2020-01-14 22:36:41 UTC
Created attachment 157155 [details]
Instructions for using template in comment 14 - and actual application

The attached file explains how to use the template in the previous comment, where the instructions use the actual styles, to provide an actual example to see how it works. If this is what you were seeking, then I think your bug report can be considered to be a duplicate of bug #62032.
Comment 16 Jason White 2020-01-15 14:31:58 UTC
(In response to comments 14 and 15 from sdc.blanco)

Is there any way to decouple the font of the numbering from the heading?

Besides that your proposed solution does work, although the mechanics are a bit different than anticipated. It seems the styles and the indentation/numbering level are not “locked together” – but I suppose that could be seen as a feature.

Thanks!
-Jason White
Comment 17 sdc.blanco 2020-01-15 15:58:16 UTC
(In reply to Jason White from comment #16)
> Is there any way to decouple the font of the numbering from the heading?
If you can accept a universal change for all paragraphs (still keeping bold where needed), then F11-Character Style, right-click edit "Numbering Symbols". 
If you want different font styles for different para styles, then more work is needed.  Start with changing Numbering Style in the relevant Paragraph style (eg, you can use Numbering ABC, then go to List Style and edit Numbering ABC, where you can change it to use 123, etc.)

> Besides that your proposed solution does work, although the mechanics are a
> bit different than anticipated. It seems the styles and the
> indentation/numbering level are not “locked together” – but I suppose that
> could be seen as a feature.
Well, font change was not mentioned in the original specification. (-:
But glad to hear it works, so I will mark this bug as a duplicate.
Conceptually outline levels (as opposed to "styles) and numbering styles (with their own levels) are independent. The current "limitation" in LO is that you cannot arbitrarily combine outline levels and numbering levels (greater than 1) in a dialog box (but fortunately, it can be done manually with TAB). Bug #62032 is a request to overcome that limitation, so that it can be specified in a Style dialog (without requiring TAB to get the coordination right).  Enjoy.

*** This bug has been marked as a duplicate of bug 62032 ***