Download it now!
Bug 127000 - LibreOffice doesn't recognize the defined "distance between lines" within a table of a .docx document created by Microsoft Office 2013. For this LibreOffice uses the default value
Summary: LibreOffice doesn't recognize the defined "distance between lines" within a t...
Status: RESOLVED DUPLICATE of bug 118812
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-08-17 18:48 UTC by hmslima1992
Modified: 2019-09-02 17:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Files used in the test. (108.07 KB, application/zip)
2019-08-24 14:10 UTC, hmslima1992
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hmslima1992 2019-08-17 18:48:34 UTC
The distance between lines within the tables (and in the rest of the document too since this is a global configuration) is set as 1.5 in a .docx file created by Microsoft Office 2013, but when I open this file in LibreOffice, the distance between lines within the tables is set as Simple instead be 1.5.

But the distance between lines of the rest of the document is fine

.

And when I edit this .docx document with LibreOffice and then I reopen it in Microsoft Office, the distance between lines within the tables is reseted as Simple instead of 1.5 that was the originally defined value.

.

I've made other tests, as you can see in this hyperlink: https://old.reddit.com/r/libreoffice/comments/cro171/ive_made_a_comparison_between_the_different/
Comment 1 hmslima1992 2019-08-24 14:10:51 UTC
Created attachment 153623 [details]
Files used in the test.

Here is a .docx document created by Microsoft Office 2013. I also provided a screenshot to you see how the tables should be displayed.

Instead of showing the fist table with the "space between lines" set as 1.5, it's set as Simple.
Comment 2 Dieter 2019-08-30 08:02:29 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

in comparison to Word 2013.

Might be related to bug 91178 and to bug 98409
Comment 3 Xisco Faulí 2019-09-02 15:37:44 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 Xisco Faulí 2019-09-02 15:38:14 UTC
@Justin Luth, I thought you might be interested in this issue...
Comment 5 Justin L 2019-09-02 17:36:48 UTC
I'm going to mark this as a duplicate of bug 118812. A table style is applied which has single spacing in the paragraph properties which overwrites the default paragraph style 1.5 spacing.

<w:style w:type="table" w:styleId="Tabelacomgrade"><w:name w:val="Table Grid"/>
  <w:spacing w:after="0" w:line="240" w:lineRule="auto"/>
</w:pPr>

<w:style w:type="paragraph" w:default="1" w:styleId="Normal">
  <w:spacing w:after="0" w:line="360" w:lineRule="auto"/>
</w:pPr>

However, it is more than that. It looks like a fundamental difference between Word and Writer - because even if you directly apply paragraph properties to 1.5 (or double, or proportional 300% etc), nothing changes visibly since Writer apparently does not consider these cells to be consecutive paragraphs, and therefore doesn't apply the spacing.  (It WOULD apply the spacing within the cell if there were multiple lines...)

It could also be considered a duplicate of bug 119054 and related to bug 118947.

*** This bug has been marked as a duplicate of bug 118812 ***