Download it now!
Bug 98409 - table properties single cell spacing not saved.
Summary: table properties single cell spacing not saved.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.0.0
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX-Tables DOC-Tables
  Show dependency treegraph
 
Reported: 2016-03-04 11:14 UTC by synthview
Modified: 2020-05-14 04:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Cell spacing bug when save as doc (17.39 KB, application/vnd.oasis.opendocument.text)
2016-03-22 10:22 UTC, synthview
Details
how it looks like in Mac Os (left space on the left cell) (70.24 KB, image/png)
2016-03-22 11:32 UTC, synthview
Details
Screenshot of the exported document in doc and docx format (149.75 KB, image/png)
2019-10-07 11:04 UTC, NISZ LibreOffice Team
Details
tdf90408_fontsizeChanged.doc: using this as the unit test. (34.00 KB, application/msword)
2020-04-22 16:51 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description synthview 2016-03-04 11:14:08 UTC
when saving in .doc and .docx format, single cell spacing (not ALL cells) isn’t kept after saving, closing and reopening the file. 
I’ve tested with adding some space to the right only.
Comment 1 Buovjaga 2016-03-21 19:52:45 UTC
Please give exact steps for reproducing or give an .odt file we can save to doc/docx.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 synthview 2016-03-22 10:22:44 UTC
Created attachment 123766 [details]
Cell spacing bug when save as doc
Comment 3 synthview 2016-03-22 10:24:49 UTC
File .odt attached.

1. I select a cell
2. right click  > table properties…
3. borders > spacing to contents > left: [a value]
4. save (odt)
5. close file
6. open file. It’s OK. 
7. save as > .doc
8. close file
9. open .doc file, cell spacing disappeared.
Comment 4 raal 2016-03-22 11:24:18 UTC
I can not confirm with Version: 5.2.0.0.alpha0+, win7
In your .odt file I see spacing to contens = 0.
Comment 5 synthview 2016-03-22 11:31:34 UTC
I’m on Mac OS X
Comment 6 synthview 2016-03-22 11:32:49 UTC
Created attachment 123767 [details]
how it looks like in Mac Os (left space on the left cell)
Comment 7 raal 2016-03-22 12:02:51 UTC
Now I can reproduce from scratch / spacing need to be apply on one cell only. When spacing is applied on whole table, then it works.
Reproducible also with Version 4.0.0.3
Comment 8 QA Administrators 2018-10-02 02:54:28 UTC Comment hidden (obsolete)
Comment 9 NISZ LibreOffice Team 2019-10-07 11:04:22 UTC
Created attachment 154794 [details]
Screenshot of the exported document in doc and docx format

Problem is still present in doc format but not in docx with:

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 489eef894e7034873ad262f9dfca554022db1b09
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-10-01_23:43:38
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 10 Justin L 2020-04-22 14:25:03 UTC
proposed fix at https://gerrit.libreoffice.org/c/core/+/92701
Comment 11 Justin L 2020-04-22 16:51:17 UTC
Created attachment 159821 [details]
tdf90408_fontsizeChanged.doc: using this as the unit test.

One interesting thing I haven't researched yet is that the top two rows import a tiny third column at the end. It isn't there in Word 2003. Is it just to expand the those rows to the table end position? In Word, those rows look minimally smaller.
Comment 12 Commit Notification 2020-05-07 12:07:18 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/99c4fefdbb6129a58421b9c7f4a005f868a0e701

tdf#98409 doc export: export (non-default) cell margins

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 BogdanB 2020-05-10 13:20:06 UTC
My LO app crash when opening the document from comment 2. Or after step 5 (from the comment 3).

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 14 Justin L 2020-05-11 17:28:45 UTC
(In reply to BogdanB from comment #13)
> My LO app crash when opening the document from comment 2. Or after step 5
> (from the comment 3).
My Ubuntu 20.04 and 16.04 don't crash at all, either loading or after saving, with compiled master from May 9.
Comment 15 BogdanB 2020-05-14 04:05:37 UTC
It's ok now
Version: 7.0.0.0.alpha1+
Build ID: 47c81498c63ae71a351f43ec2f073ba92d99fc1d
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-13_06:53:25
Calc: threaded