Download it now!
Bug 127098 - Improve filter of Track Changes
Summary: Improve filter of Track Changes
Status: RESOLVED DUPLICATE of bug 87695
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-22 13:41 UTC by Adalbert Hanßen
Modified: 2019-08-29 16:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adalbert Hanßen 2019-08-22 13:41:16 UTC
This proposal refers to experiences with LibreOfficeWriter Development up to 

Version: 6.4.0.0.alpha0+
Build ID: 8387a6db641b29e6ff3c2f4cdc4688f538cbe35f
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-09_06:28:42
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

and earlier versions. The functions to track and view changes in a document are not really practical. Therefore they should be improved.

Steps to reproduce
1. provide a document of a few pages length.
2. Switch on Edit>Track Changes>Record but do not switch on View>Track Changes at this point.
3. Apply a quite few changes in the document.
4. Apply some more changes to the document, but do this out of order from top to bottom of the document, just one change here, the other one there and so on.
5. Correct some typos in the document.
6. Add some format changes to it, e.g. adding tabs, deleting multiple white spaces.
7. Make some format changes. e.g. setting some words to italics, underlines or bold.
8. Mark some lines as headlines of different order. If you have the impression that you have touched in total 20-30% of the text somehow, this is a good example.
9. Now switch on View>Track Changes.

If you have applied enough changes, the whole document looks to be completely changed and you have difficulties to keep an overview of what has happened to it.

Therefore I propose to enhance the already existing functions of the track changes, namely View>Track Changes and Edit>Track Changes>Manage Changes, which already has a tab Filter. It gives access to select changes in its List tab. Only changes meeting certain criteria dealing with Author, Action or Comment defined in the Filter tab are shown in the List tab. 

Using the category Comment (which has nothing to do to add Comments to the text itself during the revision process) might be useful if there is a strict agreement among the revisors to categorize changes by type and assign e.g. letters to the different changes (e.g. O=optional, B=might be left out for brevity, S plus a number=superfluous, the number characterizing the duplicate where the topic is also dealt with). Using Comment requires very much discipline among the involved people however.

The Action tab lets one choose between Insertion/Deletion/Format/Table Changes. Unfortunately, selection only has an influence on the list shown in the List tab of Edit>Track Changes>Manage Changes, not on the document window. That would really provide a great benefit! The Filter criteria should also influence the display of changes in the document window, this would be the right place to deselect all format changes in View>Track Changes. 

It does not make much sense to select either Insertions or Deletions. At least one should have a chance to select Insertions or Deletions. Often one wants to view the document with the text changes emphasized (by color). Selecting Insertions or Deletions would be the right thing then. However, corrections of typos (typically done by using the spell check functions or by typing over a marked part in a word and only changing a few characters, namely transposing a few of them or adding missing ones or deleting duplicatd ones - but not exchanging digits in a number! - would also be something which should be possible to select or deselect for View>Track Changes. I propose to categorize all this as “typos”. Of course, proceed to the previous or next correction or accept all corrections should only operate on those which are selected (presently it is that way, but they are only highlighted in Edit>Track Changes>Manage Changes List tab and one can click on them to get to the proper place in the document window). Of course currently you can proceed to the next or previous meeting the filter criterion and accept the current one or reject it or accept all or reject all selected changes.

Expected result: 
9. View>Track Changes should have two basic choices:
simple
	Text changes (insertions or deletions)
	typos
	white spaces (insertions or deletions)
	format changes

complex (see Edit>Track Changes>Manage Changes>Filter)
If one checks simple, one should be able to select among the four subcategories (0 to 4 check marks).

If one selects complex, one should be able to select like in the current Edit>Track Changes>Manage Changes>Filter tab, however with the addition of being able to distinguish between real text changes, typos and white spaces like in proposed “simple” mode.

Of course, the selection should influence Edit>Track Changes>Manage Changes>List as well as the document window and the button tools to proceed to the previous, next, accept or reject should always operate on the displayed changes. 

With these enhancements one could for example

* view all substantial text changes - not even seeing or being being bothered with typo changes, format changes, white spaces insertion or deletion etc

* accept all typo corrections in one operation,

* accept all white space changes in one operation.
Comment 1 Heiko Tietze 2019-08-26 07:19:01 UTC
We mad a proposal for a TC sidebar deck in https://design.blog.documentfoundation.org/2015/02/19/tracking-changes-with-libreoffice/ and took filtering into account. The respective ticket is bug 87695.

As your input tackle more that just the filter please join the discussion on this ticket.

*** This bug has been marked as a duplicate of bug 87695 ***