Download it now!
Bug 127100 - Notebook Bar tabbed UI does not hide when OLE editing a StarMath formula (comment 8)
Summary: Notebook Bar tabbed UI does not hide when OLE editing a StarMath formula (com...
Status: RESOLVED DUPLICATE of bug 121484
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2019-08-22 15:11 UTC by Benedikt Bieringer
Modified: 2020-01-24 14:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress with Tabbed UI, sm OLE object activated--Main menu for sm module enables (45.19 KB, image/png)
2019-08-23 16:51 UTC, V Stuart Foote
Details
Impress with Tabbed UI, OLE mode (69.65 KB, image/png)
2019-08-23 17:39 UTC, Benedikt Bieringer
Details
Ilustration of the bug (69.65 KB, image/png)
2019-11-13 15:31 UTC, dante19031999
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Bieringer 2019-08-22 15:11:11 UTC
Open LibreOffice Impress, enable Tabbed UI (View -> User Interface -> Tabbed), add a formula and try changing the font size of that formula (i.e. navigate to the tab "Home" and change the font size). The Tab UI is then greyed out instead of the font size being changed.
Comment 1 Roman Kuznetsov 2019-08-22 18:54:00 UTC
Benedikt, how did you add your formula? 
If you used Insert->OLE Object->Formula then you can't change font size from Impress UI. You should enter to Edit formula mode (double click) and then select menu Format->Font size and set up font size there.

Or you can use extension https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas
Comment 2 Benedikt Bieringer 2019-08-22 22:04:52 UTC
Roman: Yes, it is an OLE element. Since the Tabbed UI replaces the menu bar with tabs, selecting the menu "Format" is no longer possible. Probably when in OLE mode there should be an OLE tab containing e.g. the "Format" menu, but there is not.
Comment 3 V Stuart Foote 2019-08-23 16:51:55 UTC
Created attachment 153600 [details]
Impress with Tabbed UI, sm OLE object activated--Main menu for sm module enables

As there is no MUFFIN mode for the Math Formula editor yet, when in Tabbed mode the Main menu should show when the OLE is being edited--it does on a recent Windows build of master.

=> WFM

=-testing-=
Windows 10 Ent 64-bit en-US (1903) with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Benedikt Bieringer 2019-08-23 17:39:07 UTC
Created attachment 153601 [details]
Impress with Tabbed UI, OLE mode

Impress with Tabbed UI, OLE mode, menu bar not visible

V Stuart: Note that it is possible to manually reactivate the menu bar when in Tabbed, maybe you have done that previously? For me the default is that the bar is hidden and the bar also does not reappear when in OLE mode, as can be seen in the screenshot. Also, while in OLE mode, when I click on the Tab "View" on "Menubar", nothing happens.

System: Manjaro KDE stable (Arch Linux, latest version)
Comment 5 Benedikt Bieringer 2019-08-23 17:48:02 UTC
I installed LibreOffice btw. through Octopy, the Arch package manager GUI. Therefore, my issue is very easy to reproduce without downloading anything manually:
* Install Manjaro KDE stable
* Launch Octopy
  - File->Check updates
  - File->System upgrade
  - enter "LibreOffice"
  - right-click -> install
  - click "commit" button
* Launch LibreOffice
  - View->User Interface->Tabbed
  - Insert->Formula (OLE menu bar not shown)
  - View->Menubar (nothing happens)
  - Exit OLE mode
  - View->Menubar (Menu bar appears)
  - Double-click formula (OLE menu bar is shown)
Comment 6 V Stuart Foote 2019-08-23 18:18:17 UTC
No, clean user profile on startup, View -> User Interface selected 'Tabbed'. Selecting to edit inserted OLE Formula opens the sm Formula editor with its Main Menu showing.

But is the issue that you can't change the size of the formula? Or that the Main Menu is hidden in this MUFFIN mode (and needs to be unhidden)?

BTW you should be wrapping the formula in a 'size ## { }' rather than tweaking the sm Format size defaults.  

=> WFM in either case.
Comment 7 Benedikt Bieringer 2019-08-24 00:51:22 UTC
V Stuart: My initial issue is that when one is in Tabbed mode and does not know where to change the font size, there is no way to find it out by oneself.

This turns out to be the result of the combination of the following two issues:

* I don't get the OLE menu bar when the menu bar is disabled, what is the default in Tabbed. Obviously also in default Tabbed, there should be a way to access it. Probably it would be reasonable to put these into an own Tab, but a fix would also be to just show it always as it is in @V Stuart s screenshot.

* If in OLE edit mode, the tab buttons are all enabled, but have no effect. When one changes Home->Font size, after a few seconds all buttons are disabled. Probably they are meant to be disabled from the beginning in OLE edit mode, but they are not, leading to the impression that they could have an effect.
Comment 8 dante19031999 2019-11-13 15:06:50 UTC
I've been making several tests. The issue is that the impress bar is not hidden when you are editing the formula. Formula has no tabbed UI, so impress tabbed bar is not replaced with formula's tabbed bar (like other object types). It's classical bar is shown under the impress tabbed bar. The bug is impress tabbed bar isn't hidden.
Comment 9 dante19031999 2019-11-13 15:09:54 UTC
Note: it happens on all modules.
Comment 10 dante19031999 2019-11-13 15:31:42 UTC
Created attachment 155790 [details]
Ilustration of the bug
Comment 11 Heiko Tietze 2020-01-24 10:36:34 UTC
My take: reopen bug 121484 and make this a duplicate. Andreas, do you agree?
Comment 12 andreas_k 2020-01-24 10:40:37 UTC
yes that's fine
Comment 13 Heiko Tietze 2020-01-24 10:43:05 UTC

*** This bug has been marked as a duplicate of bug 121484 ***