Bug Hunting Session
Bug 121484 - Notebookbar: Tabbed variant for Math
Summary: Notebookbar: Tabbed variant for Math
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2018-11-17 19:47 UTC by Roman Kuznetsov
Modified: 2018-11-22 14:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Tab bar Math mockup (59.06 KB, image/png)
2018-11-17 19:47 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-11-17 19:47:24 UTC
Description:
I want offer Tabbed variant of NB for Math

Steps to Reproduce:
1. See mockup from attach
2.
3.

Actual Results:
We don't have Tabbed NB for Math

Expected Results:
We have Tabbed NB for Math


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-11-17 19:47:50 UTC
Created attachment 146713 [details]
Tab bar Math mockup
Comment 2 V Stuart Foote 2018-11-18 17:22:46 UTC
With MUFFIN "Tabbed" mode Notebook Bar being allowed out of experimental at 6.2, it probably is appropriate to create a non-menu based UI for the sm module. 

But the sm GUI is still in need of considerable rework, e.g. bug 114395, and not clear source for the current Elements frame can be adopted without major refactoring to render correctly as .UI outside its existing UI frame.

So, while I support the requirement--I think the effort should not be rushed and should be part of a more intentional redesign of the Math formula editor. One could argue that before a MUFFIN Notebook Bar implementation--a Sidebar Deck implementation for the Formula editor is a higher UI priority.
Comment 3 Heiko Tietze 2018-11-19 11:55:20 UTC
The idea of splitting the features dropdown into single widgets sounds tempting but likely fails. Guess the left bar is one monolithic piece of code, and actually something has to happen on click at expand (missing in the mockup).
Furthermore, Math is a kind of expert tool and those experienced users prefer direct input which is done on the bottom of the UI. My take is WFM without NB.
Comment 4 andreas_k 2018-11-19 12:52:35 UTC
This is more an design decision than something else. From my point of view Math is an specific application with not that much functions so there is no need of mide functionality in an tabbed notebookbar and move all the sidebar items into an notebookbar didn't improve the user experience that much.

So I see the only benefit in have an unified UI. (I would go with WFM)
Comment 5 Heiko Tietze 2018-11-22 14:14:16 UTC
There seems to be agreement to not have a dedicated NB for Math. So let's resolve this issue.