Download it now!
Bug 127140 - Right click menu options for frequent documents in Windows 10 taskbar
Summary: Right click menu options for frequent documents in Windows 10 taskbar
Status: RESOLVED DUPLICATE of bug 76131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-24 19:48 UTC by Tracey C
Modified: 2019-09-25 16:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of quick start on W10 (32.39 KB, image/png)
2019-08-26 07:35 UTC, Heiko Tietze
Details
Jumplist recents from quick launch on Win10 task bar (128.40 KB, image/png)
2019-08-26 11:50 UTC, V Stuart Foote
Details
6.3.0 Writer Jump list recents on Start menu on Windows 10 (105.71 KB, image/png)
2019-08-26 11:51 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tracey C 2019-08-24 19:48:46 UTC
Description:
Feature Request: Add right click menu options for opening and pinning frequent / recent documents in Windows 10 quick launch bar (ideally make the behavior consistent on all OS's docks)

Similar to other software, such as Thunderbird, Firefox, Atom code editor and the Typora markdown editor I would like to request right click menu options in the icon on the Windows taskbar

Currently, Libre Office apps only offer recent documents directly in Linux
The offer the File menu (which has recent documents) on MacOS
There is no such functionality in Windows 10

Steps to Reproduce:
1. Add an icon for Calc in the Windows task bar with:
- Start - search for Calc
- Right click Calc
- Click "Pin to Taskbar"
Right click the icon for Calc in the Windows taskbar

Actual Results:
Windows: The only options currently are the ones common to all Windows programs:
- Libre Office Calc (opens the program)
- Unpin from Taskbar
- Close window (if it was already open)

MacOS: The menu shows
- Open documents
- The File menu (requiring an additional 2 clicks to see the recently open documents list)

Linux: The menu shows
- New Spreadsheet
- Recently opened documents

Expected Results:
I would like to have additional options to improve the user experience of opening frequently used documents
These options would be available whether the program was open or closed. 

On all 3 OS's
1 - The menu shows recent documents
2 - There  is an option to pin documents to a list of pinned documents


I examined the behavior of Calc and the other apps on Windows, MacOS and Linux (KDE Neon, Ubuntu based) to see what the current state of things is

Calc
- Windows: No app specific menu items present
- MacOS:   Menu shows open documents, and the File menu (which includes recent documents but is two clicks away from them being present directly in the menu)
- Linux:  New spreadsheet, recent documents. Items present whether app is open or closed

Thunderbird
- Additional right click menu options only present when it is open
- There are actions such as "New Message" present on Windows, MacOS, and Linux
- App specific right click menu options present across all 3 OS's

Firefox
- Additional menu items present whether open or closed
- Actions include "Open a new tab" "Open a New Window" "New Private Window"
- App specific right click menu options present across all 3 OS's

Atom 
- Right click menu has "New Window" etc whether the app is open or closed
- App specific right click menu options present in Windows & MacOS
- Linux:   No app specific menu items present

Typora - behavior differs between OS's
- "Pin" behavior is only present on Windows
- Windows: Right click items include "Pinned" documents, and "new"
- MacOS:   Menu shows recent documents with open documents underneath, in addition to "New, Open" and OS common menu items
- Linux:   No app specific menu items present



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 16; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-08-24 21:30:45 UTC
This description is rather scattered, please rewrite with justification.

But in general there little justification (or appeal) to implementing additional os/DE specific native code for placing LibreOffice actions outside of our UI.

Otherwise LibreOffice already fully implements Windows 7 style Jump-lists to allow recent documents--ref work done on bug 35785

Our implementation on Windows still functions correctly, Jump Lists (context menu with individual module launchers, and MRU files for each module) are populated both on Task bar and on the Start Menu.

This 'native' code is supplemental to our 'cross platform' Recent Files MRU menu list that also populates our Start Center with its thumbnail views (held per user in their LO profile).

=> WFM on Windows builds
Comment 2 Heiko Tietze 2019-08-26 07:35:29 UTC
Created attachment 153652 [details]
Screenshot of quick start on W10

I agree with the request. The quick starter has no recent documents, which is common on Windows.
Comment 3 V Stuart Foote 2019-08-26 11:50:33 UTC
Created attachment 153660 [details]
Jumplist recents from quick launch on Win10 task bar

(In reply to Heiko Tietze from comment #2)
> Created attachment 153652 [details]
> Screenshot of quick start on W10
> 
> I agree with the request. The quick starter has no recent documents, which
> is common on Windows.

Ummm, no they are present in both location. There is a reveal triangle when pinned to the Start Menu, and context menu list when pinned to the Taskbar. Microsoft has played with the GUI since implemented at Win7--but they still function correctly as we have implemented the feature.

Windows shell my need a tweak depending configuration (I use Classic Shell which does this for us).

Clips are from Windows 10 (1903) with 6.3.0.4 install.

=-ref-=

https://www.tenforums.com/tutorials/3469-turn-off-recent-items-frequent-places-windows-10-a.html
Comment 4 V Stuart Foote 2019-08-26 11:51:29 UTC
Created attachment 153661 [details]
6.3.0 Writer Jump list recents on Start menu on Windows 10
Comment 5 Heiko Tietze 2019-08-26 12:17:19 UTC
(In reply to V Stuart Foote from comment #3)
> Ummm, no they are present in both location...

Hm, then I don't see any issue. Do you, Tracey?
Comment 6 V Stuart Foote 2019-08-26 12:32:42 UTC
@Mike, Jan-Marek -- are we happy that our implementation of Win7 Jump Lists remains correct (though maybe obscured by Windows UWP shell changes)?
Comment 7 Jan-Marek Glogowski 2019-08-26 14:48:32 UTC
(In reply to V Stuart Foote from comment #6)
> @Mike, Jan-Marek -- are we happy that our implementation of Win7 Jump Lists
> remains correct (though maybe obscured by Windows UWP shell changes)?

I'm no Windows user. I'm fixing VCL bugs on any platform, if needed, but really can't say much about user experience. If these "jump lists" are the way Windows handles recent documents nowadays and it works with LO, we're fine.

So I searched for "Windows UWP" and now I know it's the acronym for "Universal Windows Platform". No idea how that would fit in here, but probably also needs an extra bug report, if we have to make changes to be UWP-compatible (if that even exists).

(In reply to Tracey C from comment #0)
> Expected Results:
> These options would be available whether the program was open or closed.

We have to rely on the OS support here. So if we miss an opportunity here, I would like to get it documented, so someone can implement it, eventually.

> On all 3 OS's
> 1 - The menu shows recent documents

If it's possible to add these "jump lists" as a submenu, then I don't have any objections about adding the "jump lists" to the right click menu of the icon or as a File menu entry.

> 2 - There  is an option to pin documents to a list of pinned documents

That is a completely different enhancement request. I don't know if any OS offers support for this in the context of recent document handling (or even outside), but I guess that would need some LO-only implementation, to save a "pinned documents" list. I don't think these could be available as part of the recent file lists. Should be handled in an extra bug report IMHO.
Comment 8 Tracey C 2019-08-27 23:34:11 UTC
(In reply to V Stuart Foote from comment #3)

> =-ref-=
> 
> https://www.tenforums.com/tutorials/3469-turn-off-recent-items-frequent-
> places-windows-10-a.html

Thank you for the informational link on showing / hiding the recently used documents in Windows. Apparently that had been turned off. I turned it back on, and this has made LO show recent documents in Windows from the task bar right click menu as well as the Start menu entry.

After re-testing on MacOS I also see recent documents there. So apparently this was a Windows setting issue rather than a LO issue.

(In reply to Jan-Marek Glogowski from comment #7)

> > 2 - There  is an option to pin documents to a list of pinned documents
> 
> That is a completely different enhancement request. I don't know if any OS
> offers support for this in the context of recent document handling (or even
> outside), but I guess that would need some LO-only implementation, to save a
> "pinned documents" list. I don't think these could be available as part of
> the recent file lists. Should be handled in an extra bug report IMHO.

Fair point about pinned documents being a different feature request, given that this turned out to be a Windows setting issue. I will open a separate issue.
Comment 9 V Stuart Foote 2019-09-25 16:08:52 UTC

*** This bug has been marked as a duplicate of bug 76131 ***