Bug 127167 - Draw Print Dialog: Preview gives totally wrong information about the real print
Summary: Draw Print Dialog: Preview gives totally wrong information about the real print
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
: 129990 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2019-08-26 15:11 UTC by Robert Großkopf
Modified: 2021-02-09 14:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Open the document. Shows the screenshots for the reported bug (552.03 KB, application/pdf)
2019-08-26 15:11 UTC, Robert Großkopf
Details
Example Draw document in A2 size (106.05 KB, application/vnd.oasis.opendocument.graphics)
2020-02-12 12:32 UTC, Gabor Kelemen (allotropia)
Details
Print dialog in 6.4 and in my local build (897.38 KB, image/png)
2020-02-12 13:05 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-08-26 15:11:07 UTC
Created attachment 153665 [details]
Open the document. Shows the screenshots for the reported bug

Open the attached document and have a look at the different preview in the dialog for printing with draw since LO 6.3.0.4.
(Sorry for the big screenshots - but the dialog isn't sizeable in GTK3 and fills nearly the whole screen ... another bug).

I have tried to print a page with user-defined 564 mm width and 400 mm height. The dialog sets Page Layout to A4. Values between print preview (356mm/216mm) and A4 (297mm/210mm)doesn't match.
Changed to tab LibreOffice Draw. Changed Size → Distribute on multiple sheets of paper. Preview shows format A4 portrait. The content "Schnellbahnnetz" is shown as format A4 landscape.
Switched to the second paper. It will be shown A4 landscape. The content will also been shown as A4 landscape, but it is (in the document) defined as nearly A2, which is about 4*A4!
Page 3 shows a part of the "Schnellbahnnetz" in A4-landscape. This part is also shown in page 1 and page 2, but it will be originally printed so.
Page 4 will show a part, which is printed in page 3 also.
Back to page 1 now. It will show the right values for A4-landscape and the whole content of "Schnellbahnnetz", which is 564 mm width and 400 mm height. It will be printed as 297 mm width and 210 mm height.

You will get one page, which prints the whole content (as "Fit to printable page") and 3 pages, which will show diffent parts of the first page in the same size, which is much too small.

All tested with LO 6.3.0.4 an OpenSUSE 15 64bit rpm Linux.
Comment 1 Gabor Kelemen (allotropia) 2020-02-12 12:32:59 UTC
Created attachment 157815 [details]
Example Draw document in A2 size
Comment 2 Gabor Kelemen (allotropia) 2020-02-12 12:34:30 UTC
Tried to create a similar example file.

Selecting different options on the LO Draw page of the Print dialog results in the preview page size being reset to A4 no matter the document page size.
Comment 3 Gabor Kelemen (allotropia) 2020-02-12 13:03:45 UTC
Proposed patch: https://gerrit.libreoffice.org/c/core/+/88530

Note, this bug is about several problems. This only fixes the page size being reset to A4 when selecting a sizing option.

The "Distribute on multiple sheets of paper" and "Tile sheet of paper with repeated slides" options still work in funny ways. 
Distribute always tries with distributing to 4 sheets, even if document page size == printer page size and when document page size is twice the printer page size (like printing an A2 document to A3 paper - won't try to pring to 2 but 4 A3 pages).
Comment 4 Gabor Kelemen (allotropia) 2020-02-12 13:05:59 UTC
Created attachment 157816 [details]
Print dialog in 6.4 and in my local build

Opening my example document in 6.4 and in my local build, and selecting "Fit to printable page" option.
Comment 5 NISZ LibreOffice Team 2020-02-17 10:25:50 UTC
*** Bug 129990 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-02-17 15:03:13 UTC
Kelemen Gábor committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/974dc965f2ef581600228ed438d80a3c914ddaf5

tdf#127167 Do not reset Draw/Impress page size

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Robert Großkopf 2020-02-26 20:16:51 UTC
Don't know what should be
"Do not reset Draw/Impress page size".

When I open the same document as created for the bug I could see directly a difference between preview and paper-size. The preview shows 356*216mm, the paper-size shows 210*297mm.

All the other buggy behavior still exists with 
Version: 7.0.0.0.alpha0+
Build ID: fef40fd13ec1739f5308d1ff3bcc2291e7a5d96f
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-02-22_03:27:06
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Only changed behavior: When I set
Changed Size → Distribute on multiple sheets of paper
the wrong paper-size from the start of the dialog is almost there: Legal instead of DIN A4.
Comment 8 Xisco Faulí 2020-07-22 15:17:05 UTC
A polite ping to Gabor Kelemen:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 9 Xisco Faulí 2021-02-09 14:39:24 UTC
Dear Gabor Kelemen,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.