Bug 119470 - PRINTING "Distribute on multiple sheets of paper" doesn't work since 6.1
Summary: PRINTING "Distribute on multiple sheets of paper" doesn't work since 6.1
Status: RESOLVED DUPLICATE of bug 145354
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords: bibisected, bisected, regression
: 130752 132423 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2018-08-24 07:17 UTC by Stefan Wessels
Modified: 2021-11-24 12:03 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file to reproduce the issue (7.95 KB, application/vnd.oasis.opendocument.graphics)
2018-08-30 23:15 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Wessels 2018-08-24 07:17:52 UTC
Description:
The printing option in libreoffice draw for large sheets "Distribute on multiple sheets of paper" doesn't work any more.
Most probably it happened after update to version  6.1.0.3
Instead of distributing the drawing is downsized to fit the page.

Steps to Reproduce:
1.Create new sheet
2.Select - Page - Properties - Format:user
3.Select a large page size e.g. 1000 mm x 200 mm
4. Draw any figure e.g. large rectangle
5. Select - File - Print
6. Under LibreOffice Draw select "Distribute on multiple sheets of paper"

Actual Results:
Figure is distributed on several pages (4) but the size is reduced to fit page

Expected Results:
Figure should be printed in original size on several pages


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-08-30 23:14:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=57991f885e60d04e93bf5004d4fdceee7d29f3d8

author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>	2017-12-12 11:32:06 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-01-23 17:01:31 +0100
commit 57991f885e60d04e93bf5004d4fdceee7d29f3d8 (patch)
tree b4d98d7051eccf14e569f4df243e7192db5f187f
parent c73f88de8bc6f892ff1215c5f634ff0bfca04553 (diff)
tdf#91362: Use document paper size for printing slides.
By default for priniting slides we use not default A4, but size provided
in slide properties.

Additinally renamed IsPageSize() -> IsPaperSize(): it is less ambiguous.


Bisected with: bibisect-linux64-6.1

Adding Cc: to Vasily Melenchuk
Comment 2 Xisco Faulí 2018-08-30 23:15:28 UTC
Created attachment 144565 [details]
file to reproduce the issue
Comment 3 Xisco Faulí 2019-01-24 12:45:22 UTC
This is fixed by the work done by Daniel Silva on the new print dialog.
See -> https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=cb443d07d54d6698eff51b5be2c6b56323f10315..bc0146c2ae43256552c276d2dd86291c98556c42

Version: 6.3.0.0.alpha0+
Build ID: 0d46fb02f3f19d11db40b6c5335d78a3894502d7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as RESOLVED FIXED

Unfortunately, the fix can't be backported. We will need to wait until LibreOffice 6.3 is released...
Comment 4 Stefan Wessels 2019-08-08 11:02:30 UTC
Installed Version 6.3.0.2 under debian linux testing.

Function for printing on multiple pages ist still not working.

Somehow multiple pages are shown inside the preview window.

However the slicing is done improper.

Too many sides generated with big overlaps.
Comment 5 Robert Großkopf 2019-08-26 14:26:29 UTC
Have tested this with LO 6.3.0.4 on OpenSUSE 15 64bit rpm Linux.
Doesn't work. The print will give the whole content on the first page and parts of the content on the other pages.

The new dialog will show different content in the preview when scrolling through the page. 
I open the dialog and it shows in tab LibreOffice Draw when choosing "Distribute on multiple sheets of paper" the portrait-format of the paper A4 of my printer. The document has landscape format A2. The print-preview will print a A4 landscape-format on 2 A4 portrait-format-pages. I could see this when switching to the second page of preview. Going back to the first par shows the preview in landscape-format. It will print the A2-format on a A4-format page.

There isn't fixed a bug with this dialog. There were created new bugs.
Comment 6 Timur 2019-08-27 10:39:57 UTC
This was marked Linux but looks like the problem also in Windows. Test LO 6.4+.
Comment 7 Alexander 2019-11-15 05:43:38 UTC
Tested LO 6.4 on Linux and Windows. Bug is still there.
Comment 8 Andrea Gelmini 2020-02-28 13:12:59 UTC
(In reply to Xisco Faulí from comment #3)
> 
> Closing as RESOLVED FIXED
> 

Are you sure?
If I compile either  6.3.0.0.alpha0+ or commit bc0146c2ae43256552c276d2dd86291c98556c42 (TIP of Daniel Silva patches), I see the same problem.

If I compile 
libreoffice-6.2.8.2 with reverted Vasily patch, it works like a charm.

I keep testing and let you know.

Ciao,
Gelma
Comment 9 pierre-yves samyn 2020-03-11 09:09:29 UTC
Hi

Stills reproduced with Version: 6.4.1.2 (x64)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; 
UI render: default; VCL: win; 
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: CL

Regards
Pierre-Yves
Comment 10 Buovjaga 2020-05-11 13:11:15 UTC
*** Bug 130752 has been marked as a duplicate of this bug. ***
Comment 11 Jean-Baptiste Faure 2020-05-23 16:19:09 UTC
This bug is a result of the fix for bug 91362. I asked (https://bugs.documentfoundation.org/show_bug.cgi?id=91362#c23) to revert this fix as it removes an useful functionality, but didn't get an answer.

Best regards. JBF
Comment 12 ace_dent 2020-06-15 19:46:39 UTC
*** Bug 132423 has been marked as a duplicate of this bug. ***
Comment 13 Donald Cram 2020-10-08 03:16:52 UTC
Hi. This is very irritating!  I spent hours in total, trying to print a single poster across a 2x2 set of pages, first in LibreOffice 6.2.8.2 and then installing and trying LibreOffice 6.4.6.  I verify that bug occurs in both LibreOffice Draw and in LibreOffice Impress, on my computer running Windows 10.  Perhaps this helps describe the problem:
1. My "Page" or "Slide" image has dimensions changed to almost double a regular letter sized sheet (by going to "Page" or "Slide"/ "Properties", then changing the dimensions).  I entered large size text which fills it up, basically what should be printed out on a 2x2 array of letter-sized paper.  I want this to print out onto 4 letter-sized sheets which I can tape together.
2. It looks like the program correctly identifies the 4 starting points out my big image, i.e. the four points in the big image which should be at the top left points of the four pages.  But then it prints the image reduced to letter page size, when it should print (in full size) only the portion of the image which fits going down and to the right.
More specifically, on the first page, it starts at the image's top left but prints a letter-sized reduction of the whole image, when it should only print the top left quarter of it in the same space.  On the second page, it starts properly midway across the image, but again prints in reduced size, rather than full size, so the result is basically the right half of the top half of the image, and then blank space.  On the third page it starts at the right point, halfway down the the left side of the image, but it prints in reduced size, so basically is printing the lower half of the image and then blank space.  On the fourth page, it starts printing at the correct point, halfway across and halfway down the image, and it should print the bottom right quarter of the image in full size, but instead it prints that in reduced size, and then blank space.
Depending on how the program expresses it, maybe you just need to fix calculation of the four bottom right points on the image that are to appear at the bottom right of the four pages.  For the first page, the correct bottom right point on the image would be a point about half way down and half way to the right.  And not the bottom right point of the image.

Hopefully this helps you see where calculations in the program are going wrong.
Don
Comment 14 Donald Cram 2020-10-08 03:17:35 UTC Comment hidden (obsolete)
Comment 15 Stephane Santon 2020-11-14 13:59:53 UTC
Hi, 
Always waiting for this bug resolution.
Using LO Draw 6.4, 7.0, ... on Windows
Comment 16 Simon Coleman 2021-02-13 17:23:53 UTC
Fails for me too, ubuntu 20.04, LibreOffice 6.4.6.2 
The distribution of the printable content is poor across several pages. 

I expected to be able to keep the print dimensions (in mm) from the document and have the large (eg, A3 source) split across multiple smaller printable pages (eg, A4)

The preview suggests both that the document will be scaled to the printer page and aligned poorly.
Comment 17 Justin L 2021-11-23 18:12:09 UTC
- if (mpOptions->IsPageSize())
+ if (mpOptions->IsPrinterPreferred())
Comment 18 Justin L 2021-11-24 08:54:39 UTC
(In reply to Justin L from comment #17)
> - if (mpOptions->IsPageSize())
> + if (mpOptions->IsPrinterPreferred())
{ // Then scale everything to print on the page }

IsPageSize == "Fit to Printable Page"
Well, it is just wrong to "scale everything to page" just because we want to use the paper size from the printer.


IsPrinterPreferred() == "Fit to Printable Page" or Impress Notes/handout/outline (but not slides) or "Distribute on multiple sheets of paper" or "Tile piece of paper with repeated slides" or isBooklet.

The commit totally changed which Impress views preferred to use the printers suggested paper size.  What should be happening in each of these cases?

DRAW: document definition should always win out in general (so not IsPrinterPreferred). That is already true
-exception: isbooklet / isTiled / isFitToPage would use the printer defined paper size. That is also already true.

IMPRESS: 
-slides: page definition is basically irrelevant - for screen purposes and should be treated as "Fit to Printable Page", and thus should prefer printer size (not currently true but was true before comment 1).
-handouts: should use master handout slide setting. (never was true - but I think it should.)
-notes: should use master notes setting. (not currently true, but was true before comment 1)
-outline: should prefer printer size. (is/was true)


Proposed revert in http://gerrit.libreoffice.org/c/core/+/125751
Comment 19 Justin L 2021-11-24 09:57:18 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3a6b9e3bc1a2854783811f1cfa86db6592685930

tdf#145354: Revert "tdf#91362: Use document paper size for printing slides"

It will be available in 7.3.0.

*** This bug has been marked as a duplicate of bug 145354 ***