Bug Hunting Session
Bug 127180 - Firebird: propose migration + Firebird by default only in experimental
Summary: Firebird: propose migration + Firebird by default only in experimental
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.2
Keywords:
Depends on:
Blocks: Database-Firebird-Default Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2019-08-27 08:31 UTC by Julien Nabet
Modified: 2019-09-08 18:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2019-08-27 08:31:48 UTC
Description:
Following discussion in http://document-foundation-mail-archive.969070.n3.nabble.com/About-putting-back-Firebird-experimental-td4265392.html#a4265519, we should put back the two following elements in experimental:
- Migration hsqldb -> Firebird
- Propose Firebird by default when creating a new DB

Steps to Reproduce:
N/A

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-08-28 20:15:42 UTC
I submitted this patch on review:
https://gerrit.libreoffice.org/#/c/78240/

It works for me but perhaps it's not optimal or I may have generated some side effect.
Would like some review.
Comment 2 Commit Notification 2019-08-29 18:55:32 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2252aba08121566e834dc530f31339e15bd94dec%5E%21

tdf#127180: Propose migration + Firebird by default only in experimental

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Julien Nabet 2019-09-02 18:41:43 UTC
Fixed on master.
Don't know if it should be backported in 6.3.
Comment 4 Xisco Faulí 2019-09-04 12:06:19 UTC
I don't see the point of putting it in experimental in master and not doing it in libreoffice 6.3. I would have done it the other way around, put it in experimental in 6-3 and leave it as it's in master so it can be tested and improved...
We did the same in 6.2 < https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-2&id=7991a4d718c282f1fd999e76f683e333b5c220af > and 6.1 < https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-1&id=0b3ee8ffbb6b33827c17af56c62dc5285f3ba258 >
Comment 5 Julien Nabet 2019-09-04 12:40:50 UTC
(In reply to Xisco Faulí from comment #4)
> I don't see the point of putting it in experimental in master and not doing
> it in libreoffice 6.3. I would have done it the other way around, put it in
> experimental in 6-3 and leave it as it's in master so it can be tested and
> improved...
> ...
Done here https://gerrit.libreoffice.org/#/c/78597/ as you may have seen.

To test Firebird on master, we just have to put enable experimental. At least, we're sure now that there won't be a new version for the moment with Firebird enabled by default whereas there are quite some nasty bugs.
Comment 6 Xisco Faulí 2019-09-04 13:28:07 UTC
(In reply to Julien Nabet from comment #5)
> (In reply to Xisco Faulí from comment #4)
> > I don't see the point of putting it in experimental in master and not doing
> > it in libreoffice 6.3. I would have done it the other way around, put it in
> > experimental in 6-3 and leave it as it's in master so it can be tested and
> > improved...
> > ...
> Done here https://gerrit.libreoffice.org/#/c/78597/ as you may have seen.
> 
> To test Firebird on master, we just have to put enable experimental. At
> least, we're sure now that there won't be a new version for the moment with
> Firebird enabled by default whereas there are quite some nasty bugs.

it was agreed in the ESC meeting to release 6.3 with the firebird migration enabled by default, it's not that we forgot to disable it before the release...
Comment 7 Julien Nabet 2019-09-04 13:35:54 UTC
(In reply to Xisco Faulí from comment #6)
> ...
> it was agreed in the ESC meeting to release 6.3 with the firebird migration
> enabled by default, it's not that we forgot to disable it before the
> release...

I don't understand what you mean, do you want I backport the patch on 6.3 branch? yes/no ?
About master branch, I thought it was ok to put back Firebird at experimental since we're not ready obviously. If there are as still many Firebird bugs for 6.4.0, I think we should let Firebird in experimental only (See first link for rationale + reactions of other QA DB people).
Comment 8 Xisco Faulí 2019-09-04 13:42:45 UTC
IMHO, I just think it should have been discussed in the ESC meeting before any action was taken...
Comment 9 Julien Nabet 2019-09-04 13:52:52 UTC
(In reply to Xisco Faulí from comment #8)
> IMHO, I just think it should have been discussed in the ESC meeting before
> any action was taken...

I abandoned the cherry-pick for 6.3. (I just noticed the release notes https://wiki.documentfoundation.org/ReleaseNotes/6.3/en indicating migration is by default option).

About master, if someone wants to revert it, no problem but I won't do this myself since I'm strongly against it because of all the reasons I quoted.
Comment 10 Commit Notification 2019-09-06 11:03:19 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/463419f3f415061db443d7b98b603f9f24a11c3d%5E%21

tdf#127180: Propose migration + Firebird by default only in experimental

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.