Bug 127186 - scalable underbrace/overbrace too short to be legible inside sm Node (Directwrite OpenGL issue)
Summary: scalable underbrace/overbrace too short to be legible inside sm Node (Directw...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 32362 103322
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2019-08-27 13:52 UTC by VincentYu
Modified: 2020-08-28 16:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sm Formula with overbrace and underbrace looks OK (30.10 KB, image/png)
2019-08-28 04:02 UTC, V Stuart Foote
Details
underbrace rendering (419.84 KB, image/png)
2019-08-28 11:38 UTC, VincentYu
Details
starmath formula with size 2 OLE inserted to Writer page (33.14 KB, image/png)
2019-08-28 13:16 UTC, V Stuart Foote
Details
with OpenGL rendering (nVidia GPU & driver) underline (8.29 KB, image/png)
2019-08-28 22:15 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VincentYu 2019-08-27 13:52:32 UTC
It's so narrow that in normal resolution it's distorted into garbage. Should have bigger height or adjustable height.
{some text here}underbrace {f}
Comment 1 VincentYu 2019-08-27 22:29:12 UTC
It's more serious when you zoom out to see 100% of the page.
Tried to insert it into draw and then export as pdf. It looked ok either zoomed in or out. So this is probably a display/rendering problem with LO.
Comment 2 V Stuart Foote 2019-08-28 04:02:33 UTC
Created attachment 153695 [details]
sm Formula with overbrace and underbrace looks OK

Can not confirm on Windows 10 Home 64-bit en-US (1903) with
recent master Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

The overbrace and underbrace render fully into the layout box for their node, height is correct. And the node scale correctly in response to size # {} specification.
Comment 3 VincentYu 2019-08-28 11:38:24 UTC
Created attachment 153703 [details]
underbrace rendering

here is the screen shot. If you zoom out further, it'll become some garbled lines.
Comment 4 V Stuart Foote 2019-08-28 13:13:48 UTC
We do not use multi-glyph composites for scalable brackets (bug 32362), so a single glyph is being stretched to fit into the box holding its node. That coupled with sm nodes placement also not using floating point to canvas (bug 103322) means that at small sizes the node and its glyph(s) will appear misallined with other nodes of the formula. Believe this is expected.

I can confirm that the underbrace node in sm example "a + b+c " this is a test " xyz} underbrace {f}" is not well alligned at smaller size--but at the 'Show all' scaling in sm the node box is the full width of the formula string, and the underbrace glyph is correctly scaled and centered in the node. 

None the less the formula is well formed when inserted to Writer canvas as OLE with a diminutive  "size 2 {}"

So, this is WFM; but needs improvement that only bug 32362, and bug 103322 would bring. This is IMHO => NAB
Comment 5 V Stuart Foote 2019-08-28 13:16:43 UTC
Created attachment 153711 [details]
starmath formula with size 2 OLE inserted to Writer page

starmath formula with size 2 OLE inserted to Writer page, scalable underbrace node well formed on document canvas at the lower end of its usable sizing.
Comment 6 VincentYu 2019-08-28 21:40:07 UTC
(In reply to V Stuart Foote from comment #5)
> Created attachment 153711 [details]
> starmath formula with size 2 OLE inserted to Writer page
> 
> starmath formula with size 2 OLE inserted to Writer page, scalable
> underbrace node well formed on document canvas at the lower end of its
> usable sizing.

May I ask what is the tech spec of your monitor(size,resolution)?
Mine is Dell 24" 1920x1200.
Maybe it's caused by pixel density too low?
Comment 7 V Stuart Foote 2019-08-28 22:15:17 UTC
Created attachment 153723 [details]
with OpenGL rendering (nVidia GPU & driver) underline

(In reply to VincentYu from comment #6)
> (In reply to V Stuart Foote from comment #5)
> > Created attachment 153711 [details]
> > starmath formula with size 2 OLE inserted to Writer page
> > 
> > starmath formula with size 2 OLE inserted to Writer page, scalable
> > underbrace node well formed on document canvas at the lower end of its
> > usable sizing.
> 
> May I ask what is the tech spec of your monitor(size,resolution)?
> Mine is Dell 24" 1920x1200.
> Maybe it's caused by pixel density too low?

Laptop Lenovo Flex4 15" Full HD 1920x1080 on a Intel HD 630 GPU, current Intel drivers. Same rendering both OpenGL and CPU or HA

On an office system 1920x1200 on an nVidia Quadro K2000 with 23.21.13.9133 driver, I do see some misrendering of the underbrace glyph when stretched to fit, it is stamped outside its node box, shifted to the right.

attached
Comment 8 Xisco Faulí 2019-09-18 11:09:58 UTC
it seems related to bug 127483
Comment 9 Buovjaga 2020-08-28 13:13:13 UTC
As Skia with Vulkan will replace OpenGL UI rendering on all platforms, it does not make sense to keep OpenGL UI reports open.

Details about Skia: https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/
Comment 10 V Stuart Foote 2020-08-28 16:17:02 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a486fd929d4b3e915f928ef495b6cb2b96d74a3a
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

When activated via expert configuration, the OpenGL rendering issues remain as reported here and dupes--but those issues are not evident with Skia Vulkan rendering.

So given deprecation of OpenGL rendering issue => WF