Bug 127244 - Some figures do not appear in this .docx file
Summary: Some figures do not appear in this .docx file
Status: RESOLVED DUPLICATE of bug 123435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-08-30 15:33 UTC by Frederic Parrenin
Modified: 2020-09-03 08:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (5.08 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-02 15:21 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2019-08-30 15:33:25 UTC
Steps to reproduce:
- open the following .docx file in both Writer and MS-Office (2013)
https://mycore.core-cloud.net/index.php/s/UNFYpy4ZR6ipZgp/download
=> Figures 2, 3, 4 and 5 do not appear in Writer.
Comment 1 Frederic Parrenin 2019-08-30 15:37:50 UTC
Correction: it is actually Figures 1, 2, 4 and 5 which do not appear.
Comment 2 Durgapriyanka 2019-08-30 21:05:29 UTC
Thank you for reporting the bug. I can confirm the bug present in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

and in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-09-02 15:21:15 UTC
Created attachment 153818 [details]
sample file
Comment 4 Xisco Faulí 2019-09-02 15:24:06 UTC
No reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

thus, this is a regression
Comment 5 Xisco Faulí 2019-09-02 15:29:20 UTC
Regression introduced by https://gerrit.libreoffice.org/plugins/gitiles/core/+/3272c1eb5563f3bda2caa24f32b1018372622109%5E!/ which is the same as in bug 123435

*** This bug has been marked as a duplicate of bug 123435 ***
Comment 6 Timur 2020-09-03 08:22:20 UTC
Graphics OK. 
There's small issue with font in caption shape, I mentioned in bug 100074.