Download it now!
Bug 127307 - odt document bookmarks disappear if saved as HTML
Summary: odt document bookmarks disappear if saved as HTML
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-03 08:47 UTC by kevin seslar
Modified: 2020-07-12 06:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kevin seslar 2019-09-03 08:47:44 UTC
Description:
LibreOffice v6.3 when FILESAVE "save as HTML" the output document has no bookmark links targeting within i.e. bookmarking into the html document itself in tables.  (Inconsistent - bookmarks at very start of document sometimes will remain to become links in output htm file - very rarely).  HTML "links" in original document (to external targets) are carried through the "save as" perfectly.  I reinstalled v6.2.6.2 & it works perfectly porting bookmarks to links in output file. 

Steps to Reproduce:
1. In Writer (.odt) file & add table & add words in some of table squares.
2. Select entire word only (not entire square), create bookmark(s).
3. Select different unused word(s) and create hyperlink to bookmarks created in step 2.  Save document as type .odt and HTML (yielding two files).

Actual Results:
Open HTML file with Chrome / IE browser.  Clicking on hyperlinks within table does not "link" to bookmarks created in LibraOffice Writer v6.3.  In the odt file type the bookmarks and hyperlinks work as expected.  

Expected Results:
If HTML file is created with LibraOffice Writer v6.2.6.2 the links to "internal to document" bookmarks works, this is expected.  For LibraOffice Writer v6.3 these destination bookmark links will not exist in the output HTML document, that is not expected.     



Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
In v6.2, bookmarks created to text entered into table squares and the links to those bookmarks (all in the same document) will be saved as destination links (and hyperlinks) in the associated "save as HTML" output files [good].

Open GL Report is 100% enabled at v4.6 (WIN10PRO)

From Help - About LibraOffice information is unavailable, I've reinstalled v6.2 which does work, because v6.3 did not work.  Sorry I didn't get the v6.3 help information.

I'm 60 years old, in my entire life I've never experienced a profile corruption issue on any of my computers.  This is not a problem that resetting my profile will fix.
Comment 1 kevin seslar 2019-09-03 08:53:24 UTC Comment hidden (obsolete)
Comment 2 Julien Nabet 2019-09-03 15:10:17 UTC Comment hidden (obsolete)
Comment 3 Dieter 2019-09-04 20:04:26 UTC Comment hidden (obsolete)
Comment 4 kevin seslar 2019-09-05 01:15:39 UTC
OK, I have to install LOv3 on a different computer because I can't get my main machines oos with v3 - so this will take awhile.  It's going to take 4 files, the before and after picture i.e. before odt file and after html file; that is one of each from v2.6 and one of each from v3.  Let me work on it.  Thank you.
Comment 5 QA Administrators 2019-09-05 09:35:32 UTC Comment hidden (obsolete)
Comment 6 kevin seslar 2019-10-26 08:16:19 UTC
Awesome work guys, thank you!  Consider this bug squashed (I have circumvented it by not using that functionality anymore) BUT imho additional documentation would be nice & would have saved me weeks of work.  Admit I did not go straight to testing for problem resolution, so this has haunted me for months perhaps.  But I figured it out.  Thank you again. 

I don't know how to request additional/change to existing documentation, but allow me to suggest it here please:  Request a paragraph or note added to either Writers Guide 6.0 (existing) Note page 78, or Getting Started Guide 6.0 (existing) Note/Tip page 338; at the end of one of those Note(s) something like: 

“Also, if relative links are enabled (via the menu Tools > Options > Load/Save > General, e.g. with only “save URLs relative to the local file system” checkbox checked) be advised that if the file is saved to a different location than it was originally saved to:  The file save operation will automatically attempt to retain the original destination for all the (document file) links, and that save operation will change all the original relative links into absolute URL links. This is expected design behavior and it is not unique to LibreOffice.  If any of the links are “Web” or internet links, then LibreOffice will not try to change them, as they were not relative links to begin with.  So if you desire to retain relative paths in the document for hyperlinks to other files:  first save the document then copy and paste the document (along with the linked files & path) to the new location/directory.  That will ensure that the “save to new location” behavior does not change the relative hyperlink destinations into absolute URLs for the LibreOffice document when the document will be opened in a different path/directory.”
Comment 7 Julien Nabet 2019-10-26 10:37:01 UTC
Olivier: thought you might be interested in this one, indeed what about  recycling this bugtracker as documentation issue?
Comment 8 Olivier Hallot 2019-10-30 14:06:08 UTC
(In reply to Julien Nabet from comment #7)
> Olivier: thought you might be interested in this one, indeed what about 
> recycling this bugtracker as documentation issue?

Done.
Comment 9 Timur 2019-11-18 12:39:35 UTC
I understand this is Fixed as Documentation.
But until it'c clear where, I'll just set as New.