Download it now!
Bug 45589 - Show bookmarks: make them visible in a document
Summary: Show bookmarks: make them visible in a document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.0.0
Keywords: needsUXEval
: 46998 89568 (view as bug list)
Depends on:
Blocks: Writer-UX Bookmarks
  Show dependency treegraph
 
Reported: 2012-02-03 04:36 UTC by Gilvan Vilarim
Modified: 2020-06-14 11:03 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
text document with bookmarks (8.95 KB, application/vnd.oasis.opendocument.text)
2012-03-16 07:54 UTC, sasha.libreoffice
Details
bookmarks in ms word (9.86 KB, image/png)
2015-09-08 11:16 UTC, Yousuf Philips (jay) (retired)
Details
ms Word book mark representation (100.34 KB, image/png)
2019-10-20 05:49 UTC, zionoto
Details
Small test document to show problem of copying from 6.3.x to 7.0.0.0 (9.21 KB, application/vnd.oasis.opendocument.text)
2020-02-12 16:48 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilvan Vilarim 2012-02-03 04:36:07 UTC
Writer should let the user see where are text bookmarks. Bookmarks could be treated as non-printable characters. When user clicked on the "pi" button, there could be some kind of visual effect to show bookmarks inside the document, just like tabs and paragraphs.

Best regards,
Gilvan.
Comment 1 sasha.libreoffice 2012-03-16 07:54:53 UTC
Created attachment 58563 [details]
text document with bookmarks
Comment 2 sasha.libreoffice 2012-03-16 07:59:54 UTC
I agree that some indicator that bookmark is in text would be useful.
Comment 3 Gilvan Vilarim 2014-05-13 01:58:39 UTC
You can see bookmarks with the Navigator (F5 key), but you do not know which part of text contains a bookmark (unless you click on the bookmark itself).

A visual symbol would be useful, just like annotations.

Best regards,
Gilvan.
Comment 4 Björn Michaelsen 2015-07-05 07:14:34 UTC
*** Bug 89568 has been marked as a duplicate of this bug. ***
Comment 5 Björn Michaelsen 2015-07-05 07:15:44 UTC
*** Bug 46998 has been marked as a duplicate of this bug. ***
Comment 6 Yousuf Philips (jay) (retired) 2015-09-08 08:38:42 UTC
Dont think that it would be good to tie it in with non-printable characters, as we would want this feature on by default and not all users toggle the "pi" button. Google Docs is the only word processor that shows bookmarks and it does so in the margins, similar to how we show line numbers (attachment 113660 [details]).
Comment 7 Cor Nouws 2015-09-08 09:09:32 UTC
Hi Jay,

(In reply to Yousuf (Jay) Philips from comment #6)
> Dont think that it would be good to tie it in with non-printable characters,
> as we would want this feature on by default and not all users toggle the
> "pi" button.

Users are pretty keen on being able to handle settings for e.g. showing page margins apart from non printable characters. I could imagine the same with bookmarks? 

Say  Options > Writer > Formatting Aids ... Display of: [ ] Bookmarks

(For me, it's no problem to have it combined with no printable characters.)

> Google Docs is the only word processor that shows bookmarks and

From what I remember Word had a setting to to show bookmarks.

> it does so in the margins, similar to how we show line numbers (attachment
> 113660 [details]).

In the text is the only thing that makes sense, IMO. Bookmarks can be single points and selections. Bookmarks are (also) used to mark pieces in the text for referencing, filling, ... So only an indicator in the margin, would not help.
Comment 8 Yousuf Philips (jay) (retired) 2015-09-08 11:16:14 UTC
Created attachment 118519 [details]
bookmarks in ms word

(In reply to Cor Nouws from comment #7)
> Hi Jay,

Hi Cor,

> Users are pretty keen on being able to handle settings for e.g. showing page
> margins apart from non printable characters. I could imagine the same with
> bookmarks? 

Yes it should be a setting configurable by itself.

> Say  Options > Writer > Formatting Aids ... Display of: [ ] Bookmarks

Yes that would be a good place for it in the Options dialog, but it should also be in the View menu.

> From what I remember Word had a setting to to show bookmarks.

Yes you are correct that Word has it, but it isnt on by default and you have to go into its options dialog to turn it on. I've attached a screenshot of how it looks when its bookmarked at the beginning and end of a line as well as on a selection.

> In the text is the only thing that makes sense, IMO. Bookmarks can be single
> points and selections. Bookmarks are (also) used to mark pieces in the text
> for referencing, filling, ... So only an indicator in the margin, would not
> help.

Placing it in the text would cause it to mix with other stuff, e.g. comments, and would result in it not looking good, i assume thats why its turned off by default in ms word. Also bookmarks in html documents can only be positioned at the beginning of a line. The main point of the marker in the margin would be to let you know that there is a bookmark on that line. Never used bookmarks before trying them out in google docs and presentation of it was very user friendly and quite easy to understand.
Comment 9 Cor Nouws 2015-09-08 12:15:08 UTC
(In reply to Yousuf (Jay) Philips from comment #8)
> Yes that would be a good place for it in the Options dialog, but it should
> also be in the View menu.

Good :)


> Yes you are correct that Word has it, but it isnt on by default and you have
> to go into its options dialog to turn it on. I've attached a screenshot of

Indeed, well hidden ;)

> Placing it in the text would cause it to mix with other stuff, e.g.
> comments, and would result in it not looking good, i assume thats why its
> turned off by default in ms word.

yes...

> Also bookmarks in html documents can only
> be positioned at the beginning of a line.

... ok..

> The main point of the marker in
> the margin would be to let you know that there is a bookmark on that line.

No  :)

> Never used bookmarks before trying them out in google docs and presentation
> of it was very user friendly and quite easy to understand.

In business (templates mostly) bookmarks may be used frequent for reasons that I mentioned. And then the exact position does matter. I you are editing in a line and need to be careful for a bookmark, it's nice to know were it is.

Still, a indicator in the margin is better than nothing, of course.
Comment 10 Manuel Lopez-Ibanez 2015-10-20 14:09:29 UTC
(In reply to Cor Nouws from comment #9)
> (In reply to Yousuf (Jay) Philips from comment #8)
> > Never used bookmarks before trying them out in google docs and presentation
> > of it was very user friendly and quite easy to understand.
> 
> In business (templates mostly) bookmarks may be used frequent for reasons
> that I mentioned. And then the exact position does matter. I you are editing
> in a line and need to be careful for a bookmark, it's nice to know were it
> is.

My current user-case. Hyperlinking citations within a text to a list of references. Using cross-references for this doesn't work since there is no way to edit the text used in the citation. My list of references is double-column, thus it would be very useful to see which bookmark name I have associated to each entry in case I end up editing the entry or two entries that could have very similar bookmark name.
Comment 11 Robinson Tryon (qubit) 2015-12-13 11:24:16 UTC Comment hidden (obsolete)
Comment 12 Leopoldo Saggin 2015-12-21 18:23:47 UTC
In order to show bookmarks into LibreOffice I'm still using an extension which was released for [Sun] OpenOffice, ie "Visible Bookmarks" by Rup.Xamqon which you can get from:
http://extensions.openoffice.org/en/project/visiblebookmarks
I translated it into Italian and this is why I know it. It is far from perfect, but it works. It was released by the author as a patch for this problem which was already present (and still not solved) in OpenOffice and he invited to vote for the solution of this bug also in its "Help" which integrates with OOo/LibO Help.

My 2 cents tip.
Topoldo
Comment 13 Cor Nouws 2017-09-02 10:07:32 UTC
A recent extension is this one
  https://extensions.libreoffice.org/extensions/bookmark-toggle
Comment 14 Nicolas Göddel 2019-08-26 15:21:19 UTC
My coworkers would really appreciate it if they would be able to show bookmarks without changing the layout like it happens when one enables field names. They often delete bookmarks in a 2000+ pages document without even noticing it. The bookmarks are there for the subject catalog at the end of the document. This especially happens if a bookmark is at the beginning of a paragraph.

I think it would be enough to make bookmarks visible like variable setters, non-breaking spaces or somehow similar.
Comment 15 mace 2019-10-03 14:53:02 UTC
I also support this request. My use case are citations in Zotero. In order to increase the compatibility with MSoffice users, I use the option to insert Zotero citations as bookmark (fields are the standard). This enables me to share my LO produced documents with MSoffice users much easier. However, the downside is that its very hard to know where the citations are. I would therefore support that bookmarks can be highlighted in grey in the same way as fields can be.
Comment 16 Cor Nouws 2019-10-03 21:21:52 UTC
For all people/teams that really would love to have this (without extension):
apart from coding yourself, there are wonderful developers that may be hired for nice improvements in LibreOffice.
  https://www.libreoffice.org/get-help/professional-support/
Comment 17 zionoto 2019-10-20 05:49:26 UTC
Created attachment 155159 [details]
ms Word book mark representation
Comment 18 zionoto 2019-10-20 05:54:54 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #6)
> Google Docs is the only word processor that shows bookmarks 

MS word has the possibility to show bookmarks as non printable chars: the bookmarks are represented by square brackets as follows: [bookmarked text] please see the attached screenshot I have just tested.
Comment 19 Michael Stahl (CIB) 2020-01-30 13:18:15 UTC
i've implemented something, will push to master now, please test...
Comment 20 Commit Notification 2020-01-30 13:19:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ef8427d12a63127a2eb867637699343d630545dd

tdf#45589 sw: invalidate on bookmark insertion/deletion

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-01-30 13:20:01 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/46e04a712e97f9095ef4da7f0e52f50cf2bfbb32

tdf#45589 sw: add bookmarks to SwScriptInfo

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-01-30 13:22:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2817f07fdd942cea6574043971534bf089b527ce

tdf#45589 sw: split text portions at bookmarks

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2020-01-30 13:38:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ce8120f1e53f7b81e653b01d141643013bc69ab

tdf#45589 sw: create and paint text portions for bookmarks

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2020-01-31 16:27:23 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/04405edc3fac32938b8940bc767656ea6c7820f9

tdf#45589 offapi,officecfg,sw: add option to toggle bookmark display

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 sdc.blanco 2020-02-02 13:07:33 UTC
Thanks for the big work needed to make these bookmark shadings!
A little random feedback:
-Able to see field shading with bookmarks.
-Able to change colors (for field shadings) in Options (and have it appear on bookmark fields)
-Able to "toggle" appearance of bookmark fields using Options dialog
(could not see that it was possible to make an accelerator key assignment or toolbar icon to toggle assignment)

(also noticed that if bookmark was applied to several characters (shown with []), then it was hard to delete it with a backspace, compared to a single space (shown with | )  (could be useful enhancement to be able to select a word, and then have "Insert bookmark" to automatically copy that word into the "Insert Bookmark" dialog.)
Comment 26 Commit Notification 2020-02-06 12:01:45 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c0b7fe8281319146c4a2e36e203cfd65633ce3bd

tdf#45589 sw: don't paint field shading for bookmarks

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 sdc.blanco 2020-02-06 13:15:04 UTC
(In reply to Commit Notification from comment #26)
> tdf#45589 sw: don't paint field shading for bookmarks
More random feedback from a random naive user with 7.0.0.0.alpha0+ (x64)
Build ID: dfd027342e6b4107ebd3369de96ef2be3883724d  -- not trying to suggest anything -- just feedback. (I am sure that many who use bookmarks will be happy for this new capability.)

1. Understand now that Ctrl-F10 (View Formatting Marks) toggles appearance of bookmarks.  (WFM -- but I get the impression from comment 6 and comment 8 that UX thinks it should be a separate toggle.  Maybe file a new bug report if you are not interested.)

2. Field shadings. (I may be the only one who gets to try pink bookmarks. (-: )
a. Toggling "Field Shading" (Ctrl-F8) does not affect bookmark shading.  
   (i.e., variables, nonbreaking spaces, etc. disappear, but not bookmarks) (WFM)

b. Try "Insert>Formatting Mark>Insert soft hyphen (or "Insert non-breaking space").  
   (with field shading on, these look a lot (too much?) like a bookmark.
    could actually be useful to give bookmark a different color! - but not linked to "field shadings" -- also given that ctrl-F8 (toggle field shading) does not affect visibility of bookmark.)

Julian Nabet made a patch recently with Application Colors for sections (bug #129905).  It might/should be possible to make a separate entry in Application Colors for bookmarks (like those for "Field Shading" and "Section boundaries" to control the color of the bookmarks).  OBS. at present, the on/off "checkbox" for Field Shadings and Section do not work to turn off the selected color.

3.  Comment 6 suggests that the bookmark option (in Tool-Options) should be set "on" as default.
Comment 28 sdc.blanco 2020-02-06 13:32:07 UTC
When the dust settles, I was going to update the help page: 
https://help.libreoffice.org/7.0/en-US/text/shared/optionen/01040600.html
which introduced the question about whether bookmark shading should also appear in HTML documents. (my own attempt shows that the bookmarks are placed at the beginning of the sentence of the .html file, does not keep specific positions or ranges.)

And a small UI problem: 

Tools>Options>LO Writer/Web>Formatting Aids  - Display formatting 
    the | [] signs are shown, but no label appears.
Comment 29 sdc.blanco 2020-02-06 13:41:21 UTC
(In reply to sdc.blanco from comment #27)
> present, the on/off "checkbox" for Field Shadings and Section do not work to
> turn off the selected color.
Correction:  The on/off checkbox for Field Shadings does work (for fields), but not for bookmarks (in the dfd027342e6b4107ebd3369de96ef2be3883724d build). 
(bug #129905 is for sections)
Comment 30 Cor Nouws 2020-02-06 20:11:43 UTC
(In reply to sdc.blanco from comment #27)
> More random feedback from a random naive user with 7.0.0.0.alpha0+ (x64)
Know that it's much appreciated :)
Comment 31 Michael Stahl (CIB) 2020-02-12 11:12:32 UTC
(In reply to sdc.blanco from comment #27)
> 1. Understand now that Ctrl-F10 (View Formatting Marks) toggles appearance
> of bookmarks.  (WFM -- but I get the impression from comment 6 and comment 8
> that UX thinks it should be a separate toggle.  Maybe file a new bug report
> if you are not interested.)

yes, tying it to formatting marks was easiest to implement for now, and i wasn't quite sure to what extent the comments here were individual opinions and to what extent they were a consensus of UX team...

> Julian Nabet made a patch recently with Application Colors for sections (bug
> #129905).  It might/should be possible to make a separate entry in
> Application Colors for bookmarks (like those for "Field Shading" and
> "Section boundaries" to control the color of the bookmarks).  OBS. at
> present, the on/off "checkbox" for Field Shadings and Section do not work to
> turn off the selected color.

possible, but it turns out the color for the pilcrow glyph at the end of the paragraph is hardcoded, so i just used the same color for now.

> 3.  Comment 6 suggests that the bookmark option (in Tool-Options) should be
> set "on" as default.

oh, it's not on by default? ... no i just started with fresh UserInstallation and it is on for me (the Formatting Marks button is off by default).


> Tools>Options>LO Writer/Web>Formatting Aids  - Display formatting 
>    the | [] signs are shown, but no label appears.

not sure what you mean, where should a label appear?

it says "[x] Bookmarks     | [ ]" here

do you mean a tooltip? i dont get any for the other options...
Comment 32 sdc.blanco 2020-02-12 12:57:39 UTC
(In reply to Michael Stahl (CIB) from comment #31)
> yes, tying it to formatting marks was easiest to implement for now, and i
> wasn't quite sure to what extent the comments here were individual opinions
> and to what extent they were a consensus of UX team...
Removing needsDevEval
Adding needsUXEval with cc to Design team

> > Tools>Options>LO Writer/Web>Formatting Aids  - Display formatting 
> >    the | [] signs are shown, but no label appears.
> 
> not sure what you mean, where should a label appear?
Critical difference (in Tools-Options dialog)

For LibreOfficeDev Writer - Formatting Aids
                   ^^^^^^
> it says "[x] Bookmarks     | [ ]" here
Confirmed.

For LibreOfficeDev Writer/Web - Formatting Aids
                   ^^^^^^^^^^
it says (only):         | []

> do you mean a tooltip? 
No -- but now that you ask -- it might be friendly to have a tooltip that explains the meaning of  | [] 
(not quite sure how to say it:
Here is a bad attempt meant to inspire improvement: 
  | indicates a single character bookmark, [] indicates a bookmark over a range of characters
Comment 33 Michael Stahl (CIB) 2020-02-12 13:27:00 UTC
(In reply to sdc.blanco from comment #32)

> For LibreOfficeDev Writer/Web - Formatting Aids
>                    ^^^^^^^^^^
> it says (only):         | []

oh, i didn't notice the "Web" ... should be fixed with https://gerrit.libreoffice.org/c/core/+/88535

> > do you mean a tooltip? 
> No -- but now that you ask -- it might be friendly to have a tooltip that
> explains the meaning of  | [] 
> (not quite sure how to say it:
> Here is a bad attempt meant to inspire improvement: 
>   | indicates a single character bookmark, [] indicates a bookmark over a
> range of characters

hmm unfortunately i don't know how to put a tooltip on a dialog...
Comment 34 sdc.blanco 2020-02-12 14:55:19 UTC
(In reply to Michael Stahl (CIB) from comment #33)
> hmm unfortunately i don't know how to put a tooltip on a dialog...
Since the paint is still wet....

Should it go over the signs ( | [] ) themselves?  In that case, put this property 

<property name="tooltip_text" translatable="yes" 
context="optformataidspage|bookmarks_label|tooltip_text">TOOLTIP TEXT GOES HERE</property>

in the <object class="GtkLabel" id="bookmarks_label"> (just after line 210)
(where TOOLTIP TEXT ... needs to be "repaired")

(also good that you cleaned up the "Tabs" problem)

For the future (about tooltips, etc.): 

https://wiki.documentfoundation.org/Development/Accessibility
Comment 35 sdc.blanco 2020-02-12 16:45:25 UTC
(In reply to Michael Stahl (CIB) from comment #31)
> possible, but it turns out the color for the pilcrow glyph at the end
> of the paragraph is hardcoded, so i just used the same color for now.
1. As one subjective opinion, it seems easy enough to see the bookmark marks (with Formatting Marks turned on.)
2. And in this updated version, there is no longer the "conflict" in appearance with other formatting marks (e.g., soft-hyphen, etc.).
3. So "Application Colors" is now more a matter of flexibility for taste than necessity. (but it was nice to have pink bookmarks)
4. I leave "final opinions" about these questions to UX (especially if bookmark visibility should not be linked to Formatting Marks, Ctrl-F10).

And an esoteric problem -- (discovered by accident)

1. Open test file in 6.3.x 
2. Select all, copy and paste into 7.0.0.0. document
3. In 7.0.0.0, Open Navigator, double click on each bookmark  
(effects should be obvious -- but in words)
a. "single" bookmark | got moved to the end of the word and transformed 
    into [.  
b. end of "range" ( ] ) bookmark moved down a couple of words.  

No problem if testfile is opened in 7.0.0.0
No problem copying and pasting from one 7.0.0.0 document to another.

(I suspect you will know why this happens --  "workaround" is to "open" a pre-7.0 document -- just cannot copy and paste text with bookmarks from pre-7.0 documents.  Shall we predict future bug reports? (-: )
Comment 36 sdc.blanco 2020-02-12 16:48:48 UTC
Created attachment 157822 [details]
Small test document to show problem of copying from 6.3.x to 7.0.0.0

Have not tried to open/test the other test documents here.  Attached is a little one-page test document with two bookmarks, one for a single character and one for a range (within a word) to be used with procedure in comment 35
Comment 37 Commit Notification 2020-02-13 09:26:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8daffb60dd2863878bb04317ca2849d76df01f4b

tdf#45589 sw: fix Formatting Aids options page for Writer/Web

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2020-02-13 11:57:29 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/da164e43779029dbb4795adf60c02179d12cdd7c

tdf#45589 sw: add tooltip to Formatting Aids dialog Bookmark label

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 39 Michael Stahl (CIB) 2020-02-13 12:03:57 UTC
(In reply to sdc.blanco from comment #35)
> And an esoteric problem -- (discovered by accident)
> 
> 1. Open test file in 6.3.x 
> 2. Select all, copy and paste into 7.0.0.0. document
> 3. In 7.0.0.0, Open Navigator, double click on each bookmark  
> (effects should be obvious -- but in words)
> a. "single" bookmark | got moved to the end of the word and transformed 
>     into [.  
> b. end of "range" ( ] ) bookmark moved down a couple of words.  
> 
> No problem if testfile is opened in 7.0.0.0
> No problem copying and pasting from one 7.0.0.0 document to another.

if you copy and paste in the same LO process, a fast internal copy is used.

if you copy in one LO process and paste in another, IIRC in Writer it's exported to RTF and then imported.

so probably that's an RTF filter problem, and should be filed as a separate bug.
Comment 40 Commit Notification 2020-02-16 09:22:21 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/247ecc7553759608d08f7fa82db49d972b7cd60d

tdf#45589 update "Formatting Aids" and "View" help pages in Options
Comment 41 sdc.blanco 2020-02-16 11:19:13 UTC
(In reply to Nicolas Göddel from comment #14)
> This especially happens if a bookmark is at the beginning of a
> paragraph.
Not too bad at beginning of paragraph, as long as View>Text Boundaries is not turned on (or changed in Options-Application Colors to something that contrasts with color of the paragraph mark (pilcrow).

(In reply to Michael Stahl (CIB) from comment #39)
> so probably that's an RTF filter problem, and should be filed as a separate
> bug.
Maybe it too rare to fix?
How often will someone have two versions of LO running and copying text with bookmarks between them?
And what will happen when copying from Word to LO?  
You must decide whether to file a report -- also because you will know better how to describe the problem.
Comment 42 sdc.blanco 2020-02-16 12:12:28 UTC
(In reply to Commit Notification from comment #37)
> https://git.libreoffice.org/core/commit/
> 8daffb60dd2863878bb04317ca2849d76df01f4b
> 
> tdf#45589 sw: fix Formatting Aids options page for Writer/Web
> Affected users are encouraged to test the fix and report feedback.
@Michael - the tooltip appears now (which I think is helpful)
(And then -- probably not your fault -- it seems to take 2 or 3 seconds before the tooltip actually appears -- seems like it might be hard to discover.)

And still some small wrinkles (unexpected/unintended side effects)with the  LibreOfficeDev Writer/Web - Formatting Aids:

 a.  It is possible to insert bookmarks in .html pages (using a :uno icon from the toolbar).  
 b.  Insert-Bookmark does not appear in the menus for .html (but maybe it should)
 c.  The inserted bookmarks are saved in the .html file, using the HTML 4 <a> code (which is now deprecated).  (but selected ranges are saved as "point" bookmarks).
 d. But it is not possible to see the bookmarks (because the "Option" control is not present in Writer/Web).

Maybe you should put the control back in Writer/web?  and then I can file a bug report about points b. and c (which is about inserting bookmarks, not about "seeing" them)

And finally(?):

1.  I believe it is correct that Tab should be hidden (as you fixed).
2.  And before you started, "Hidden characters" element was also hidden in Writer/Web (but, in fact, it is possible to "hide" characters and they are saved (in html) as (display: none) -- but it is not possible to see them in the Writer Html (because the the control is not available on the options page. 

(I can also file a bug report about the "hidden characters" case -- or maybe you will "silently" repair it?)
Comment 43 sdc.blanco 2020-03-19 10:03:47 UTC
(In reply to Commit Notification from comment #37)
> https://git.libreoffice.org/core/commit/
> 8daffb60dd2863878bb04317ca2849d76df01f4b
> 
> tdf#45589 sw: fix Formatting Aids options page for Writer/Web
Commit message says: 

"There is no Insert->Bookmark in Writer/Web so i guess the Bookmark
checkbox shouldn't be shown."

But for Writer/Web there is Insert->Anchor  (which opens the Bookmark dialog, and inserts bookmarks in the .html document, but selected ranges are saved as "point" bookmarks.)

Not possible to see the bookmarks (because the "Option" control is not present in Writer/Web). (may also be relevant to bug#127307)
Comment 44 Heiko Tietze 2020-03-19 10:20:46 UTC
(In reply to sdc.blanco from comment #42)
> it seems to take 2 or 3 seconds...
> some small wrinkles...

(In reply to sdc.blanco from comment #43)
> Commit message says...

(Haven't started to follow you)

Please file new tickets. I guess nobody takes a discussion on a resolved issue (with many comments!) serious. Follow-up is fine.
Comment 45 sdc.blanco 2020-03-19 10:22:33 UTC
(In reply to sdc.blanco from comment #42)
> I can also file a bug report about the "hidden characters" case 
Done.  See bug #131415