Bug 127403 - BASIC editor: black code after select
Summary: BASIC editor: black code after select
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Jan-Marek Glogowski
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6....
Keywords: bibisected, bisected, regression
: 127542 (view as bug list)
Depends on:
Blocks: BASIC-IDE
  Show dependency treegraph
 
Reported: 2019-09-06 10:17 UTC by Kamil Landa
Modified: 2019-12-04 16:34 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Printscreen for black code (138.93 KB, image/png)
2019-09-06 10:17 UTC, Kamil Landa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kamil Landa 2019-09-06 10:17:10 UTC
Created attachment 153983 [details]
Printscreen for black code

In Basic editor if some text is selected then all code is black. 
Code is also black after finding some text with Ctrl+F.

Step for reproduce:
1a) select something in Basic editor -> all code is black
1b) or press Ctrl+F and find some text -> all code is black
1c) or select one character and rewrite it -> line with rewrited character is colored, but other code is black


Color code again:
1a)+1b) the code is colored after unselect
1c) select all (Ctrl+A) and after unselect the code is also colored 


Verze: 6.3.1.2 (x64)
ID sestavení: b79626edf0065ac373bd1df5c28bd630b4424273
Vlákna CPU: 8; OS: Windows 10.0; Vykreslování UI: výchozí; VCL: win; 
Národní prostředí: cs-CZ (cs_CZ); Jazyk UI: cs-CZ
Calc: CL
Comment 1 Oliver Brinzing 2019-09-06 18:29:52 UTC
confirming with:

Version: 6.3.1.2 (x64)
Build-ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

but *not* reproducible with:

Version: 6.2.7.1 (x64)
Build-ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 2 Kamil Landa 2019-09-10 13:18:30 UTC
Bug is also in 6.3.2.1

Verze: 6.3.2.1 (x64)
ID sestavení: db810050ff08fd4774137f693d5a01d22f324dfd
Vlákna CPU: 8; OS: Windows 10.0; Vykreslování UI: výchozí; VCL: win; 
Národní prostředí: cs-CZ (cs_CZ); Jazyk UI: cs-CZ
Calc: CL
Comment 3 Oliver Brinzing 2019-09-15 07:58:25 UTC
*** Bug 127542 has been marked as a duplicate of this bug. ***
Comment 4 raal 2019-09-16 20:45:19 UTC
This seems to have begun at the below commit.
Adding Cc: to Jan-Marek Glogowski ; Could you possibly take a look at this one?
Thanks

f80307fce5d2c6d48eff88b76f2d370d193605f8 is the first bad commit
commit f80307fce5d2c6d48eff88b76f2d370d193605f8
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu May 23 01:28:13 2019 +0200

    source sha:cc223fa12a61ba0e580b884386a7f5d7efd0541f

author	Jan-Marek Glogowski <glogow@fbihome.de>	2019-05-16 01:25:19 +0000
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2019-05-22 23:00:45 +0200
commit	cc223fa12a61ba0e580b884386a7f5d7efd0541f (patch)
tree	62184f16ce568b083fae06dd0585f0a193c95e10
parent	9b6a9a1f50a6d7326e97b02618e9bd5e44fb5832 (diff)
VCL keep / return the original set TextEngine font
Comment 5 Kamil Landa 2019-10-22 11:23:24 UTC
Bug is also in 6.4.0.0.alpha1

Verze: 6.4.0.0.alpha1 (x64)
ID sestavení: cc57df8f942f239d29cb575ea5a7cb01405db787
Vlákna CPU: 8; OS: Windows 10.0 Build 17763; Vykreslování UI: GL; VCL: win; 
Národní prostředí: cs-CZ (cs_CZ); Jazyk UI: cs-CZ
Calc: CL
Comment 6 Gerhard Schaber 2019-11-25 09:46:20 UTC
If the commit has already been identified, can it be reverted until a fix for the commit is available?
Comment 7 Xisco Faulí 2019-11-25 09:49:29 UTC
(In reply to Gerhard Schaber from comment #6)
> If the commit has already been identified, can it be reverted until a fix
> for the commit is available?

see comment 4
Comment 8 Jan-Marek Glogowski 2019-11-25 15:57:35 UTC
There is now: https://gerrit.libreoffice.org/#/c/83654/
Comment 9 Commit Notification 2019-11-26 19:51:42 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b1e73fd49661e07e6085310f3f6ecc6ade2a3762

tdf#127403 Revert "VCL keep / return the original set TextEngine font"

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-11-27 09:55:38 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/13d777a0aa3802871cf01869d904ceec39096024

tdf#127403 Revert "VCL keep / return the original set TextEngine font"

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-11-27 12:35:18 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/9b8d8ed2926ead0abb659749c04bcaf5286c7d2b

tdf#127403 Revert "VCL keep / return the original set TextEngine font"

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Gerhard Schaber 2019-11-28 07:02:43 UTC
I can confirm that it works again, now. Thanks. 

One thing I noticed, but I guess it was like that earlier--when I double-click a word, that word gets selected, which is expected, but the whole editor is getting refreshed. When I deselect the word with a single click, it refreshes the whole editor again. This is a little annoying, because every refresh takes a while.
Comment 13 Xisco Faulí 2019-11-28 10:13:23 UTC
(In reply to Gerhard Schaber from comment #12)
> I can confirm that it works again, now. Thanks. 
> 
> One thing I noticed, but I guess it was like that earlier--when I
> double-click a word, that word gets selected, which is expected, but the
> whole editor is getting refreshed. When I deselect the word with a single
> click, it refreshes the whole editor again. This is a little annoying,
> because every refresh takes a while.

Please, create a new report for that issue
Comment 14 Xisco Faulí 2019-11-28 10:17:28 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 2bf687bebb30defe576ddb20c1c9680979ed3086
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 15 Gerhard Schaber 2019-11-28 10:24:52 UTC
I guess the unnecessary refreshes are already covered with bug #107944
Comment 16 Gerhard Schaber 2019-12-03 09:35:05 UTC
Any chance to get this with 6.3.4? Or is there a nightly build for 6.3.5 for Windows?
Comment 17 Xisco Faulí 2019-12-03 10:02:55 UTC
(In reply to Gerhard Schaber from comment #16)
> Any chance to get this with 6.3.4? Or is there a nightly build for 6.3.5 for
> Windows?

it's waiting for review: https://gerrit.libreoffice.org/#/c/83903/
Comment 18 Gerhard Schaber 2019-12-03 10:49:49 UTC
Thanks for the hint.
Comment 19 Commit Notification 2019-12-04 16:34:09 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-4":

https://git.libreoffice.org/core/commit/09caf33cf8f83859f7e736e0bdac2d15682f4b2e

tdf#127403 Revert "VCL keep / return the original set TextEngine font"

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.