Download it now!
Bug 127417 - PARAGRAPH TABS: Not possible to delete all tabs in table cells.
Summary: PARAGRAPH TABS: Not possible to delete all tabs in table cells.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0 target:6.3.5
Keywords: bibisected, bisected, regression
: 128438 129777 130337 (view as bug list)
Depends on:
Blocks: Paragraph-Tab-Stops
  Show dependency treegraph
 
Reported: 2019-09-07 10:14 UTC by Hans
Modified: 2020-02-01 06:49 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen Recording (1.07 MB, video/quicktime)
2019-09-08 14:39 UTC, Hans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans 2019-09-07 10:14:57 UTC
Description:
I'm using multiple tables within a text document and I'm trying to set/change tabs within the cells. Dialog opens when double-clicking the ruler, and I can delete/add tabs. But after confirmation, deleted tabs are not deleted and new tabs not set.

Reverted to 6.2.6.2 and it works just fine in there.

Steps to Reproduce:
1.Create text document
2.Create table within text document, e.g. 4 columns.
3.Put cursor into a cell, select a cell, or select a group of cells. Doesn't matter.
4.Double click into horizontal ruler to open tab dialog.
5.Delete/create some tabs.
6.Confirm to return to text.


Actual Results:
Tabs are not created or deleted.

Expected Results:
Tab creation/deletion to be applied.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 2; OS: Mac OS X 10.11.6; UI render: GL; VCL: osx; 
Locale: de-DE (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-09-08 14:20:28 UTC
I can't confirm this with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 01837a85004a6f891a09c0a63ed7eff75d634827
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_00:07:05
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded

I put cursor in a cell an could add or delete tabs for this cell.

Does it also happen in safe mode (Help => Restart in Safe Mode)?
Comment 2 Hans 2019-09-08 14:39:48 UTC
Created attachment 154018 [details]
Screen Recording
Comment 3 Hans 2019-09-08 14:42:10 UTC
Yes, it's the same in safe node here.
I added a screen recording.
Comment 4 Alex Thurgood 2019-09-09 05:36:38 UTC
If I add the tab stops directly by single clicking on the bottom of the ruler, I can't reproduce this behaviour

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
Threads CPU : 4; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 5 Alex Thurgood 2019-09-09 05:42:21 UTC
If I add the tabs stops via the dialog as reported in the initial post, I still can't reproduce the buggy behaviour with

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
Threads CPU : 4; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

For me, double-clicking anywhere on the ruler area covering the cell width introduces a tab stop at that position, so works for me.
Comment 6 Alex Thurgood 2019-09-09 05:45:17 UTC
@Hans : any particular language / page setup combination that we should be aware of. In your example video, I see that you are working in inches, is your page setup Letter with en-US locale by any chance ?
Comment 7 Hans 2019-09-09 07:13:35 UTC
Yes, my settings are a bit 'special'. I'm using German locale on an US/intl. Macbook with en-US UI and A4 paper size. It always worked, up to and including v6.2.6.2.

I tried things step by step to pinpoint the problem. This is what I found.
Good news:
- adding a tab by clicking into the ruler works,
- moving a tab by clicking into the ruler works,
- adding a single tab using the dialog works,
- adding multiple tabs using the dialog works,
- deleting one tab (not the last/only one) using the dialog works,
- deleting multiple tabs (not all) using the dialog works.
Bad news:
- deleting the last/only tab fails,
- deleting all tabs at once fails.

So the problem appears to be in deleting the last or only tab of an existing set.
Comment 8 Dieter 2019-09-09 07:20:44 UTC
Delete all doesn't work.

I confirm this with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 01837a85004a6f891a09c0a63ed7eff75d634827
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_00:07:05
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded

but not with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 9 Xisco Faulí 2019-09-17 12:15:34 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e2682235cded9a7cd90e55f0bfc60a1285e9a46

author	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-18 19:25:06 +0200
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-25 19:59:04 +0200
commit	1e2682235cded9a7cd90e55f0bfc60a1285e9a46 (patch)
tree	17457bc49d6faf37270c8a481b94765f58a5f434
parent	5e4c1e6ba425ce0b75864e4584a846957b032e61 (diff)
WIP: Further preparations for deeper Item changes

Bisected with: bibisect-linux64-6.3

Adding Cc: to Armin Le Grand
Comment 10 Xisco Faulí 2019-09-17 12:18:19 UTC
Steps to reproduce:
1. Open Writer
2. Click different times on the ruler -> Tabs are added
3. Double click on the ruler
4. Tabs - Delete all - Ok

-> Tabs are still displayed on the tab

@Thorsten, @Michael S., I thought you might be interested in this issue...
Comment 11 Xisco Faulí 2020-01-09 12:43:03 UTC
(In reply to Xisco Faulí from comment #10)
> Steps to reproduce:
> 1. Open Writer
> 2. Click different times on the ruler -> Tabs are added
> 3. Double click on the ruler
> 4. Tabs - Delete all - Ok
> 
> -> Tabs are still displayed on the tab
> 
> @Thorsten, @Michael S., I thought you might be interested in this issue...

Still reproducible in

Version: 6.5.0.0.alpha0+
Build ID: 838935758a5ec8e0e68f4df0cf5bfcf737e3f6f2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, I thought you might be interested in this issue...
Comment 12 Commit Notification 2020-01-11 13:58:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/65a06cfcfba0743584faca9d6e2a3c0d51ece45b

Resolves: tdf#127417 delete-all tabs doesn't work

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2020-01-11 14:01:22 UTC
fixed in master, backports to 6-4 and 6-3 in gerrit
Comment 14 Commit Notification 2020-01-11 22:30:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/dfb60d3b80ca8459505ab7e4599eb9406f1bfb3e

Resolves: tdf#127417 delete-all tabs doesn't work

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-01-11 22:30:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/05398dc3dcce44632075734205261100490dd29c

Resolves: tdf#127417 delete-all tabs doesn't work

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2020-01-13 09:32:05 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: d5047c4a1cbae1cb2b57ed435ecd63e6817506d3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 17 Xisco Faulí 2020-01-13 09:33:48 UTC
*** Bug 129777 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2020-01-13 09:35:14 UTC
*** Bug 128438 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2020-01-14 01:20:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-0":

https://git.libreoffice.org/core/commit/0839896894f4a6ea615325ffa517750e970ab04f

Resolves: tdf#127417 delete-all tabs doesn't work

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Dieter 2020-02-01 06:49:19 UTC
*** Bug 130337 has been marked as a duplicate of this bug. ***