Bug 128438 - Writer: Cannot remove tab marks in paragraph using the Paragraph dialog
Summary: Writer: Cannot remove tab marks in paragraph using the Paragraph dialog
Status: RESOLVED DUPLICATE of bug 127417
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2019-10-28 18:06 UTC by Eduardo Sanchez
Modified: 2020-01-13 09:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Sanchez 2019-10-28 18:06:28 UTC
System info from "About" box:
Version: 6.3.2.2
Build ID: SlackBuild for 6.3.2 by Eric Hameleers
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: es-PY (es_PY.UTF-8); UI-Language: en-US
Calc: threaded

When opening a document where one or more paragraphs have tab marks, selecting those paragraphs, and then opening the menu Format > Paragraph and clicking on the "Tabs" tab, either selecting the particular tab mark and then clicking on the "Delete" button, or even clicking "Delete All" does not work. The tab mark is still there.

The only way to remove the tab mark is to reapply the paragraph style, when such tab mark is not part of the style definition.

A fix would be greatly appreciated.

Thanks for making Libreoffice available!

Eduardo Sanchez
Asunción Paraguay South America
Comment 1 V Stuart Foote 2019-10-28 20:52:42 UTC
Tab marks are formatting characters in the paragraph text runs.

They are inserted into the text, you do not control them from style dialog or the ruler GUI. Those configurations control the text layout when tabs are present.

Simply remove the tab marks.

Done with the Find & Replace dialog, <Ctrl>+H, and set 'Regular expressions' checkbox--then search for "\t" and replace with a <space> (or another string of your choice).
Comment 2 Eduardo Sanchez 2019-10-29 12:49:53 UTC
Reopening. Did you ever made an effort to understand my bug report?

I am NOT speaking about tab characters. I thought that was apparent. It wasn't apparently.

I am speaking about tab marks, those little things that could be seen from the ruler GUI.

AS for the official LO 6.3 Help, 
(https://help.libreoffice.org/6.3/en-US/text/shared/01/05030300.html?DbPAR=SHARED#bm_id3156027)

[quote]
Delete

Deletes the selected element or elements without requiring confirmation.
[/quote]

Well, selecting the element (tab marks or tab stops as the Help calls it, NOT a tab character) and clicking "Delete" does not have any effect. The tab marks / tab stops are still there. Therein lies the bug.

Thanks again,


Eduardo
Comment 3 Eduardo Sanchez 2019-10-29 13:36:55 UTC
More detail:

Selecting any paragraphs or number of paragraphs for which a tab mark / tab stop is applied, invoking Format > Paragraph... , selectiing the "Tabs" tab and clicking on the "Delete" button... does nothing.
Comment 4 Dieter 2019-10-29 19:29:44 UTC
I can delete tabs in the paragraph dialog, but when I close dialog, tabs are still there. If I open dialog again, tab entries are again in the dialog. Is this the same, that happens to you?

Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Eduardo Sanchez 2019-10-29 19:36:20 UTC
(In reply to Dieter Praas from comment #4)
> I can delete tabs in the paragraph dialog, but when I close dialog, tabs are
> still there. If I open dialog again, tab entries are again in the dialog. Is
> this the same, that happens to you?
> 
> Version: 6.4.0.0.alpha1 (x64)
> Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
> Locale: de-DE (de_DE); UI-Language: en-US
> Calc: threaded

Hi Dieter:
That is exactly the same behavior. That is, clicking delete appears to delete tab stops, but they are still present after closing the dialog. That is, "Delete" is ineffectual.
Comment 6 Dieter 2019-10-30 21:30:05 UTC
(In reply to Eduardo Sanchez from comment #5)
> Hi Dieter:
> That is exactly the same behavior.

=> NEW
Comment 7 Dieter 2019-10-31 08:20:26 UTC
It doesn't happen with

Version: 6.1.6.3 (x64)
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 8 raal 2019-11-05 06:17:50 UTC
This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand; Could you possibly take a look at this one?
Thanks

919fbf02a7ae264469801e9b8106690d0f380868 is the first bad commit
commit 919fbf02a7ae264469801e9b8106690d0f380868
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Apr 26 04:48:01 2019 +0200

    source sha:1e2682235cded9a7cd90e55f0bfc60a1285e9a46
author	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-18 19:25:06 +0200
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-25 19:59:04 +0200
commit	1e2682235cded9a7cd90e55f0bfc60a1285e9a46 (patch)
tree	17457bc49d6faf37270c8a481b94765f58a5f434
parent	5e4c1e6ba425ce0b75864e4584a846957b032e61 (diff)
WIP: Further preparations for deeper Item changes
Comment 9 Markus Elfring 2019-11-23 18:45:39 UTC
(In reply to Dieter Praas from comment #4)

I became also curious under which circumstances the deletion of unwanted tabulator positions will work again by the paragraph dialogue.
Comment 10 Xisco Faulí 2020-01-13 09:35:14 UTC
This is a duplicate of bug 127417 and it's fixed in target:6.5.0 target:6.4.1
target:6.3.5

*** This bug has been marked as a duplicate of bug 127417 ***