Bug 127549 - Custom Date format MM/DD/YY lost on cell copy/paste
Summary: Custom Date format MM/DD/YY lost on cell copy/paste
Status: RESOLVED DUPLICATE of bug 126116
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86 (IA32) macOS (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-14 17:38 UTC by DanD_LO_User
Modified: 2019-09-15 17:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DanD_LO_User 2019-09-14 17:38:29 UTC
Description:
In a Calc spreadsheet, I have a column of dates with the entire column declared to use format MM/DD/YY. Adding a new line to the table with copy/paste, the new date is in format MM/DD/YYYY. Both the source cell, and the entire column containing both the source and destination, are declared to use format MM/DD/YY.

I can edit the new cell format to be MM/DD/YY, but that gets annoying. This is relatively new behavior, but I'm not positive when it crept in; I've been putting up with it for a bit before reporting it.

Steps to Reproduce:
1. Enter a date in a cell, e.g. 09/14/19.
2. Set the date format for the column of the cell to MM/DD/YY.
3. Copy the cell, then paste it into the cell just below it.


Actual Results:
The date in the new cell (target of paste) is 09/14/2019

Expected Results:
The date in the new cell should be 09/14/19


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2019-09-15 08:46:05 UTC
there were some issues with date formats:

Bug 126116 - Displayed form of date changes to dd-mm-yyyy when date is changed in cell with format dd-mm-yy

should be fixed starting with LO 6.2.6

can you please try with LO 6.2.7?
Comment 2 DanD_LO_User 2019-09-15 15:18:39 UTC
The issue seems fixed in 6.2.7.1. Thank you.

Sorry, I did search before opening the bug, just not well enough apparently.
I will leave it to developers to close it as a duplicate, rather than mess things up trying to do it myself. Changing back to UNCONFIRMED as requested by the note.
Comment 3 Oliver Brinzing 2019-09-15 17:09:46 UTC

*** This bug has been marked as a duplicate of bug 126116 ***