Bug 127613 - Crash with no clear reason - even in safe mode
Summary: Crash with no clear reason - even in safe mode
Status: RESOLVED DUPLICATE of bug 127619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 127637 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-18 04:38 UTC by Stuart
Modified: 2019-10-01 05:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
crash report (79.03 KB, text/plain)
2019-09-18 04:38 UTC, Stuart
Details
Crash report (89.77 KB, text/plain)
2019-09-18 23:58 UTC, Nahum Castro
Details
Online Update Prefs (252.22 KB, image/png)
2019-09-20 07:56 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart 2019-09-18 04:38:44 UTC
Created attachment 154240 [details]
crash report

Shortly after opening the application, it crashes. Sometimes this is immediate but it can sometimes take a few minutes. It does this even if I have not opened a document.
 
This began happening in the most recent stable version. I have since downgraded, but it still occurs. 

I have booted in safe mode and deleted my user profile and save state. None of these things seem to make a difference.

Crash report attached.
Comment 1 Julien Nabet 2019-09-18 08:05:31 UTC
You can give a try to https://wiki.documentfoundation.org/QA/FirstSteps
Also, do you have any accessibility tool enabled on MacOs?
If yes, could you disable them for the test?
Comment 2 Stuart 2019-09-18 18:19:16 UTC
Thanks.

I do not use any accessibility tools.

The following methods did not help:
. Using the most recent stable release
. Using older version:
  Version: 6.2.7.1
  Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
  CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
  Locale: en-US (en_US.UTF-8); UI-Language: en-US
  Calc: threaded
. Deleting user profile

I will see if there is another new release I should check.
Comment 3 Julien Nabet 2019-09-18 19:27:27 UTC
Did you install any specific fonts? If yes, could you uninstall them for the test?
Comment 4 Nahum Castro 2019-09-18 23:40:46 UTC
I have the same crash loop with 6.2.7. when copied and pasted a gmail text for printing. Since then LibreOffice crash just few seconds after start. I downgrade to 6.1.5.2 and also begun to crash the same way.

Before this crash behavior where normal

Already erased libreoffice from application support directory.

Can't capture crash report from apple LO restarts without the crash report.

If I start with the terminal get this at every crash:
MacBook-Pro-de-Nahum:MacOS nahum$ ./soffice 
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed

My iMac don't suffer from this.

Thanks in advance.

SO: OS X 10.13.6
Macbook pro 13 inch early 2011
16 GB RAM
Comment 5 Nahum Castro 2019-09-18 23:58:20 UTC
Created attachment 154274 [details]
Crash report

Crash after check for updates.
Comment 6 Nahum Castro 2019-09-19 00:24:34 UTC
Workaround

Disable check for updates autamatically in 
preferences
online update

And libreoffice will stop the crash loop.
Comment 7 Julien Nabet 2019-09-19 05:05:14 UTC
Alex: thought you might be interested in this one
Comment 8 Julien Nabet 2019-09-19 09:14:17 UTC
*** Bug 127637 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2019-09-19 10:13:06 UTC
@Nahum: which frequency were your update checks set to ?

Mine are set to weekly, and I don't get random crashes like the ones you are reporting.

Do you have any of the other option boxes ticked on the Online Updates dialog ?
If so, which ones ?
Comment 10 Alex Thurgood 2019-09-19 10:14:23 UTC
@Stuart : do you have the same online update settings problem that Nahum has reported ?
Comment 11 Stuart 2019-09-19 18:31:55 UTC
Yes. Disabling auto update seems to be a workaround. I will update if that changes.
Comment 12 Nahum Castro 2019-09-20 01:59:32 UTC
Only shows on Mac OS X 13 and 14 and any LibreOffice version from 6.1 to 6.3. This crash don't appear on Linux(Centos, Ubuntu) or Windows 10 only Mac.

The update frecuency is weekly.

Thanks
Comment 13 Alex Thurgood 2019-09-20 07:56:53 UTC
Created attachment 154316 [details]
Online Update Prefs
Comment 14 Alex Thurgood 2019-09-20 07:58:12 UTC
@Stuart, Nahum :

Do you have any of the other option boxes ticked on the Online Updates dialog ?
If so, which ones ?

No repro for me with 

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
Threads CPU : 8; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

and the update preferences indicated in screenshot
Comment 15 Alex Thurgood 2019-09-20 08:00:24 UTC
@Stuart, Nahum : out of interest, do you happen to have any JDK declared in LibreOffice under Preferences >  Advanced ?

Just hoping that our online update code doesn't require some kind of Java...
Comment 16 Stuart 2019-09-21 22:24:47 UTC
I didn't have JDK declared when this started, but adding it was one of the things I tried in order to resolve the issue on my end originally. It did not appear to have an effect.
Comment 17 QA Administrators 2019-09-22 03:00:22 UTC Comment hidden (obsolete)
Comment 18 Alex Thurgood 2019-09-30 06:59:24 UTC
Seems very similar to bug 127619, but that one is only reported as affecting macOS 10.13.6
Comment 19 David Wales 2019-09-30 10:00:43 UTC
I think I'm getting the same issue.

I'm running the lastest LibreOffice (6.3.2.2) on macOS 10.13.6.

Where can I find crash reports and logs?
Comment 20 David Wales 2019-09-30 10:23:00 UTC
I followed the comment in bug #127619 suggesting to disable auto update, click 'Apply', then 'OK', then quit LibreOffice before it has a chance to crash.

It has not crashed since.
Comment 21 Julien Nabet 2019-09-30 17:37:59 UTC
(In reply to David Wales from comment #19)
> I think I'm getting the same issue.
> 
> I'm running the lastest LibreOffice (6.3.2.2) on macOS 10.13.6.
> 
> Where can I find crash reports and logs?

Here is some info for MacOs part:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#macOS:_How_to_get_debug_information
Comment 22 Alex Thurgood 2019-10-01 05:41:08 UTC

*** This bug has been marked as a duplicate of bug 127619 ***