Download it now!
Bug 127680 - New Print dialog: impossible to only print even/odd pages from a range/selection
Summary: New Print dialog: impossible to only print even/odd pages from a range/selection
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: high major
Assignee: Srijan Bhatia
URL:
Whiteboard: target:7.1.0
Keywords: bibisectNotNeeded, regression
: 45201 127679 127709 129111 131412 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2019-09-21 08:26 UTC by Mike Kaganski
Modified: 2020-07-24 09:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-09-21 08:26:17 UTC
In the new Print dialog in version 6.3, the two previously independent groups of settings (Range from General tab, and Page Sides from Page Layout tab) were merged into one single radio group. This prevents one from selecting something in the document, or define a pages range, and only print even/odd pages from that selection/range.

The examples of user complaints are:
Bug 122707 comment 17 ( https://forumooo.ru/index.php/topic,7793 )
https://ask.libreoffice.org/en/question/209447/print-range-oddeven-pages-in-lo_writer-63/

This is usability regression.
Comment 1 Oliver Brinzing 2019-09-21 09:06:29 UTC
*** Bug 127679 has been marked as a duplicate of this bug. ***
Comment 2 Oliver Brinzing 2019-09-21 09:17:31 UTC
reproducible with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 71ef762f21ada8c25aad2183065478171e985e8c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 3 Heiko Tietze 2019-09-24 09:24:12 UTC
*** Bug 127709 has been marked as a duplicate of this bug. ***
Comment 4 Oliver Brinzing 2019-11-30 13:50:04 UTC
*** Bug 129111 has been marked as a duplicate of this bug. ***
Comment 5 NISZ LibreOffice Team 2020-03-19 08:00:33 UTC
*** Bug 131412 has been marked as a duplicate of this bug. ***
Comment 6 birnbach@posteo.de 2020-04-23 13:29:25 UTC
Problem persists in LibreOffice 6.4.3.2
Comment 7 Heiko Tietze 2020-05-28 14:57:04 UTC Comment hidden (obsolete)
Comment 8 Srijan Bhatia 2020-06-15 15:07:02 UTC
I'll be working on this.
Comment 9 Andrej 2020-06-16 05:48:39 UTC Comment hidden (obsolete)
Comment 10 Mike Kaganski 2020-06-16 06:59:18 UTC
(In reply to Andrej from comment #9)
> (In reply to Heiko Tietze from comment #7)
> > I doubt the severity. Printing only even/odd pages of a range is a corner
> > case. And easy to work around by entering the actual page numbers. Plus, was
> > it ever possible to print even/odd pages before?
> > 
> > Nevertheless we should solve the issue.
> > ...
> 
> Unfortunately, it is not easy to enter 50 even pages of the range.

Of course, Heiko simply wasn't familiar with how often the need arises to print part of a large text document double-sided on a single-side printer. However, despite doubting, he didn't actually change the severity, only expressed his doubts; and continued to "Nevertheless we should solve the issue". So it's not abandoned, don't worry - Srijan Bhatia even assigned it, so hopefully it will be fixed soon - good luck Srijan Bhatia! :-)
Comment 11 Srijan Bhatia 2020-06-16 15:34:53 UTC
(In reply to Heiko Tietze from comment #7)
> I doubt the severity. Printing only even/odd pages of a range is a corner
> case. And easy to work around by entering the actual page numbers. Plus, was
> it ever possible to print even/odd pages before?
> 
> Nevertheless we should solve the issue. I suggest to have buttons for
> Odd/Even that switch the selection to Range and enter the pages in this
> field. If pages has been filled with a value before, eg. 1-20 we could
> modify that.

Shouldn't there be a seperate field for taking range for the even and odd options? The pages option can take single page numbers as well in which case a user could input an odd page number in the even option or the opposite(It won't print it though as the code won't allow it).
Comment 12 Timur 2020-06-16 17:03:30 UTC
*** Bug 45201 has been marked as a duplicate of this bug. ***
Comment 13 Srijan Bhatia 2020-06-18 13:25:24 UTC
Submitted a patch for this.
https://gerrit.libreoffice.org/c/core/+/96612

Did this for draw/impress as well as it would suffer from the same issue.
Comment 14 Commit Notification 2020-07-02 10:13:17 UTC
Srijan Bhatia committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/14b8c176133979cd1c3163ef5fe3eed0e6479fea

tdf#127680 Add the option to print even or odd values from a particular range

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Timur 2020-07-07 09:59:14 UTC
Works in Writer, Impress, Draw 7.1+. (Impress/Draw works with Slides/Pages, not with Selection, which I guess was meant for content not pages).

Still not in Calc (as noted in the patch review). Can be another bug.

I find odd this order "Even and Odd"/"Even"/"Odd", per real numbers better sequence would be "Odd and Even"/"Odd"/"Even" (as is in MSO and WPS). 
I see that in pre-6.3 there used to be the same order and in post-6.3 again Even and Odd but it should be corrected, best here and now.
Comment 16 Srijan Bhatia 2020-07-12 15:58:40 UTC
(In reply to Timur from comment #15)
> Works in Writer, Impress, Draw 7.1+. (Impress/Draw works with Slides/Pages,
> not with Selection, which I guess was meant for content not pages).
> 
> Still not in Calc (as noted in the patch review). Can be another bug.
> 
> I find odd this order "Even and Odd"/"Even"/"Odd", per real numbers better
> sequence would be "Odd and Even"/"Odd"/"Even" (as is in MSO and WPS). 
> I see that in pre-6.3 there used to be the same order and in post-6.3 again
> Even and Odd but it should be corrected, best here and now.

Patch for this
https://gerrit.libreoffice.org/c/core/+/98602
Comment 17 Timur 2020-07-24 09:35:58 UTC
Heiko, Mike, can xou please push Srijan's patch?
Comment 18 Commit Notification 2020-07-24 09:41:23 UTC
Srijan Bhatia committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/28df1d9a8d51ce8b682a9723fcc2810127c3d7a2

tdf#127680 change even/odd dialog order

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.