Download it now!
Bug 127697 - LO Writer 6.3 hangs during Greek spell check
Summary: LO Writer 6.3 hangs during Greek spell check
Status: RESOLVED DUPLICATE of bug 127060
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2019-09-22 12:03 UTC by I.E. Saridakis
Modified: 2019-09-30 13:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This an odt version of the original txt file (29.88 KB, application/vnd.oasis.opendocument.text)
2019-09-24 12:09 UTC, I.E. Saridakis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description I.E. Saridakis 2019-09-22 12:03:49 UTC
Description:
LO Writer hangs when spell-checking a Greek document (even, txt) containing capitalised words. The Greek spellchecking component is my-spell-el-gr (0.9-1), but the bug is reproducible also with hunspell-el (1:6.0.3-3), on a Linux Mint 19.2 machine.

Steps to Reproduce:
1. Open any txt doc containing mixed normal and capitalised words.
2. Spell-check the doc. 
3.

Actual Results:
Hangs every time, with different documents, after the first or second capitalised word is encountered, and it is necessary to kill the app.

Expected Results:
The spellchecking should normally complete.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Xisco Faulí 2019-09-23 11:38:14 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 I.E. Saridakis 2019-09-24 12:09:27 UTC
Created attachment 154425 [details]
This an odt version of the original txt file

The bug shows up when

1. a capitalised Greek word (e.g. "ΚΑΝΟΝΙΚΟΤΗΤΑ") which is not recognised by the dictionary/spell-checker appears more than once in a string (paragraph); and
2. "Ignore all" is selected during the spell check process; if "Ignore once" is pressed, spellchecking runs as expected.

This bug is present only from LO 6.3 - spellchecking the same document in previous releases is flawless.

Thanks for your attention,
Yannis Saridakis
Comment 3 Dieter 2019-09-28 04:34:15 UTC
I confirm it with

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

but not with

Version: 6.1.6.3 (x64)
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 4 Xisco Faulí 2019-09-30 13:47:14 UTC
Problem is happening when using 'Ignore all', it seems a dupe of bug 127060

*** This bug has been marked as a duplicate of bug 127060 ***