Bug 127713 - "Create PDF form" setting not saved
Summary: "Create PDF form" setting not saved
Status: RESOLVED DUPLICATE of bug 127493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 10:09 UTC by dave.mueller
Modified: 2019-10-08 13:32 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dave.mueller 2019-09-23 10:09:34 UTC
Description:
The setting of the "Create PDF form" checkbox is not saved during multiple 

Steps to Reproduce:
1. File -> Export as PDF...
2. In the "General Options" tab, activate/check the "Create PDF form" checkbox.
3. Export document as PDF.
4. File -> Export as PDF...
5. Check the setting of the "Create PDF form" checkbox.

Actual Results:
After opening the "PDF Options" dialog a second time the "Create PDF form" checkbox is unchecked again.

Expected Results:
Preserve the setting of the "Create PDF form" checkbox.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273

Not sure if this related in any way or not but there are 3 GUI object in this dialog having 'c' as keyboard shortcut.
Comment 1 dave.mueller 2019-09-23 12:00:55 UTC
Seems to be a regression of the 6.3.1 branch as I can't reproduce it with LO Version: 6.3.0.4 (x64) Build-ID: 057fc023c990d676a43019934386b85b21a9ee9
Comment 2 Timur 2019-10-08 11:25:11 UTC
I don't reproduce. Please check whether this happens with any document or a specific one and please attach it. 
Please see bug 127493, we have some issues from LO 6.3, probably related.
Comment 3 dave.mueller 2019-10-08 12:54:34 UTC
> Please check whether this happens with any document or a specific one and please attach it. 

It happens with all documents, even a newly created, empty one.

I noticed that the "Create PDF form" checkbox stays checked all the time, not unchecked as written previously.


> Please see bug 127493, we have some issues from LO 6.3, probably related.

Yes, bug 127493 basically describes the same issue ("Create PDF form" checkbox is always active).
Comment 4 Timur 2019-10-08 13:32:59 UTC

*** This bug has been marked as a duplicate of bug 127493 ***