Download it now!
Bug 127493 - With or without "Create PDF form", Export to PDF always exports modifiable fields to PDF (workaround: print)
Summary: With or without "Create PDF form", Export to PDF always exports modifiable fi...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords: bibisected, bisected, regression
: 127713 127795 130730 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-11 10:30 UTC by chris master
Modified: 2020-02-17 16:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Writer document with checkbox (9.18 KB, application/vnd.oasis.opendocument.text)
2019-09-16 13:17 UTC, chris master
Details
Test2 File with Checkbox and DateBox (9.56 KB, application/vnd.oasis.opendocument.text)
2019-09-16 13:27 UTC, chris master
Details
Print test2.odt with PDF24 PDF Printer (9.54 KB, application/pdf)
2019-09-16 13:28 UTC, chris master
Details
Export as PDF/A without PDF-Form (24.91 KB, application/pdf)
2019-09-16 13:29 UTC, chris master
Details
Export as PDF without form (12.67 KB, application/pdf)
2019-09-16 13:30 UTC, chris master
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris master 2019-09-11 10:30:37 UTC
When I export a writer doc to pdf and choose no PDF Formular, it still exports with Formular.
As PDF 1/A it works, but date fields are empty.
Comment 1 Timur 2019-09-11 14:54:18 UTC Comment hidden (obsolete)
Comment 2 chris master 2019-09-16 13:15:35 UTC
Reproduce export PDF without formular problem:
1) Open Writer
2) Menu: Datei (File) -> Eportieren als (Export As) -> Als PDF exportieren (Export as PDF)
3) Uncheck PDF-Formular erzeugen (create PDF Form Controls???)
4) Export

Do again the Steps 2 and 3 and PDF-Formular erzeugen (create PDF Form Controls???) is checked again.
It is not possible to uncheck it.
And so it is not possible to create a PDF without the controls.

Try:
Formular (Form??) -> Markierfeld (Checkbox??) -> Insert into Document
Create a PDF like in 2), 3), 4)
When you open the PDF you can check and uncheck the Checkbox.
Comment 3 chris master 2019-09-16 13:17:45 UTC Comment hidden (obsolete)
Comment 4 chris master 2019-09-16 13:27:33 UTC
Created attachment 154193 [details]
Test2 File with Checkbox and DateBox
Comment 5 chris master 2019-09-16 13:28:19 UTC
Created attachment 154194 [details]
Print test2.odt with PDF24 PDF Printer

The output is perfect
Comment 6 chris master 2019-09-16 13:29:54 UTC
Created attachment 154195 [details]
Export as PDF/A without PDF-Form

Datebox should not be empty
Checkbox is ok
Comment 7 chris master 2019-09-16 13:30:45 UTC
Created attachment 154196 [details]
Export as PDF without form

It is still a form.
Checkbox is selectable, same to datebox.
Comment 8 Timur 2019-09-16 14:02:38 UTC
I reproduce with master 6.4+ and set to New. Looks like a regression.
Comment 9 Roman Kuznetsov 2019-10-03 19:54:51 UTC
yep, don't repro in

Version: 6.2.2.1 (x64)
Build ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

it's really a regression
Comment 10 Timur 2019-10-08 13:32:59 UTC
*** Bug 127713 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2019-11-27 10:58:36 UTC
*** Bug 127795 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-12-11 16:37:18 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=76fcd878da1624e73f1eb9d9405485d4faf66edf

author	Jan-Marek Glogowski <jan-marek.glogowski@extern.cib.de>	2019-07-31 18:48:30 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-08-07 23:29:09 +0200
commit	76fcd878da1624e73f1eb9d9405485d4faf66edf (patch)
tree	3b0f4f69483a43be9e03ac2c987d34d1dcd42278
parent	a70f0251b98d7d06d27b0f72f3877ea77b659d80 (diff)
tdf#126642 always allow PDF/A form export

Bisected with: bibisect-linux64-6.3

Adding Cc: to Jan-Marek Glogowski
Comment 13 Commit Notification 2019-12-12 07:42:36 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b06cba8f13e0b71346cb884cf827751f2086fd8e

tdf#127493 store ExportFormFields checkbox value

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2019-12-12 10:52:00 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 4a8d3b80283cec4a93dd697eab70afcb82f04f4f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jan-marek, thanks for fixing this issue!!
Comment 15 Commit Notification 2019-12-12 11:16:23 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0d1d0e1a68ce2a48efb7b318e8e01c92361d6b78

tdf#127493 store ExportFormFields checkbox value

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-12-12 16:01:18 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/75406122dd7f6896d003aff46decb78bb40f2fa8

tdf#127493 store ExportFormFields checkbox value

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2020-02-17 16:15:54 UTC
*** Bug 130730 has been marked as a duplicate of this bug. ***