Bug 130730 - PDF Export of forms does not work
Summary: PDF Export of forms does not work
Status: RESOLVED DUPLICATE of bug 127493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-17 11:10 UTC by Rüdiger Hölscher
Modified: 2020-02-17 16:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.odt with form field an the resulting .pdf file without editable form fields (123.05 KB, application/zip)
2020-02-17 16:01 UTC, Rüdiger Hölscher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rüdiger Hölscher 2020-02-17 11:10:14 UTC
Description:
A writer file with form fields can not be exported anymore into an PDF file with editable form fields. 

Steps to Reproduce:
1. create a writer file with form fields
2. Enable the checkbox "create PDF form" in the PDF export options 
3. try to export the Writer file

Actual Results:
No PDF file with form fields occurs. Just a standard File

Expected Results:
The exported File should be a PDF form with editable Form fieds


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I think the bug occurs after updating Libre Office
Comment 1 Dagmara 2020-02-17 11:24:20 UTC
No reproduction with:
Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Works as expected - after exporting to PDF, the editable fields are present in PDF file.
Comment 2 Xisco Faulí 2020-02-17 15:32:55 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 3 Rüdiger Hölscher 2020-02-17 16:01:09 UTC
Created attachment 157955 [details]
.odt with form field an the resulting .pdf file without editable form fields

Here an .odt file with 2 form fields, a Screenshot of how i did the export and the .pdf  file without editable form fields.
Comment 4 Rüdiger Hölscher 2020-02-17 16:02:36 UTC
Thank you for your help!
Comment 5 Xisco Faulí 2020-02-17 16:15:54 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 28d844a589e52abfe62dc66b888e78665221ba28
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I believe this is a duplicate of bug 127493
Could you please try again with LibreOffice 6.4 ?

*** This bug has been marked as a duplicate of bug 127493 ***
Comment 6 Rüdiger Hölscher 2020-02-17 16:36:23 UTC
I am using libre office still from the arch linux repository. So i think i will wait until libre office 6.4 became "still".