Bug 127795 - Form fields not shown as form fields in PDF Export
Summary: Form fields not shown as form fields in PDF Export
Status: RESOLVED DUPLICATE of bug 127493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-26 15:00 UTC by Thierry Menigoz
Modified: 2019-11-27 10:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF file generatedthrough the "Export as PDF" / "PDF form" command (181.95 KB, application/pdf)
2019-09-26 15:00 UTC, Thierry Menigoz
Details
Original Writer file (85.60 KB, application/vnd.oasis.opendocument.text)
2019-09-30 08:51 UTC, Thierry Menigoz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Menigoz 2019-09-26 15:00:24 UTC
Created attachment 154554 [details]
PDF file generatedthrough the "Export as PDF" / "PDF form" command

I created a Writer document with form fields in order to generate a PDF form with fields to be filled-iin through the 'Export As PDF' and then "Create PDF Form" checked as I did in previous versions of LibreOffice.

The rendered PDF file reflects the orginal Open Document but it is not a PDF form with interactive form fields as it did before, or at least not seen as form by usual PDF readers (I personnaly use "Foxit Phantom PDF").

I tried in checking in and out and changing various options in the PDF Export dialog but no change.

I noticed that, on the contrary of previous LibO versions (and other options in the dialog box in the version 6.3), the check box "Export as PDF form" do not remain checked when I do a new export.

An export of the same Writer file from Libo 6.1 gave me the expected result at once.
Comment 1 Oliver Brinzing 2019-09-28 09:31:18 UTC Comment hidden (obsolete)
Comment 2 Thierry Menigoz 2019-09-30 08:51:34 UTC
Created attachment 154646 [details]
Original Writer file

Here is the original Writer file used to export the PDF file previously attached.

As required, I switched bug status back to UNCONFIRMED
Comment 3 Alex Thurgood 2019-09-30 09:10:08 UTC
@Thierry : what exactly do you mean when you write that the form doesn't have interactive form fields ?

I took your Writer document, exported it to PDF, the FPDF option was already activated in my export dialog, and I can click on the form fields, tick boxes, etc and fill in data.

No repro with

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
Threads CPU : 8; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 4 Alex Thurgood 2019-09-30 09:15:35 UTC
Note that in my case, I was opening the PDF file generated from the Writer file in Apple's Preview.

I also tried opening my generated PDF in Adobe Reader and could edit the data of the form fields in that too.

As an aside, the display of the form is actually quite terrible (font magnification, overlapping fields) in both Preview.app and Adobe Reader, but that I would guess is a completely different bug.
Comment 5 Thierry Menigoz 2019-09-30 09:32:41 UTC
On my side, the "Export as PDF" c/w "as PDF Form"  gives a PDF file with no clickable fields or check box (see my first attachment with the PDF file generated on my computer at work (Windows 10 + Libo 6.3.1.2).

Achieving this export on a parallel installation of Libo 6.1 exports correctly with clickable form controls in the PDF.

Regarding appearance, Export under Windows 10 is correct.
Comment 6 Alex Thurgood 2019-09-30 11:04:52 UTC
@Thierry : thanks.

I'm guessing that this is a Windows specific bug then.
Comment 7 Oliver Brinzing 2019-09-30 11:59:00 UTC
not repro with:

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

exported pdf (FDF) is editable with Acrobat Reader DC.
Comment 8 K.M. 2019-10-25 14:05:19 UTC
I was experiencing exactly the same symptoms with

Version: 6.3.2.2
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Linux 4.12; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: CL

under 

openSUSE Leap 15.1

A PDF export with PDF-Form option would create form fields in the PDF that were not editable or even enter-able at all. The fields of the .odt were visible in the PDF but not usable as form fields. I used "evince" as PDF viewer.

When I tested it on the same system (same account, same LO user profile) with an earlier LO version it was working though. I thought it is a regression, but after that re-testing again with above newest LO version it suddenly worked as well.




I figured out that deleting the LO user profile helped solving the problem in my case.
Comment 9 Timur 2019-11-18 20:34:10 UTC
Strange that bug 127493 is opposite. 
When testing exported PDF, it's better to try different options (pdf/a) and open all in different readers, because we have some issues with Adobe Reader.
Comment 10 Timur 2019-11-19 09:55:07 UTC
I couldn't reproduce with original attachment 154646 [details], I always get bug 127493, I tried also https://online.foxitsoftware.com/phantompdf.
Although I have the same for PDF attachment 154554 [details].
Thierry, please see that bug and reset profile (permanently if not customized ot temp. jsut rename "user" folder" in profile).
Comment 11 Thierry Menigoz 2019-11-27 10:31:52 UTC
(In reply to Timur from comment #10)
> I couldn't reproduce with original attachment 154646 [details], I always get
> bug 127493, I tried also https://online.foxitsoftware.com/phantompdf.
> Although I have the same for PDF attachment 154554 [details].
> Thierry, please see that bug and reset profile (permanently if not
> customized ot temp. jsut rename "user" folder" in profile).

Dear Timur,

Sorry for my late answer.
I "reset" my Libo User Folder and, as you mentioned, the form was generated with active fields in the PDF but the ones filled with default values in the ODT were generated empty as described in bug 127493 :(
Comment 12 Timur 2019-11-27 10:58:36 UTC
Thanks, I conclude this is a duplicate. 
If not, please explain and feel free to set Unconfirmed again.

*** This bug has been marked as a duplicate of bug 127493 ***