Bug 127217 - PDF export: LibreOffice 6.3 option buttons in forms not working in Adobe Reader (OK in other readers)
Summary: PDF export: LibreOffice 6.3 option buttons in forms not working in Adobe Read...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: highest normal
Assignee: Thorsten Behrens (allotropia)
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.6
Keywords: bisected, needsDevAdvice, regression
: 127917 128020 128664 128822 130891 131690 134813 136849 137554 138132 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-08-29 13:12 UTC by b3_1987
Modified: 2021-03-24 13:50 UTC (History)
28 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test ODT (14.46 KB, application/vnd.oasis.opendocument.text)
2019-08-30 09:09 UTC, Timur
Details
tail of terminal output from bibisect in 64-6.3 repo (2.97 KB, text/plain)
2019-08-31 20:28 UTC, Terrence Enger
Details
Invoer.odt - testcase (9.88 KB, application/vnd.oasis.opendocument.text)
2020-02-25 08:07 UTC, Hans Dijkema
Details
The PDF generated with LO 6.4.0 (16.25 KB, application/pdf)
2020-02-25 08:08 UTC, Hans Dijkema
Details
The PDF generated with LO 6.2.8 (16.54 KB, application/pdf)
2020-02-25 08:34 UTC, Hans Dijkema
Details
Two radio buttons in odt file (8.56 KB, application/vnd.oasis.opendocument.text)
2020-07-07 08:54 UTC, Jack
Details
Two radio buttons in pdf file before changes made by the "Preview" app. (7.88 KB, application/pdf)
2020-07-07 08:55 UTC, Jack
Details
Two radio buttons in pdf file after changes made by the "Preview" app. (10.41 KB, application/pdf)
2020-07-07 08:55 UTC, Jack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b3_1987 2019-08-29 13:12:51 UTC
Description:
When exporting PDF files with forms that have option buttons (radio buttons) in LibreOffice 6.3, the resulting PDF file has issues in Acrobat Reader / the PDF reader in Microsoft Edge. The problem is that radio buttons cannot be selected (checked). In Linux, using Okular, they work fine.
When exporting the same .odt file as PDF form in LibreOffice 6.2.6, the form works correctly in Adobe Reader / Edge - the radio buttons work as expected.

Steps to Reproduce:
1. Create a new document in Writer.
2. Add some option buttons.
3. Export as PDF (enable "Create PDF form").
4. Open the file in Adobe Reader / Edge.

Actual Results:
The option (radio) buttons cannot be checked (marked as selected).

Expected Results:
The option buttons should be selectable, as they are in the PDF files exported in LibreOffice 6.2.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.4
Build ID: 6.3.0-0
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Also replicable in LibreOffice 6.3.0 in Windows 10.
Comment 1 Timur 2019-08-30 09:08:17 UTC
I tested with master 6.4+ in Windows and exported PDF form can be checked in PDF-Xchange and Foxit (reporter already said Okular in Linux is fine) but cannot be checked in Adobe Reader XI.
This may be the bug or NorOurBug. So I add NeedsDevAdvice. Until then, I'll set to New. 
Reporter, please write your Adobe version and test with older and newer.

You marked as Linux but I'd say this is not OS issue, rather PDF reader. 
Although the issue is not related, see differences in PDF readers in Bug 84963.
Comment 2 Timur 2019-08-30 09:09:19 UTC
Created attachment 153749 [details]
Test ODT

Reporter had better attached a sample. I'm doing it now.
Comment 3 Terrence Enger 2019-08-31 20:28:15 UTC
Created attachment 153784 [details]
tail of terminal output from bibisect in 64-6.3 repo

evince 3.30.2, as delivered with debian-buster shows the difference
between clickable radio buttons from older LO vs. not-clickable
buttons from recent LO.  Of course, this does not prove that the bug
is ours.  I do not understand the pdf format well enough to have an
opinion.

Working in the bibisect-linux-64-6.3 repository, I find:

          commit    s-h       date
          --------  --------  -------------------
    good  9c6a30c7  1e8a9c19  2019-07-03 12:45:35
    bad   998e100d  76b5dca9  2019-07-03 12:45:45

From git log:

    commit 76b5dca9dc0ff60f8f62cbecdee68f8f3b287ceb
    Author: Thorsten Behrens <Thorsten.Behrens@CIB.de>
    Date:   Tue Apr 9 02:19:14 2019 +0200

        tdf#113448 don't export any font for radio buttons
    
        Change-Id: Ie84b19a3dfaec32184bb825b7593ec33a5c4145c
        Reviewed-on: https://gerrit.libreoffice.org/74994
        Tested-by: Jenkins
        Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
        (cherry picked from commit 6ec26ba3aa195eac62fb8803137070d23a69491c)
        Reviewed-on: https://gerrit.libreoffice.org/75012
        Reviewed-by: Katarina Behrens <Katarina.Behrens@cib.de>

I am removing bibisectRequest and adding bisected.
Comment 4 Timur 2019-10-03 12:53:31 UTC
*** Bug 127917 has been marked as a duplicate of this bug. ***
Comment 5 Oliver Brinzing 2019-10-08 17:34:01 UTC
*** Bug 128020 has been marked as a duplicate of this bug. ***
Comment 6 Frank Rowe 2019-10-09 04:51:41 UTC
OK @Oliver Brinzing
Comment 7 Oliver Brinzing 2019-11-08 17:33:25 UTC
*** Bug 128664 has been marked as a duplicate of this bug. ***
Comment 8 Oliver Brinzing 2019-11-15 18:54:56 UTC
*** Bug 128822 has been marked as a duplicate of this bug. ***
Comment 9 Hans Dijkema 2020-02-25 08:07:54 UTC
Created attachment 158164 [details]
Invoer.odt - testcase

Another testcase. Output in LO 6.4.0 works with:

* Foxit PDF reader
* Google Chrome
* PDF Reader by Xodo

works not with:

* Adobe PDF Reader DC
* Microsoft Edge
Comment 10 Hans Dijkema 2020-02-25 08:08:28 UTC
Created attachment 158165 [details]
The PDF generated with LO 6.4.0
Comment 11 Hans Dijkema 2020-02-25 08:34:11 UTC
Created attachment 158169 [details]
The PDF generated with LO 6.2.8

Works with:

* Adobe PDF Reader DC
* Google Chrome
* Foxit PDF Reader
* Xodo PDF Reader

Doesn's work with:

* Microsoft EDGE
Comment 12 Hans Dijkema 2020-02-25 08:35:47 UTC
Here, the behaviour of Microsoft EDGE is different. With LO 6.4.0.3, it won't check the radiobuttons. With LO 6.2.8, it will check all radiobutton (as if they were checkboxes).
Comment 13 Oliver Brinzing 2020-02-25 17:40:01 UTC
*** Bug 130891 has been marked as a duplicate of this bug. ***
Comment 14 Oliver Brinzing 2020-03-30 18:08:49 UTC
*** Bug 131690 has been marked as a duplicate of this bug. ***
Comment 15 Georg 2020-04-09 08:00:42 UTC Comment hidden (no-value)
Comment 16 Jack 2020-07-07 08:50:52 UTC Comment hidden (me-too)
Comment 17 Jack 2020-07-07 08:51:17 UTC Comment hidden (obsolete)
Comment 18 Jack 2020-07-07 08:54:01 UTC
Created attachment 162743 [details]
Two radio buttons in odt file
Comment 19 Jack 2020-07-07 08:55:02 UTC
Created attachment 162744 [details]
Two radio buttons in pdf file before changes made by the "Preview" app.
Comment 20 Jack 2020-07-07 08:55:42 UTC
Created attachment 162745 [details]
Two radio buttons in pdf file after changes made by the "Preview" app.
Comment 21 Steve Coleman 2020-07-26 02:40:37 UTC
Same problem here.

LO Writer Version: 6.4.5.2
Build ID: 6.4.5.2-2.fc32

Evince Document Viewer 3.36.7 fails
Xreader 2.6.4-1 fails
Okular with "show forms" works!

With evince, I can just barely see a difference when the control is clicked on. Its as if the dot has no color (transparent?) but then displays only a very faint shadow for the dot. 

I can also verify that the Before/After pdf's that were posted works as promised using evince. The 'Before' pdf fails and the 'After' pdf works just fine. I'm not sure what "preview" app we are talking about here, but it does seem to fix the problem. I tried diffing the documents but need better tools to decode the pdf's.
Comment 22 Georg 2020-08-07 09:46:52 UTC
I see this defect is assigned already - will it be fixed soon?
I would like to upgrade to version 7 - but the problem still exists within this version.
Comment 23 Timur 2020-09-19 15:39:47 UTC
*** Bug 134813 has been marked as a duplicate of this bug. ***
Comment 24 Timur 2020-09-19 15:42:13 UTC
*** Bug 136849 has been marked as a duplicate of this bug. ***
Comment 25 Timur 2020-09-19 15:48:28 UTC
Xisco, please see to revert this commit. Fix is worse for more users than original issue, which can be reopen with normal priority.
Comment 26 Timur 2020-09-19 15:52:58 UTC
This is the last chance for fix in LO 6.4.7.
Comment 27 Dirk Munk 2020-09-19 16:27:35 UTC Comment hidden (no-value)
Comment 28 Dirk Munk 2020-09-19 16:47:42 UTC
I opened my pdf file ( Bug 138649 ) in Nuance Power PDF Advanced. When I set in to Form, and click on the properties of what should be one of my radio buttons, Power PDF thinks it is a Check Box, not a Radio Button. That could explain a few things.
Comment 29 Dirk Munk 2020-09-19 20:02:40 UTC Comment hidden (no-value)
Comment 30 Dirk Munk 2020-09-24 14:01:09 UTC Comment hidden (no-value)
Comment 31 Joel M 2020-09-24 14:23:28 UTC
(In reply to Dirk Munk from comment #30)
> Some more thoughts on this matter.
> 
> Let's assume this is an error in Writer, as it appears to be.

Not to discourage participation, but if I'm reading the earlier comments right, I think they already found the change in LO that broke it. (See #3.) Something about assigning / not assigning fonts to form widgets in PDF generation: https://git.libreoffice.org/core/+/76b5dca9dc0ff60f8f62cbecdee68f8f3b287ceb%5E%21 . That commit might be what comment #25 is referring to.
Comment 32 Thierry 2020-09-26 16:18:34 UTC
Is there any chance to get this issue solved ?

I'm running LO 7.0.1 both on Linux & Windows, with the same consequence on radio buttons within a PDF created file. Those buttons cannot be selected, or, may be, displayed as selected in the reader (black circle not visible).

Note: I programmatically edited the PDF file (via pdftk + FDF data), and there, when I set radio button to selected in my FDF data, the PDF file generated is displaying radio buttons status properly.
This means the PDF file has the appropriate information within, but may be something is blocking PDF-readers (Adobe acroread,...) to properly behave...

Thanks in advance to anyone who could bring a solution there...
Comment 33 V Stuart Foote 2020-10-17 17:35:40 UTC
*** Bug 137554 has been marked as a duplicate of this bug. ***
Comment 34 rolland.julien.29 2020-11-02 17:06:22 UTC Comment hidden (obsolete)
Comment 35 rolland.julien.29 2020-11-02 17:15:50 UTC
(In reply to rolland.julien.29 from comment #34)
> On LO 7.0.3.1, it's worked

I'm sorry for these comment.

From LO 7.0.3.1, radio buttons from PDF exported can read from browser (MozDev 83.0b7 (64-bit) | Chrome 86.0.4240.111 | Edge 86.0.622.51 | Opera 72.0.3815.186 on Windows 10) but not from Adobe Reader DC 2020.012.20048 (Windows 10 x64).

It seems that PDF exported have an other element within radio button which hide it.
Comment 36 Horst Schottky 2020-11-09 19:10:31 UTC
I compared some PDFs in MasterPDF, which I exported with earlier versions of writer with others, I exported with the actual Version (6.4..).

The difference is, the widgets themself (not the Text - the circle-widget) in earlier versions have fonts (ZaDi or ZapfDinbat) while the widgets in PDFs from LO 6.4.x have none.
The widgets of checkbuttons have even in PDFs exported from the actual writer a font (named F7) and so they work.
Comment 37 Timur 2020-11-12 08:58:39 UTC
*** Bug 138132 has been marked as a duplicate of this bug. ***
Comment 38 audit 2020-11-25 10:57:45 UTC
I could reproduce the problem with LO 7.0.3.1, default ubuntu document viewer or acrobat reader in windows could not select the radio buttons, whereas firefox embedded viewer could.

I then changed the export pdf settings in LO and marked "Archive (PDF/A ISO 19005)" and PDF/A version as PDF/A-3b, and the radio buttons were clickable and selected in default ubuntu document viewer and windows acrobat reader.

Not sure if this is a solution or a workaround, but with that it works ;)
Comment 39 Peter Petrakis 2020-12-04 19:06:39 UTC
This is an intermittent issue in 6.4.6.2 (Ubuntu) and consistently broken on Windows 7.0.3.1 . At first I thought this was a cross platform issue where the PDF form I was generating on Linux was somehow broken and that could only be seen on Window's PDF viewers. Generating the form on Windows using the same source document and output settings confirms that it's the PDF rendering that's the problem.

The PDF/A format work around mentioned here does not work. https://bugs.documentfoundation.org/show_bug.cgi?id=127217#c38

Now for whatever reason, it went from intermittent to consistently broken on 6.4.6.2-ubuntu. I've since switched to combo boxes as a work around but that brings with it the new problem of the foreground/background colors being difficult to see on Windows platforms [1]. It's good enough for now, but if this isn't fixed soon, we'll probably have to pony up for MS Word for the law firm. Which is a shame as the attorney has been using it as her primary word processor for years, it's only forms that are broken. We just can't spend days debugging forms when we're billing out at 250/hr.

1. https://www.petrakis.law/s/PetrakisLawClientIntakeForm_120320.pdf
Comment 40 ambrosa 2020-12-19 09:40:16 UTC
LO 7.0.3.1 x64 running on Windows 10
Same problem here with radio buttons while exporting PDF as form : radio button not working into Adobe Acrobat DC reader.
Workaround exporting document as PDFA-3/b not working. I've tried all exporting options combination. 
The forms works correctly if loaded with browsers (Chrome, Firefox, Edge).

There is something strange: using Acrobat DC I see that the radio buttons *are clickable* but I don't see the black spot inside it ! So I cannot see evidence that the radio button was selected.
Is it possible that was a spot colour problem ?
Comment 41 ambrosa 2020-12-21 08:28:24 UTC
I forget to sat that with LO 6.2.8.2 Win x64, PDF forms are exported perfectly and radio buttons work fine.
Now in my Windows 10 machine I removed all newer LO installation and installed 6.2.8.2 waiting this bug resolution.
Comment 42 loe.florian 2021-01-11 12:58:58 UTC
Same problem here on Ubuntu 20.04

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 12; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: de-DE
Ubuntu package version: 1:7.0.4_rc2-0ubuntu0.20.04.2
Calc: CL
Comment 43 Martin Leclerc 2021-03-04 14:55:41 UTC
I did not see as reference to this in this thread, just making sure it is visible. Quote from the link provided below:

Radiobutton checked value bug: works in all pdf viewers except Acrobat Reader.

Checked" radiobutton value is only working in Acrobat Reader when:

* First radio button value is "0".
* Radio button values are consecutive integers.

https://community.adobe.com/t5/acrobat-reader/radiobutton-checked-value-bug-works-in-all-pdf-viewers-except-acrobat-reader/m-p/11410025

I hope this helps !
Comment 44 Commit Notification 2021-03-11 22:50:25 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a0d63ee5df921e5f1ac915ada783fdef0dbbb057

tdf#127217: Fix buttons in forms not working in Adobe Reader

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Julien Nabet 2021-03-12 08:05:24 UTC
Backports waiting for review here:
- 7.1: https://gerrit.libreoffice.org/c/core/+/112305
- 7.0: https://gerrit.libreoffice.org/c/core/+/112306
Comment 46 tobyps 2021-03-12 19:51:36 UTC
(In reply to Commit Notification from comment #44)

> Affected users are encouraged to test the fix and report feedback.

Works with the Daily from today.

Great work, Thanks.
Comment 47 Commit Notification 2021-03-12 22:52:50 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3faaad6d16881dbbd70e34dcb0445a3373f8ddad

tdf#127217: vcl_pdfexport: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 48 Commit Notification 2021-03-15 14:35:26 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/fc337124c9bb7498fc84a1c60250d7c043e8c7a6

tdf#127217: Fix buttons in forms not working in Adobe Reader

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 49 Commit Notification 2021-03-15 14:38:06 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/70c33addf14d7ee9db874c0d653fbd8f035ac96e

tdf#127217: Fix buttons in forms not working in Adobe Reader

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 Xisco Faulí 2021-03-15 14:43:02 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: c18e5fd7d6c85d4755f1a70d97336d07b2add510
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Julien Nabet, thanks for fixing this issue!! Unittest is also added.
Comment 51 Commit Notification 2021-03-24 13:50:17 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-2":

https://git.libreoffice.org/core/commit/830fac3743c02ccd76fe2ca3b0a81e79ec697857

tdf#127217: Fix buttons in forms not working in Adobe Reader

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.