Download it now!
Bug 133431 - FORMCONTROLS text in PDF form fields shows as dots (⦁⦁⦁⦁) in Acrobat Reader
Summary: FORMCONTROLS text in PDF form fields shows as dots (⦁⦁⦁⦁) in Acrobat Reader
Status: RESOLVED DUPLICATE of bug 50879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-27 10:19 UTC by Jos van den Oever
Modified: 2020-06-02 07:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
form fields with default font (12.06 KB, application/vnd.oasis.opendocument.text)
2020-05-27 10:19 UTC, Jos van den Oever
Details
pdf version of the odt with default font in the form control (12.38 KB, application/pdf)
2020-05-27 10:19 UTC, Jos van den Oever
Details
form field with arial font (12.07 KB, application/vnd.oasis.opendocument.text)
2020-05-27 10:20 UTC, Jos van den Oever
Details
pdf version of form field with arial font (12.36 KB, application/pdf)
2020-05-27 10:20 UTC, Jos van den Oever
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jos van den Oever 2020-05-27 10:19:06 UTC
Created attachment 161319 [details]
form fields with default font

LibreOffice can create PDF forms. When such files are opened in Acrobat Reader (tested in 2017 version) the text that is filled in shows up as ⦁⦁⦁⦁⦁ symbols.

This was already noticed in 2018.

https://ask.libreoffice.org/en/question/163428/when-form-is-converted-to-pdf-dots-appear-instead-of-text/?answer=246669#post-id-246669

A solution is to set the font in the text field to 'Arial'.
Comment 1 Jos van den Oever 2020-05-27 10:19:58 UTC
Created attachment 161320 [details]
pdf version of the odt with default font in the form control
Comment 2 Jos van den Oever 2020-05-27 10:20:29 UTC
Created attachment 161321 [details]
form field with arial font
Comment 3 Jos van den Oever 2020-05-27 10:20:58 UTC
Created attachment 161322 [details]
pdf version of form field with arial font
Comment 4 Dieter 2020-05-29 08:08:03 UTC
Jos, thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 5 NISZ LibreOffice Team 2020-06-02 07:21:44 UTC

*** This bug has been marked as a duplicate of bug 50879 ***