Download it now!
Bug 127736 - FILEOPEN DOCX Spacing and Line spacing in header is not applied
Summary: FILEOPEN DOCX Spacing and Line spacing in header is not applied
Status: RESOLVED DUPLICATE of bug 128195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2019-09-24 08:10 UTC by NISZ LibreOffice Team
Modified: 2020-06-16 20:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
he sample document opened side by side in MS Word and LibreOffice 6.4 Master (224.22 KB, image/png)
2019-09-24 08:10 UTC, NISZ LibreOffice Team
Details
The sample file (28.99 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-24 08:13 UTC, NISZ LibreOffice Team
Details
Screenshot from current master (44.01 KB, image/png)
2020-06-16 20:20 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-09-24 08:10:25 UTC
Description:
In the attached DOCX document the last paragraph of the header has a 12 pt spacing and 1.5 lines of Line Spacing set with direct formattingthat is shown in MS Word but LibreOffice 6.4 does not apply it, and due to this the document layout does not match.

Steps to Reproduce:
Open the sample DOCX in LibreOffice 6.4

Actual Results:
There is no spacing and line spacing applied at all.

Expected Results:
There would be spacing and line spacing


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 NISZ LibreOffice Team 2019-09-24 08:10:52 UTC
Created attachment 154414 [details]
he sample document opened side by side in MS Word and LibreOffice 6.4 Master
Comment 2 NISZ LibreOffice Team 2019-09-24 08:13:57 UTC
Created attachment 154415 [details]
The sample file
Comment 3 Xisco Faulí 2019-09-24 10:38:21 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: a283627036c9b1c56e4b765866b8fb8a26ec87ab
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 Timur 2020-01-08 11:10:22 UTC
Repro 6.5+. Looks inherited.
Comment 5 Gabor Kelemen 2020-06-16 20:20:56 UTC
Created attachment 162073 [details]
Screenshot from current master

Looks good in current master:

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded
Comment 6 Gabor Kelemen 2020-06-16 20:22:18 UTC
Checked with bibisect-linux-64-7.1 this was solved with the commit to bug #128195

*** This bug has been marked as a duplicate of bug 128195 ***