Download it now!
Bug 128195 - FILEOPEN: DOCX: last line in header doesn't use spacing after
Summary: FILEOPEN: DOCX: last line in header doesn't use spacing after
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.6
Keywords: filter:docx
: 56372 127736 (view as bug list)
Depends on:
Blocks: DOCX-Header-Footer docx-aggressive-competitors
  Show dependency treegraph
 
Reported: 2019-10-17 09:31 UTC by Xisco Faulí
Modified: 2020-07-03 11:15 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (14.53 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-10-17 09:31 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.4 Master (13.39 KB, image/png)
2019-10-17 09:32 UTC, Xisco Faulí
Details
Sample in DOC format (26.50 KB, application/msword)
2019-10-18 00:16 UTC, Aron Budea
Details
Word PDF export (180.97 KB, application/pdf)
2020-05-19 12:39 UTC, Samuel Mehrbrodt (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-10-17 09:31:44 UTC
Created attachment 155057 [details]
sample file

Steps to reproduce:
1. Open the attached file

-> Last line in header doesn't use spacing after, thus, there is no separation between the header and the body of the document. See attached image

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 01d28b0b85f99590c0581e4bbf636bc9281e0571
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Xisco Faulí 2019-10-17 09:32:38 UTC
Created attachment 155058 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 2 Aron Budea 2019-10-17 23:20:10 UTC
Confirmed with LO 6.4.0.0.alpha0+ (bb6bcabda53dbd64dda43f09fab9f4ad6f34eba6) / Windows.
Comment 3 Aron Budea 2019-10-18 00:16:13 UTC
Created attachment 155101 [details]
Sample in DOC format

Same issue in DOC format. I didn't want to create a separate bug report right away, that can be done whenever, eg. if the DOCX part is resolved separately.
Comment 4 NISZ LibreOffice Team 2019-12-16 08:59:45 UTC
Bug #127736 is about this too, plus Line Spacing is not applied either (unlike in Word).
Comment 5 Justin L 2020-03-27 12:34:08 UTC
This looks simply like a layout difference between the two programs. I didn't see any compat settings related to this. (The closest is automargin - but that is only handled on import).

So likely if this is worth fixing, it would require a new compat layout setting. It seems to be related to EatSpacing() - which only eats lower spacing and not upper spacing.

Another option would be to disable dynamic header sizing in this situation - although that might have other implications...
Comment 6 Justin L 2020-04-18 18:21:32 UTC
*** Bug 56372 has been marked as a duplicate of this bug. ***
Comment 7 Samuel Mehrbrodt (CIB) 2020-05-19 12:39:39 UTC
Created attachment 161005 [details]
Word PDF export

Add PDF exported from Word

PS: When reporting layout differences to Word, it is generally helpful to attach a PDF produced by Word to the bug.
Comment 8 Commit Notification 2020-06-15 12:43:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9b5805d1ef2b9e9c4e8f389c069807bf4489ea95

tdf#128195 Keep spacing below last paragraph in header (docx)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-15 14:57:51 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/fbd62e247fd588a595e44cec787fc8944f158777

tdf#128195 Keep spacing below last paragraph in header (docx)

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-06-16 07:48:15 UTC
Nice! Verified in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Samuel, thanks for fixing this issue!!
Comment 11 Gabor Kelemen 2020-06-16 20:22:18 UTC
*** Bug 127736 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2020-06-18 12:54:16 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/21e319ffba1e9357914e343bda793f65b4129155

tdf#128195 Keep spacing below last paragraph in header (docx)

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.