Bug 127845 - Opening a file LO says it previously crashed, but fails to recover (win10 only?)
Summary: Opening a file LO says it previously crashed, but fails to recover (win10 only?)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 127867 128493 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-28 12:04 UTC by tim
Modified: 2019-11-08 11:38 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["jscript.dll"]
Regression By:


Attachments
WinDbg output for LibreOffice_6.2.8.1_Win_x64 dev version (17.09 KB, text/plain)
2019-10-04 21:50 UTC, vesper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2019-09-28 12:04:53 UTC
Opening one of many different calc files get a message saying 'Due to an error LO crashed. The next time.....  

No files to be recovered are listed in the box below.

It then offers to send a crash report - done twice.

It then offers to open in safe mode.  I have tried most of the options.  None make any difference.

I uninstalled 6.3.1.2, cleared out appdata for LO for this user, and installed 6.3.0.  No change.

After a while LO doesn't seem to do anything.  In task manager there are many Libreoffice processes, which all have to be killed.

This has only happened since installing windows 10 updates KB4517211 and 4522738 on 27/9/19.

Writer seems OK.
Comment 1 tim 2019-09-28 12:19:16 UTC
I tried clearing out appdata, uninstalling, using bitdefender to clear any registry issues, rebooting, and installing 6.2.7.  I got the same error.

It still says it crashed the last time it ran, even though this version hasn't run before.

The latest crash report (of several) is now listed above.
Comment 2 tim 2019-09-28 12:20:53 UTC
To be clear, this is happening on many different calc files.
Comment 3 tim 2019-09-28 12:25:39 UTC
And now it's happening on some writer files as well.

I may be unable to reproduce this since I may well have to revert to an older windows version (I can't uninstall the last two updates).
Comment 4 tim 2019-09-28 13:18:59 UTC
Looking at one of the many crash reports (which I don't understand), it seems something is up with jscript.dll.  There are loads of reports about it, not just from me, with "EXCEPTION_ACCESS_VIOLATION_READ".  The reports go back a long time, many different versions of LO.

I have tried several of the calc and odt files on another machine, and they are OK.
Comment 5 Julien Nabet 2019-09-28 14:43:25 UTC
Could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?

Also, if you use LO 64 bits, you must have Java 64 bits
...LO 32 bits -> Java 32 bits.
Comment 6 tim 2019-09-28 15:59:33 UTC
I have 64 bits LO, and Java, and in tools, advanced, it's seen.

I have just reset the PC and am reinstalling all the apps.  It seemed OK, then failed as before.  Not every sheet or every time.  

I reset my profile (many times)

I have tried OpenGL off - no difference.

OpenCL is not available - I switched it on but it went off again after restart.

Baffling and very frustrating.  This is my partner's system, and it's now  unusable for much of what she needs.
Comment 7 Julien Nabet 2019-09-28 16:50:10 UTC Comment hidden (obsolete)
Comment 8 tim 2019-09-28 18:19:58 UTC
(In reply to Julien Nabet from comment #7)
> Perhaps try https://help.libreoffice.org/Common/Safe_Mode even if it'd be
> just a workaround.
> 
> Also, you can try brand new 6.3.2 or even nightly builds (see
> https://dev-builds.libreoffice.org/daily/master/)
> 
> About jscript, where did you find other crashes with it?
> Indeed, the crashreport doesn't give much details except it's jscript part.

Safe mode doesn't work ta all either when entered from the screen asking to send a bug report.

I'm now on 6.3.2.  No change.

When I opened the bug report website, I then clicked on jscript.dll.
Comment 9 tim 2019-09-28 19:56:59 UTC
The problem may, just may, have gone away.  I'll report again if it re-appears.

Having reset W10, and cleared the user profile yet again, I initially did not select the java version in the options, advanced settings (the 'use a java' tick box was still selected).

I then made sure I deleted all the LO lock files I could find.  Opening a document that had given the error previously and had a lock file caused LO to start refusing to open many other files again saying it had crashed. It seemed I had to start 'clean'. 

I then opened many odt and ods files successfully.  After a while I enabled the current 64 bit java version, and it all still seems to be OK.

In the mean time a W10 .net update from 27/9/19 that I had removed (in the hope it would help) was also reinstalled.

If I could add a symbol here for crossed fingers, I would, but this will have to do 

X
Comment 10 tim 2019-09-29 12:06:54 UTC
I tried to reproduce the problem on a different PC that has the same LO version and W10 patches.  I copied over one of the same spreadsheets that appeared to crash, opened it, and then killed soffice (using taskkill /F), leaving a lock file.

I then opened the sheet again, but the name of the file was clearly displayed in the box saying "Due to an error LO crashed. The next time...".  The file duly opened successfully. So I have failed to replicate the crash where no such file name is provided to recover from.

The PC on which the problem kept recurring yesterday has now decided to pretend nothing happened.

I will however, if it's OK, leave this report open for a while in case the problem comes back.
Comment 11 Julien Nabet 2019-09-29 19:38:19 UTC
*** Bug 127867 has been marked as a duplicate of this bug. ***
Comment 12 Julien Nabet 2019-09-29 19:42:18 UTC
Xisco: I'm afraid some Win10 has some updates which may impact LO so more people may submit a bug. Thought you might be interested in this one.

Let's put this one to NEW meanwhile.
Comment 13 tim 2019-09-30 08:41:54 UTC
It's kind of good to know I am not alone in this strange one.  

If there's anything more I can do to help, please let me know.  Unfortunately for the purposes of tracking it I currently don't have the problem.

I mentioned the 2 Win10 updates that were installed last week after which I got the problem.  After resetting Win10 it reinstalled those 2 and also installed KB4514359.  On 29/9 a further 5 security updates were installed, plus KB890830.  I still had the problem briefly after that, before clearing all lock files.

I had the same problem in several LO versions from 6.2.7 to 6.3.2.

I have said what I did to eventually get rid of the problem, but I suspect it might return if, for any reason, I manage to crash stop LO by mistake (eg by closing down leaving a file open) and leaving a lock file.
Comment 14 tim 2019-09-30 10:29:15 UTC
As I feared, the problem has recurred.  I opened an existing odt, edited and printed, all OK, and I closed that file.

I then attempted to open an ODS, and got this same problem again.  Some odts now also give the same problem.

One odt opened OK but when I went to print settings it crashed and asked to recover, this time giving the correct file name in the recovery box.

Libreoffice is now unusable.  If there is any chance really old versions, or alpha new ones might be better, please advise and I'll try.  

Anything else I can try?
Comment 15 tim 2019-09-30 10:29:24 UTC Comment hidden (obsolete)
Comment 16 tim 2019-09-30 13:50:40 UTC
I have rolled back to a recovery disk version of W10, and am reinstalling from there.  I have managed to prevent updates KB4517211 and 4522738 from installing, and will not install any more W10 updates for some time to come.

If the problem recurs I will post again here.
Comment 17 tim 2019-10-01 11:34:13 UTC
Can I query whether this really is a 'medium' level issue?  

For those affected (and one guesses numbers will increase as people install updates) it's crippling unless they are able to roll back Windows.  I was unable to uninstall the relevant updates (Windows would not let me, saying they could not be uninstalled at all).

I was fortunate in having been careful to have a recovery disk, daily data backups to restore, my own instructions on how to get back to where I was, and the ability to halt all further updates using gpedit.msc.  I believe many systems and users may be unable to prevent updates being installed.
Comment 18 vesper 2019-10-02 13:59:23 UTC
(I had previously opened Bug 127867 which was marked as a duplicate of this bug)

I have opened a thread on the Windows 10 forum (in Windows 10 Support) to report this issue there, since jscript.dll is a Microsoft replacement for oracle's java (somehow).  Folks affected by this bug are encouraged to follow along and comment there. 

www.windows10forums.com/threads/after-latest-windows-update-libreoffice-no-longer-works-jscript-dll-is-implicated-on-all-crashes.20421/

ALSO, I tried experimenting with getting LO to use MY JRE (java runtime environment), but had no successes to report.  MAYBE the LO team could explore that idea further...

Al Vesper (aka dumbscreenname)
Comment 19 vesper 2019-10-02 14:00:47 UTC
... and yes, LO is unusable for me too...
Comment 20 Julien Nabet 2019-10-02 14:09:01 UTC
Quite naively, I thought there was only 1 Win10 version + updates/patches.

But taking a look at https://en.wikipedia.org/wiki/Windows_10_version_history, it seems there are different ones.
For example some companies may stick to Redstone 3/1709 version because the next ones don't include mobile devices.

So, it could be interesting people provide Windows 10 version.
Comment 21 vesper 2019-10-02 14:47:13 UTC
(In reply to vesper from comment #19)
> ... and yes, LO is unusable for me too...

Edition         Windows 10 Pro
Version         1803
Installed on    5/3/2018
OS build        17134.1039

Hint (on WIN 10): Settings/System/About -> Windows specifications
Comment 22 tim 2019-10-02 14:55:43 UTC
I'm on:

Windows Pro 1903
Latest updates
Version 18362.356

Installed in July 2019 (but since reinstalled to get rid of the offending updates - which I assume is one of the 2 I mentioned).
Comment 23 tim 2019-10-02 14:58:00 UTC
I've since yet had more strange things going on but guess they are nothing to do with LO (I lost write access to almost all the files whilst editing a writer file).
Comment 24 Julien Nabet 2019-10-02 15:15:53 UTC
(In reply to vesper from comment #18)
> ...
> I have opened a thread on the Windows 10 forum (in Windows 10 Support) to
> report this issue there, since jscript.dll is a Microsoft replacement for
> oracle's java (somehow).  Folks affected by this bug are encouraged to
> follow along and comment there. 
> ...

jscript.dll is related to Javascript, not Java (see https://en.wikipedia.org/wiki/JScript).
But jscript is related to .NET framework and I think the bug may be related to it.
Comment 25 tim 2019-10-02 15:44:48 UTC
(In reply to Julien Nabet from comment #24)
> (In reply to vesper from comment #18)
> > ...
> > I have opened a thread on the Windows 10 forum (in Windows 10 Support) to
> > report this issue there, since jscript.dll is a Microsoft replacement for
> > oracle's java (somehow).  Folks affected by this bug are encouraged to
> > follow along and comment there. 
> > ...
> 
> jscript.dll is related to Javascript, not Java (see
> https://en.wikipedia.org/wiki/JScript).
> But jscript is related to .NET framework and I think the bug may be related
> to it.

In that case, see https://support.microsoft.com/en-gb/help/4522738/sep-26-2019-kb4522738-cumulative-update-for-net-framework

I looked at this, and the help for it (which has a different KB number), and the file list, and couldn't find jscript.


However, the (optional) update KB4517211 did indeed update jscript.dll.  Being optional, it may well be that many did not install it (yet). See 
https://support.microsoft.com/en-gb/help/4517211/windows-10-update-kb4517211
Comment 26 tim 2019-10-02 16:24:58 UTC
(In reply to vesper from comment #21)
> (In reply to vesper from comment #19)
> > ... and yes, LO is unusable for me too...
> 
> Edition         Windows 10 Pro
> Version         1803
> Installed on    5/3/2018
> OS build        17134.1039
> 
> Hint (on WIN 10): Settings/System/About -> Windows specifications

Vesper, you are on a different version of Win 10 than me.  It would be interesting to know what updates you installed on or around 26/9/19, and what the date is on your jscript.dll.  

I have responded on the Windows forum as well.

It seems the optional KB4517211 is in preparation for the next major release of windows, so this problem is almost certainly not going to go away.  There are loads of fixes, including security ones.  It may be that the kb number is different for 1803.
Comment 27 vesper 2019-10-02 17:37:17 UTC
The .NET update installed on Sept 26 is KB4515842 on my system; after I uninstalled it and restarted the OS, LO still fails.  I reinstalled that update after that.  (other things failed with that update missing of course).

My c:\Windows\System32\jscript.dll has a creation date of 9/16/2019 which would be the build date in Seattle or somewhere.
Comment 28 vesper 2019-10-02 18:33:04 UTC
(I will be happy to try things for the LO techies if anyone has anything to propose.  Suggest which MS debugging tools to turn on, or other steps...)
Comment 29 tim 2019-10-02 18:38:29 UTC
(In reply to vesper from comment #27)
> The .NET update installed on Sept 26 is KB4515842 on my system; after I
> uninstalled it and restarted the OS, LO still fails.  I reinstalled that
> update after that.  (other things failed with that update missing of course).
> 
> My c:\Windows\System32\jscript.dll has a creation date of 9/16/2019 which
> would be the build date in Seattle or somewhere.
Did you have any other OS (not .NET) updates around then? It may well be some form of fix being applied to several OS version.
Comment 30 Julien Nabet 2019-10-02 18:41:41 UTC
Michael/Tor: it seems there's something in last version of jscript.dll provided by Microsoft for Win10 which makes LO crash. I let you read the comments for the details.

Thought you might be interested in this one.
Comment 31 vesper 2019-10-02 19:10:22 UTC
(In reply to tim from comment #29)

> Did you have any other OS (not .NET) updates around then? It may well be
> some form of fix being applied to several OS version.

There were two updates applied on 9/26: the .NET one (KB4515842), and KB4516045 which was the major OS build.  As I mentioned previously, it MAY turn out that on a system with this build LO could still function properly, but since there are two of us reporting, the problem is larger than one rogue user.  I also note that the Bugzilla hurdle could be keeping others from checking in...  :)
Comment 32 vesper 2019-10-02 19:15:36 UTC
... I now realize that my testcase for failure is exceedingly simple as I described in my original BUG report which was closed as a duplicate.  I'm reproducing it below:

1. create a NEW LO writer file and open it (in LO)
2. Format / Page    (or a lot of other things)

Boom.
Comment 33 tim 2019-10-02 20:44:10 UTC
And my test case is simply to attempt to open a file.

Would it help if vesper could install a development/debug version of LO and get a more detailed crash report?
Comment 34 Julien Nabet 2019-10-02 20:53:40 UTC
(In reply to tim from comment #33)
> And my test case is simply to attempt to open a file.
> 
> Would it help if vesper could install a development/debug version of LO and
> get a more detailed crash report?

Indeed a build with symbols may help indeed to have a backtrace more detailed.
See https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
Comment 35 tim 2019-10-02 21:11:56 UTC
(In reply to Julien Nabet from comment #34)
> (In reply to tim from comment #33)
> > And my test case is simply to attempt to open a file.
> > 
> > Would it help if vesper could install a development/debug version of LO and
> > get a more detailed crash report?
> 
> Indeed a build with symbols may help indeed to have a backtrace more
> detailed.
> See
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:
> _How_to_get_a_backtrace

I wish I could help.  Unfortunately of my 3 Windows 10 systems, the 2 I hardly ever use don't exhibit the problem (I run ubuntu/xubuntu on them, dual booted).  The one system that does fail is my partner's, which only runs Windows and which needs to work, so I can't run that test myself.

I hope vesper can.

I don't suppose it's relevant, but in my case the system that fails is a new Intel NUC8i system with an i5 cpu.  The others are 5 or more years old, one Intel and one AMD.
Comment 36 tim 2019-10-03 06:49:09 UTC
(In reply to vesper from comment #31)
> (In reply to tim from comment #29)
> 
> > Did you have any other OS (not .NET) updates around then? It may well be
> > some form of fix being applied to several OS version.
> 
> There were two updates applied on 9/26: the .NET one (KB4515842), and
> KB4516045 which was the major OS build.  As I mentioned previously, it MAY
> turn out that on a system with this build LO could still function properly,
> but since there are two of us reporting, the problem is larger than one
> rogue user.  I also note that the Bugzilla hurdle could be keeping others
> from checking in...  :)

vesper, as a matter of interest, will Windows let you uninstall KB4516045?  It does include an updated jscript.dll.  I couldn't uninstall the version of the update on my system.

If it doesn't let you uninstall it, you might be able to roll back to a windows restore point before the two updates.  I tried and failed (for a variety of reasons of my own making), but you may be able to.  If you do manage to roll back you may find that the 'update history' still includes the 2 new updates.  This got me completely confused in the past.  It turns out that the 'update history' in windows just lists entries from a log file, and that log is not rolled back in the restore.   To see what updates are actually installed you have to do a proper check on what is installed (use cmd command systeminfo.exe).
Comment 37 vesper 2019-10-04 09:07:47 UTC
I believe that Bug 127794 is a duplicate report of this, or at least eerily similar.  Further, I'm now working on the assumption that this is NOT a LO problem, but a Microsoft problem.  The Windows Update I installed on 9/27 seems to have caused all this and I am now concentrating on:

windows10forums.com/threads/multiple-applications-have-broken-after-9-26-windows-update.20437/
Comment 38 tim 2019-10-04 09:24:45 UTC Comment hidden (obsolete)
Comment 39 vesper 2019-10-04 09:38:12 UTC Comment hidden (obsolete)
Comment 40 vesper 2019-10-04 09:47:42 UTC
In reference to your query "Can you install a debug/development version of libreoffice and get the resulting crash report to the people at Libreoffice? That might help them to help us." on windows10forums.com/threads/multiple-applications-have-broken-after-9-26-windows-update.20437/#post-102525, I got so far as downloading the WinDbg tool referenced in Julien's post (comment 34) (and that wiped out my Windows update history), installing it and trying to run it.  I discovered then that I couldn't attach to the LO process, no doubt because I don't (yet) have the LO debug version installed.  I'll get back to that, but not until sometime next week at the earliest...
Comment 41 tim 2019-10-04 09:59:13 UTC Comment hidden (obsolete)
Comment 42 tim 2019-10-04 10:04:12 UTC Comment hidden (obsolete)
Comment 43 tim 2019-10-04 10:05:08 UTC Comment hidden (obsolete)
Comment 44 tim 2019-10-04 10:07:11 UTC
(In reply to vesper from comment #40)
> In reference to your query "Can you install a debug/development version of
> libreoffice and get the resulting crash report to the people at Libreoffice?
> That might help them to help us." on
> windows10forums.com/threads/multiple-applications-have-broken-after-9-26-
> windows-update.20437/#post-102525, I got so far as downloading the WinDbg
> tool referenced in Julien's post (comment 34) (and that wiped out my Windows
> update history), installing it and trying to run it.  I discovered then that
> I couldn't attach to the LO process, no doubt because I don't (yet) have the
> LO debug version installed.  I'll get back to that, but not until sometime
> next week at the earliest...
The windows update history is just a log file, and sometimes misleading (particularly if you do a rollback to a restore point).

I use the admin version of cmd systeminfo.exe to see what is actually installed.
Comment 45 tim 2019-10-04 12:06:47 UTC
If anyone has a system exhibiting this fault, there's a new Windows 10 update for each OS version that might help.  For 1903 it's KB4524147.  It's said to fix several recently introduced issues, and includes an update to jscript.dll.

Unfortunately I can't really test it since have got my partner's system working without the previous updates (and spending many hours doing so) I don't dare risk it, for now at least.
Comment 46 vesper 2019-10-04 14:17:35 UTC
I have installed the corresponding KB4524149 update for my OS version 1803 (it includes the new jscript.dll and is advertised to fix some of these problems), and there have been no changes which I can observe.
Comment 47 Julien Nabet 2019-10-04 17:11:06 UTC
(In reply to vesper from comment #46)
> I have installed the corresponding KB4524149 update for my OS version 1803
> (it includes the new jscript.dll and is advertised to fix some of these
> problems), and there have been no changes which I can observe.

I don't know Windows internal mechanism so not sure.
Did you restart Windows to be sure the right version of the dll was in memory?
Indeed, perhaps this kind of dll is just loaded once at Windows startup.
Comment 48 vesper 2019-10-04 21:50:52 UTC
Created attachment 154765 [details]
WinDbg output for LibreOffice_6.2.8.1_Win_x64 dev version

This is the Exception Analysis portion of my debug session on LO 6.2.8.1 I ran just now.  The previously reported crash resulting from Format > Page DID NOT OCCUR.  Instead, this crash occurred when I entered some text in a new LO .odt file and then attempted to print the file.  I hope it helps; suggestions for next steps are invited.
Comment 49 Mike Kaganski 2019-10-04 21:59:19 UTC
This must have something with printer driver which uses jscript for something. The crash dimp suggests that; also a IRC conversation with a user suffering from the same problem (http://crashreport.libreoffice.org/stats/crash_details/c2dbb1a8-4337-4064-9864-a1b8d8ba776e#allthreads) suggests that in safe mode, the crash occured when trying to print. That user's printer is HP OfficeJet Pro 6975
Comment 50 vesper 2019-10-04 22:31:59 UTC
My printer is an HP 8720.

I have discovered that EVERYTHING I try to print causes the application (which tried to print) to crash, but other things crash too...
Comment 51 vesper 2019-10-04 22:34:46 UTC Comment hidden (off-topic)
Comment 52 Mike Kaganski 2019-10-04 22:37:05 UTC
(In reply to vesper from comment #50)
> but other things crash too...

Many things could need some information from printer, e.g. viewing in page break mode in Calc...

Could you please try setting your default system printer to something else (like some PDF virtual printer) and retry?
Comment 53 Mike Kaganski 2019-10-04 22:38:59 UTC Comment hidden (off-topic)
Comment 54 vesper 2019-10-04 22:51:39 UTC
... from what I've see so far, I can print to a pdf.  I agree that the printer driver I've got is not compatible with Msft's new jscript code...
Comment 55 vesper 2019-10-05 01:13:38 UTC
FIXED!  (or at least what I just tested is fixed).

I have an HP 8720 printer, and after updating my printer drivers to HP's latest, the LO crashing problem has gone away.  HP released the current drivers about a year ago, and for those of us with a "if it ain't broke, don't fix it" attitude, now that it's broke, it's time to fix it.  I've tested a number of the other problem applications too, and they all seem to be working again.
Comment 56 vesper 2019-10-05 01:14:46 UTC
THANKS MIKE!
Comment 57 Mike Kaganski 2019-10-05 05:27:56 UTC
Tentatively resolving NOTOURBUG then, according to comment 55. Must be some combination of HP printer driver version and some MS update related to jscript, that don't co-exist. Thanks for letting us know vesper!

If closing it turns out to be wrong, please reopen.
Comment 59 tim 2019-10-05 11:47:38 UTC
I haven't been printing anything.  Can an old HP driver still cause problems even if  not printing?  I will check it.

I'm really wary of updating the failing system. Recovering to a working version takes me a long and tricky time.
Comment 60 tim 2019-10-05 12:04:12 UTC
(In reply to vesper from comment #55)
> FIXED!  (or at least what I just tested is fixed).
> 
> I have an HP 8720 printer, and after updating my printer drivers to HP's
> latest, the LO crashing problem has gone away.  HP released the current
> drivers about a year ago, and for those of us with a "if it ain't broke,
> don't fix it" attitude, now that it's broke, it's time to fix it.  I've
> tested a number of the other problem applications too, and they all seem to
> be working again.
I also have an 8270 printer.  Windows says it's up to date, but it is dated 29/5/17, version 20 79 16692.  The install files from HP are dated mid 2018.
Comment 61 tim 2019-10-05 12:18:25 UTC
I'm sure it's not an LO bug, but I cannot yet be sure this problems has gone away for me.  I am puzzled about printer driver versions, since I haven't changed that for at least several months, and it's the same on all my systems.  But only one system repeatedly failed just opening odt and ods files.

I am at something of a loss as to know what to do.
Comment 62 tim 2019-10-05 15:05:01 UTC
(In reply to tim from comment #61)
> I'm sure it's not an LO bug, but I cannot yet be sure this problems has gone
> away for me.  I am puzzled about printer driver versions, since I haven't
> changed that for at least several months, and it's the same on all my
> systems.  But only one system repeatedly failed just opening odt and ods
> files.
> 
> I am at something of a loss as to know what to do.
The strange and unsettling world of Windows. The 'must have' update KB4524147 (for 1903) of 4th October is now 'optional' on 5th October.  I've taken a new recovery drive and backups, but will leave the optional update until pushed for other updates (probably this Tuesday). 

I have also made free partition space on the disks to install a linux flavour (probably xubuntu 1804) if it comes to that.  We only got this machine as a new Windows-only system because we thought there might be more support from local people if the wotsits hit the fan - could be a mistaken decision.

My printer driver was (and is) definitely up to date, so there are, or were, other issues relating to the updates of 26 September.

I now have even less hair.
Comment 63 tim 2019-10-17 10:11:48 UTC
I did last week's Windows Updates, and all seems stable now - I hope.  Thanks for the help.
Comment 64 Xisco Faulí 2019-11-08 11:38:50 UTC
*** Bug 128493 has been marked as a duplicate of this bug. ***