Download it now!
Bug 127883 - AutoCorrect need alternative for handling use of keyboard input of apostrophe as apostrophe (rather than single quote)
Summary: AutoCorrect need alternative for handling use of keyboard input of apostrophe...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2019-09-30 12:34 UTC by severin.kunz
Modified: 2020-05-02 15:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description severin.kunz 2019-09-30 12:34:19 UTC
Description:
I am getting absolutely annoyed every time I try to type the ' with my keyboard layout DE-CH, it will always type ‹ or › respectively.  PLEASE fix this, or I will throw my keyboard at my monitor!

Actual Results:
‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›‹›

Expected Results:
''''''''''''''''''''''''''


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-09-30 13:49:32 UTC
That is a Localized Option for auto-correction.

The keyboard apostrophe is being replaced with the typographic.

Suppressed, or changed to a different character choice, from:

Tools -> AutoCorrect -> AutoCorrect Options 

and on the 'Localized Options' a checkbox to enable/disable replacment for both single and double quotes, and selection boxes to choose what Unicode glyph is used for replacement.

The default choices come from configuration file for the locale de-CH you are using.
Comment 2 severin.kunz 2019-09-30 13:52:04 UTC
This might not be a bug, but it's absolutely not a desired behaviour!
Comment 3 V Stuart Foote 2019-09-30 14:07:22 UTC
(In reply to severin.kunz from comment #2)
> This might not be a bug, but it's absolutely not a desired behaviour!

But it is "desired"...

The autocorrection is enabled by default for all locales. And, feature was explicitly set to the  < > pairing for de-CH (and all Swiss languages) for bug 105837

Since you only seem to want keyboard apostrophe, just disable the autocorrect replacement to turn the feature off.
Comment 4 severin.kunz 2019-09-30 14:09:02 UTC
No it's not desired.
At least certainly NOT directly after a letter.

Before a letter, yes. Directly after and between two letters, no.
Comment 5 severin.kunz 2019-09-30 14:11:21 UTC
For example

‹some text› ‹some text› 

might be desired, even though it's outdated.

it›s or hat›s is absolutely not desired

as well as f›(x) is not desired.
Comment 6 V Stuart Foote 2019-09-30 14:20:43 UTC
There is no issue of the keyboard mapping. This ia an autocorrect function.

So while typing imput either disable the autocorrect, or immediately revert it with <Ctrl>+Z

You have to pick which feature works best for you work flow. How often do you use an apostrophe in your writing versus how often to you include quotes and need them in their typographic form. 

That is the way the program works. And this report is INVALID.

If you have additional feature in mind to adjust the autocorrect/edit engine to no make a replacement mid-word--write it up to be an enhancement.
Comment 7 severin.kunz 2019-09-30 14:22:07 UTC Comment hidden (no-value)
Comment 8 severin.kunz 2019-09-30 14:25:25 UTC
Literally no other software behaves like this, and the keyboard shows a ' and not a ‹, it's really hard to understand your reasoning.
Comment 9 severin.kunz 2019-09-30 14:26:06 UTC
At least it should not correct the issues I've mentioned.
Comment 10 V Stuart Foote 2019-09-30 14:33:41 UTC
OK, please write up an enhancement as to behavior you would like, understanding that the AutoCorrect behavior is the preferred way of getting single and double typographic quotes from keyboard to document canvas. And that a <ctrl>+Z revert of any autocorrection is considered reasonable UX by the project.
Comment 11 V Stuart Foote 2019-09-30 14:45:53 UTC
NEEDINFO to the OP...
Comment 12 Heiko Tietze 2019-10-01 06:57:02 UTC
Guillemets are the default quotation mark in Swiss. If you, for some reason, don't want to change the setting under Tools > AutoCorrect > Localized Options: Single Quotes, you could also switch the German locale (de_DE) where curved quotation marks are standard.

https://en.wikipedia.org/wiki/Quotation_mark