Bug 127900 - Frame language set in master ignored in slides created from that master
Summary: Frame language set in master ignored in slides created from that master
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All All
: medium normal
Assignee: Dániel Arató (NISZ)
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords: bibisected, bisected, regression
: 137864 (view as bug list)
Depends on:
Blocks: Master-Slide
  Show dependency treegraph
 
Reported: 2019-10-01 10:13 UTC by Mike Kaganski
Modified: 2021-11-11 18:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-10-01 10:13:17 UTC
Starting from https://git.libreoffice.org/core/+/40bb9ac690d979ef544d5aa759bd734a176912a0, setting a language to a frame in slide master, and creating a new slide based on that master, gives a frame with initial language.

1. Create a new blank presentation
2. Open Master Slides sidebar; right-click on the only one master displayed in "Used in This Presentation" (Default), and choose "Edit Master..."
3. In the opened master, right-click at the border of the main frame (where a sample outline is displayed), and choose "Character..."
4. In Character dialog, open Font tab, and choose Language to anything different (if Arabic/Asian scripts are enabled, it's enough to only change Western script language) -> OK
5. Menu View->Normal
6. Menu Slide->New Slide (Ctrl+M)
7. Check the language of the frame of the newly created slide (using procedure from steps 3-4)

Expected: the language should be same as set at step 4
Actual: the language is same as before step 4

Tested with Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

and current master toward 6.4
Comment 1 Xisco Faulí 2019-10-03 13:44:43 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: c9336bfb6bbf6d73d3f23c124262ade30133448d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Adding Cc: to Gülşah Köse
Comment 2 Commit Notification 2021-09-21 10:13:17 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ca5e344aec6a5848831101bc0d623b2bac754b6e

tdf#127900 sd: fix regression at applying master properties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2021-09-22 08:46:22 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/dbfb7940e4e6b0a1f136a6d109d0e6926617208f

tdf#127900 sd: fix regression at applying master properties

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 NISZ LibreOffice Team 2021-10-05 11:36:56 UTC
Verified in:
Comment 5 NISZ LibreOffice Team 2021-10-05 11:37:22 UTC
Verified in:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c2de581d1943df2d84f2b71817b6a8bee41f0217
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 6 Justin L 2021-11-11 18:38:57 UTC
*** Bug 137864 has been marked as a duplicate of this bug. ***