Bug 127968 - Shape's line width drop-down is empty for the first click.
Summary: Shape's line width drop-down is empty for the first click.
Status: RESOLVED DUPLICATE of bug 126388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-10-04 18:56 UTC by typingcat
Modified: 2019-10-04 21:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
When I clicked the Width drop-down for the first time for a shape. It is empty. Clicking it again for the same shape shows the width menu. (15.35 KB, image/png)
2019-10-04 18:57 UTC, typingcat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description typingcat 2019-10-04 18:56:07 UTC
Description:
In Draw or Writer, if I add a new shape like a line, and then in the Properties panel, click Line -> Width drop-down menu, the menu is empty. If I close the menu and click it again, then I can see the width values.

Steps to Reproduce:
1. Start Writer or Draw.
2. Insert a Line.
3. In the Properties -> Line, click the Width drop-down.

Actual Results:
Menu is empty.

Expected Results:
Menu shows widths.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I am using 200% DPI on a 4K monitor. If I disable OpenGL, the menu shows widths but heavily flickers.
Comment 1 typingcat 2019-10-04 18:57:25 UTC
Created attachment 154763 [details]
When I clicked the Width drop-down for the first time for a shape. It is empty. Clicking it again for the same shape shows the width menu.
Comment 2 m.a.riosv 2019-10-04 20:27:08 UTC
Please test changing 'Menu/Tools/Options/LibreOffice/View - OpenGL' option.

Happens for me with OpenGl enable, with it disable, flicking.
Version: 6.3.3.0.0+ (x64)
Build ID: cb14e82a823f313e3e1bedc83c60a5d575b1c89e
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-3, Time: 2019-10-01_07:29:14
Locale: es-ES (es_ES); UI-Language: en-US Calc: 
Version: 6.4.0.0.alpha0+ (x64)
Build ID: d744838991594eebe27acc4c7d9fb4579d654853
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-29_05:12:00
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded

Works fine, with and without OpenGL
Version: 6.2.8.1 (x64)
Build ID: 815fe723fb0e60e4a39ff860f907cc63980a0232
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 3 V Stuart Foote 2019-10-04 20:48:04 UTC
Not clear if this is a manifestation on OpenGL Rendering of the RenderContext() issues affecting default GDI rendering (bug 91488)

But with OpenGL Rendering enabled confirm the empty list.

Bug 127676 to correct default GDI rendering was just patched with

https://git.libreoffice.org/core/commit/25cc6dcef22e51c1bfa01e8fbed5046439bb1428 

that may have improved the OpenGL rendering. Please test a current nightly dev build.

https://dev-builds.libreoffice.org/daily/master/
Comment 4 V Stuart Foote 2019-10-04 21:24:54 UTC
Nope, no improvement with patch for bug 127676

Windows 10 Ent 64-bit en-US (1903) with 
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 489eef894e7034873ad262f9dfca554022db1b09
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-10-01_23:43:38
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

*** This bug has been marked as a duplicate of bug 126388 ***