Bug 126388 - OpenGL: Empty drop-down list Line Width in Sidebar when open it first time after drawing of line with arrow
Summary: OpenGL: Empty drop-down list Line Width in Sidebar when open it first time af...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 127968 130901 (view as bug list)
Depends on:
Blocks: Sidebar-Properties-Line VCL-OpenGL
  Show dependency treegraph
 
Reported: 2019-07-14 14:43 UTC by Roman Kuznetsov
Modified: 2020-08-28 13:58 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (43.49 KB, image/png)
2019-07-14 14:44 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-14 14:43:03 UTC
Description:
OpenGL: Empty drop-down list Line Width in Sidebar when open it first time after drawing of line with arrow

Steps to Reproduce:
1. Open Draw (make sure OpenGL enabled)
2. Drawing Line with arrow
3. Try open drop-down list Line Width in Line section in Sidebar => it's empty
4. Click on page
5. Try open drop-down list Line Width in Line section in Sidebar else one => it works fine

Every time as you drawing a line that drop-down list is empty when you open it at once after drawing a line

Actual Results:
drop-down list Line Width in Line section in Sidebar is empty

Expected Results:
drop-down list Line Width in Line section in Sidebar looks fine


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.3.0.1 (x64)
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-07-14 14:44:09 UTC
Created attachment 152765 [details]
Screenshot

If OpenGL is disabled then that control works fine
Comment 2 Roman Kuznetsov 2019-07-14 14:46:13 UTC
don't repro in 6.2.2.1 => regression
Comment 3 Telesto 2019-07-15 12:50:44 UTC
Repro
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-10_00:49:53
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 4 Luke 2019-07-15 17:08:03 UTC
This doesn't just affect OpenGL. If you disable OpenGL, the same drop-down will flash and spike CPU usage in Windows.
Comment 5 Roman Kuznetsov 2019-07-15 18:20:03 UTC
I bisected it

asus@notebook-2 /cygdrive/c/logit/bibisect-win32-6.3
$ git bisect good
042a2ef692f5a43bf0074f4ecef16a7cba12627e is the first bad commit
commit 042a2ef692f5a43bf0074f4ecef16a7cba12627e
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 29 17:34:15 2018 -0800

    source sha:8ea1bdce62880448a42bcc4a283308bdccebb2cf

https://gerrit.libreoffice.org/#/c/63827/

Added to CC: Mike Kaganski
Comment 6 Xisco Faulí 2019-09-27 17:19:30 UTC
Hi Roman,
Could you please recheck this issue after https://git.libreoffice.org/core/commit/25cc6dcef22e51c1bfa01e8fbed5046439bb1428
Comment 7 Roman Kuznetsov 2019-09-28 08:00:10 UTC
(In reply to Xisco Faulí from comment #6)
> Hi Roman,
> Could you please recheck this issue after
> https://git.libreoffice.org/core/commit/
> 25cc6dcef22e51c1bfa01e8fbed5046439bb1428

no effect, problem still here (my problem is empty drop-down list with enabled OpenGL, but not flickering with disabled OpenGL)

Версия: 6.4.0.0.alpha0+ (x64)
ID сборки: 24c7c12224f1c1d66f335f6fe085595352137646
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-28_01:32:49
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 8 V Stuart Foote 2019-10-04 21:24:54 UTC
*** Bug 127968 has been marked as a duplicate of this bug. ***
Comment 9 Roman Kuznetsov 2020-02-25 16:45:41 UTC
*** Bug 130901 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2020-08-28 12:20:52 UTC
As Skia with Vulkan will replace OpenGL UI rendering on all platforms, it does not make sense to keep OpenGL UI reports open.

Details about Skia: https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/
Comment 11 Telesto 2020-08-28 13:58:02 UTC
Looks indeed OK with skia
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL