Bug 127998 - Anchor system behaves strangely with eps format
Summary: Anchor system behaves strangely with eps format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2019-10-07 11:59 UTC by Pierre Colombier
Modified: 2019-11-19 16:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
here is the vim project logo (11.75 KB, application/postscript)
2019-10-13 20:01 UTC, V Stuart Foote
Details
here is the xpost project logo (2.98 KB, application/postscript)
2019-10-13 20:02 UTC, V Stuart Foote
Details
Screenshot that shows the bug (273.14 KB, image/jpeg)
2019-10-14 07:17 UTC, Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Colombier 2019-10-07 11:59:13 UTC
Description:
When I import an image in eps format 

The Anchor system seems to always locate the anchor a few lines above the 
requested area.

When using anchor as caracter => Rotation does not update the box ratio.

Workaround : convert eps to png with imagemagick. LibreOffice seems to process png data nicely.


Steps to Reproduce:
1.go to step 4 if you have an .eps image 
2.get some postscript data (virtual printer) 
3.convert to eps (did it with linux tool ps2eps v1.68.
4.import eps file as image in a writer document
5.rotate, zoom, play with the anchor system : the problem shoud be obvious.

Actual Results:

The Anchor system seems to always locate the anchor a few lines above the 
requested area.

When using anchor as caracter => Rotation does not update the box ratio.

Expected Results:
Same behaviour as if the image data was in the png format 
exemple that worked for me 
convert -density 300 -rotate 90 file.eps file.png
import the png file instead of the eps file.



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.5.2
Build ID: 1:6.1.5-3
Threads CPU : 8; OS : Linux 4.19; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.utf8); Calc: group threadedp


OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 410.104
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 410.104
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 410.104
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
Comment 1 Dieter 2019-10-13 05:23:11 UTC
Pierre, thank you for reporting the bug. Could you please attach an eps-image, because that makes it easier to follow your steps.
Comment 2 V Stuart Foote 2019-10-13 20:01:33 UTC
Created attachment 154976 [details]
here is the vim project logo
Comment 3 V Stuart Foote 2019-10-13 20:02:07 UTC
Created attachment 154977 [details]
here is the xpost project logo
Comment 4 Dieter 2019-10-14 07:17:04 UTC
Created attachment 154986 [details]
Screenshot that shows the bug

Image is not displayed (that might be another issue), but I could reproduce the bug usaing attachment 154977 [details] with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 460908269972fd1f89312a1e62897ed1503e9e98
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-30_09:18:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-10-23 11:39:41 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-10-23 11:40:16 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2019-10-23 11:52:53 UTC
so it seems a regression,(In reply to Dieter Praas from comment #4)
> Created attachment 154986 [details]
> Screenshot that shows the bug
> 
> Image is not displayed (that might be another issue), but I could reproduce
> the bug usaing attachment 154977 [details] with

Reported in bug 128340
Comment 8 Xisco Faulí 2019-10-23 12:02:18 UTC
and by the way, i don't see the eps on windows either, but that is more bug 67464
Comment 9 Xisco Faulí 2019-10-23 12:11:26 UTC
it seems the anchor problem was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f40bf6a79de6d60da0a5090cdfeda6242e889f0

Closing as RESOLVED FIXED