Bug 128340 - EPS image vanishes while being rotated
Summary: EPS image vanishes while being rotated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2019-10-23 11:51 UTC by Xisco Faulí
Modified: 2021-10-25 08:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-10-23 11:51:24 UTC
Steps to reproduce:
1. Open a a new writer file
2. Insert attachment 154977 [details] from bug 127998
3. Select the image and using the sidebar, rotate it

-> The image vanishes depending on the rotate angle

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 437dc68285dab0f08a1ded2193d86d64f560cd9b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-10-23 11:54:59 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9fa01a8d1137a95af9865a3e47995734c40da6e

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-24 13:01:08 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-30 19:48:46 +0200
commit b9fa01a8d1137a95af9865a3e47995734c40da6e (patch)
tree 6d1e0a3e44b1a96fe5302d779c00fbee55cf8d24
parent f4a9ce33415a85d0b86ced3a0bf780f4ec61e25f (diff)
Support buffering SystemDependent GraphicData

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 2 V Stuart Foote 2019-10-23 12:18:17 UTC
There are 3 methods in the ieps filter. Both the gs and gs/imagmagik 'convert' import bring in BMP.  The thrid, using gs/pstoedit will bring in an EMF

On Windows 10 Home 64-bit en-US (1903) with
Version: 6.4.0.0.alpha1+ (x64)
Build ID: 546e6c359e96a2e7f5aab7c158c7e843be6c8957
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default or GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

With Windows builds both BMP imports rotate with no issue.  The pstoedit based EMF rotation loses portions of the image depending on the rotation angle.
 
Since the BMP seem OK, is this an issue with EPS or with the EMF as imported?

I didn't check rotation on export out to PDF or printing (gs or Windows printing) but could be issues there as well.
Comment 3 QA Administrators 2021-10-23 03:44:58 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2021-10-24 15:06:25 UTC
no repro in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: f8bb970fd385c80b085a071da0f8acc119498005
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

Only Linux problem?
Comment 5 Xisco Faulí 2021-10-25 08:09:36 UTC
issue fixed in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: d05c69a892535b910943fe98fbce42f5cc860aa4
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and

Version: 7.0.0.0.alpha1+
Build ID: 574c57090642347980d2395e1e183cc7b5c171ad
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: ar-DZ (en_US.UTF-8); UI: en-US
Calc: threaded

Closing as RESOLVED WORKSFORME