Download it now!
Bug 128009 - AutoText: entries with spaces near beginning of name are not suggested in "Display remainder of name as suggestion while typing" mode
Summary: AutoText: entries with spaces near beginning of name are not suggested in "Di...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: AutoText
  Show dependency treegraph
 
Reported: 2019-10-08 05:20 UTC by Mike Kaganski
Modified: 2019-10-14 12:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-10-08 05:20:33 UTC
When '[x] Display remainder of name as suggestion while typing' is enabled under Tools->AutoText..., tooltips are shown when typing at least 3 characters of words which start the long names of autotext entries [1]. E.g., typing "lor" would bring "Lorem Ipsum" suggestion.

However, the suggestion is only limited to preceding characters os a single word: after you type a space, typing following characters of second word of an AutoText entry name will not bring that entry suggestion. This disallows using entries like "Mr Smith" or "Dr Brown", where starting word is only two character long.

To reproduce:
1. Add a new AutoText entry
1.1. In a blank text document, type "Mr Smith, The Greatest Agent Of All Times"
1.2. Select all, and open AutoText dialog (Tools->AutoText... (Ctrl+F3))
1.3. Put "Mr Smith" to the Name box; click AutoText button, and select "New" in the drop-down menu
1.4. Make sure "[x] Display remainder of name as suggestion while typing" is checked
1.5. Close the dialog
2. Use the entry when typing text
2.1. In a new text document, start typing "lor" to make sure you see the "Lorem Ipsum" tooltip; when it's shown, Enter would replace the typed characters with the lorem ipsum autotext; so the feature is working as intended.
2.2. Try typing "dr smi", and see that the "Dr Smith" entry is not suggested.

The request is to support also such AutoText entries in the suggestions. This works e.g. in MS Word.

[1] https://help.libreoffice.org/6.3/en-US/text/swriter/01/02120000.html
Comment 1 Mike Kaganski 2019-10-08 05:21:00 UTC
https://gerrit.libreoffice.org/80392
Comment 2 Commit Notification 2019-10-08 12:31:37 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ef2ec07b4113fdadf863352c832af657b5ae205c

tdf#128009: Allow spaces in AutoText suggestions

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.